aboutsummaryrefslogtreecommitdiff
path: root/src/auction/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/auction/Makefile.am')
-rw-r--r--src/auction/Makefile.am37
1 files changed, 22 insertions, 15 deletions
diff --git a/src/auction/Makefile.am b/src/auction/Makefile.am
index 8518244fa..0c250a0b4 100644
--- a/src/auction/Makefile.am
+++ b/src/auction/Makefile.am
@@ -5,6 +5,7 @@ pkgcfgdir= $(pkgdatadir)/config.d/
5 5
6libexecdir= $(pkglibdir)/libexec/ 6libexecdir= $(pkglibdir)/libexec/
7 7
8
8dist_pkgcfg_DATA = \ 9dist_pkgcfg_DATA = \
9 auction.conf 10 auction.conf
10 11
@@ -16,13 +17,22 @@ if USE_COVERAGE
16 AM_CFLAGS = -fprofile-arcs -ftest-coverage 17 AM_CFLAGS = -fprofile-arcs -ftest-coverage
17endif 18endif
18 19
19# use bin_PROGRAMS for gnunet-auction wrapper script
20 20
21libexec_PROGRAMS = \ 21libexec_PROGRAMS = \
22 gnunet-service-auction
23
24gnunet_service_auction_SOURCES = \
25 gnunet-service-auction.c
26gnunet_service_auction_LDADD = \
27 $(top_builddir)/src/util/libgnunetutil.la \
28 -ljansson \
29 $(GN_LIBINTL)
30
31
32bin_PROGRAMS = \
22 gnunet-auction-create \ 33 gnunet-auction-create \
23 gnunet-auction-info \ 34 gnunet-auction-info \
24 gnunet-auction-join \ 35 gnunet-auction-join
25 gnunet-service-auction
26 36
27gnunet_auction_create_SOURCES = \ 37gnunet_auction_create_SOURCES = \
28 gnunet-auction-create.c 38 gnunet-auction-create.c
@@ -45,23 +55,20 @@ gnunet_auction_join_LDADD = \
45 -ljansson \ 55 -ljansson \
46 $(GN_LIBINTL) 56 $(GN_LIBINTL)
47 57
48gnunet_service_auction_SOURCES = \
49 gnunet-service-auction.c
50gnunet_service_auction_LDADD = \
51 $(top_builddir)/src/util/libgnunetutil.la \
52 -ljansson \
53 $(GN_LIBINTL)
54
55 58
56check_PROGRAMS = \ 59check_PROGRAMS = \
57 test_auction_api 60 test_auction_api
58 61
59if ENABLE_TEST_RUN
60AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
61TESTS = $(check_PROGRAMS)
62endif
63
64test_auction_api_SOURCES = \ 62test_auction_api_SOURCES = \
65 test_auction_api.c 63 test_auction_api.c
66test_auction_api_LDADD = \ 64test_auction_api_LDADD = \
67 $(top_builddir)/src/util/libgnunetutil.la 65 $(top_builddir)/src/util/libgnunetutil.la
66
67
68check_SCRIPTS = \
69 test_auction_create.sh
70
71if ENABLE_TEST_RUN
72AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
73TESTS = $(check_PROGRAMS) $(check_SCRIPTS)
74endif