aboutsummaryrefslogtreecommitdiff
path: root/src/auction/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/auction/Makefile.am')
-rw-r--r--src/auction/Makefile.am74
1 files changed, 74 insertions, 0 deletions
diff --git a/src/auction/Makefile.am b/src/auction/Makefile.am
new file mode 100644
index 000000000..87f917283
--- /dev/null
+++ b/src/auction/Makefile.am
@@ -0,0 +1,74 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgcfgdir= $(pkgdatadir)/config.d/
5
6libexecdir= $(pkglibdir)/libexec/
7
8
9pkgcfg_DATA = \
10 auction.conf
11
12if MINGW
13 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
14endif
15
16if USE_COVERAGE
17 AM_CFLAGS = -fprofile-arcs -ftest-coverage
18endif
19
20
21libexec_PROGRAMS = \
22 gnunet-service-auction
23
24gnunet_service_auction_SOURCES = \
25 gnunet-service-auction.c
26gnunet_service_auction_LDADD = \
27 $(top_builddir)/src/util/libgnunetutil.la \
28 -ljansson \
29 $(GN_LIBINTL)
30
31
32bin_PROGRAMS = \
33 gnunet-auction-create \
34 gnunet-auction-info \
35 gnunet-auction-join
36
37gnunet_auction_create_SOURCES = \
38 gnunet-auction-create.c
39gnunet_auction_create_LDADD = \
40 $(top_builddir)/src/util/libgnunetutil.la \
41 -ljansson \
42 $(GN_LIBINTL)
43
44gnunet_auction_info_SOURCES = \
45 gnunet-auction-info.c
46gnunet_auction_info_LDADD = \
47 $(top_builddir)/src/util/libgnunetutil.la \
48 -ljansson \
49 $(GN_LIBINTL)
50
51gnunet_auction_join_SOURCES = \
52 gnunet-auction-join.c
53gnunet_auction_join_LDADD = \
54 $(top_builddir)/src/util/libgnunetutil.la \
55 -ljansson \
56 $(GN_LIBINTL)
57
58
59check_PROGRAMS = \
60 test_auction_api
61
62test_auction_api_SOURCES = \
63 test_auction_api.c
64test_auction_api_LDADD = \
65 $(top_builddir)/src/util/libgnunetutil.la
66
67
68check_SCRIPTS = \
69 test_auction_create.sh
70
71if ENABLE_TEST_RUN
72AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
73TESTS = $(check_PROGRAMS) $(check_SCRIPTS)
74endif