aboutsummaryrefslogtreecommitdiff
path: root/src/chat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/chat/Makefile.am')
-rw-r--r--src/chat/Makefile.am82
1 files changed, 82 insertions, 0 deletions
diff --git a/src/chat/Makefile.am b/src/chat/Makefile.am
index ad099e6b1..f10796c23 100644
--- a/src/chat/Makefile.am
+++ b/src/chat/Makefile.am
@@ -37,3 +37,85 @@ gnunet_chat_LDADD = \
37 $(top_builddir)/src/chat/libgnunetchat.la \ 37 $(top_builddir)/src/chat/libgnunetchat.la \
38 $(top_builddir)/src/util/libgnunetutil.la \ 38 $(top_builddir)/src/util/libgnunetutil.la \
39 $(GN_LIBINTL) 39 $(GN_LIBINTL)
40
41check_PROGRAMS = \
42 test_chat \
43 test_chat_acknowledgement \
44 test_chat_anonymous \
45 test_chat_authentication \
46 test_chat_p2p \
47 test_chat_acknowledgement_p2p \
48 test_chat_anonymous_p2p \
49 test_chat_authentication_p2p \
50 test_chat_private \
51 test_chat_private_p2p
52
53if !DISABLE_TEST_RUN
54TESTS = $(check_PROGRAMS)
55endif
56
57test_chat_SOURCES = \
58 test_chat.c
59test_chat_LDADD = \
60 $(top_builddir)/src/chat/libgnunetchat.la \
61 $(top_builddir)/src/util/libgnunetutil.la
62
63test_chat_acknowledgement_SOURCES = \
64 test_chat.c
65test_chat_acknowledgement_LDADD = \
66 $(top_builddir)/src/chat/libgnunetchat.la \
67 $(top_builddir)/src/util/libgnunetutil.la
68
69test_chat_anonymous_SOURCES = \
70 test_chat.c
71test_chat_anonymous_LDADD = \
72 $(top_builddir)/src/chat/libgnunetchat.la \
73 $(top_builddir)/src/util/libgnunetutil.la
74
75test_chat_authentication_SOURCES = \
76 test_chat.c
77test_chat_authentication_LDADD = \
78 $(top_builddir)/src/chat/libgnunetchat.la \
79 $(top_builddir)/src/util/libgnunetutil.la
80
81test_chat_p2p_SOURCES = \
82 test_chat.c
83test_chat_p2p_LDADD = \
84 $(top_builddir)/src/chat/libgnunetchat.la \
85 $(top_builddir)/src/util/libgnunetutil.la
86
87test_chat_acknowledgement_p2p_SOURCES = \
88 test_chat.c
89test_chat_acknowledgement_p2p_LDADD = \
90 $(top_builddir)/src/chat/libgnunetchat.la \
91 $(top_builddir)/src/util/libgnunetutil.la
92
93test_chat_anonymous_p2p_SOURCES = \
94 test_chat.c
95test_chat_anonymous_p2p_LDADD = \
96 $(top_builddir)/src/chat/libgnunetchat.la \
97 $(top_builddir)/src/util/libgnunetutil.la
98
99test_chat_authentication_p2p_SOURCES = \
100 test_chat.c
101test_chat_authentication_p2p_LDADD = \
102 $(top_builddir)/src/chat/libgnunetchat.la \
103 $(top_builddir)/src/util/libgnunetutil.la
104
105test_chat_private_SOURCES = \
106 test_chat_private.c
107test_chat_private_LDADD = \
108 $(top_builddir)/src/chat/libgnunetchat.la \
109 $(top_builddir)/src/util/libgnunetutil.la
110
111test_chat_private_p2p_SOURCES = \
112 test_chat_private.c
113test_chat_private_p2p_LDADD = \
114 $(top_builddir)/src/chat/libgnunetchat.la \
115 $(top_builddir)/src/util/libgnunetutil.la
116
117EXTRA_DIST = \
118 test_chat_data.conf \
119 test_chat_peer1.conf \
120 test_chat_peer2.conf \
121 test_chat_peer3.conf