aboutsummaryrefslogtreecommitdiff
path: root/src/conversation/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/conversation/Makefile.am')
-rw-r--r--src/conversation/Makefile.am42
1 files changed, 21 insertions, 21 deletions
diff --git a/src/conversation/Makefile.am b/src/conversation/Makefile.am
index 0f99a6526..0b8a34d36 100644
--- a/src/conversation/Makefile.am
+++ b/src/conversation/Makefile.am
@@ -41,7 +41,7 @@ plugin_LTLIBRARIES = \
41libgnunet_plugin_gnsrecord_conversation_la_SOURCES = \ 41libgnunet_plugin_gnsrecord_conversation_la_SOURCES = \
42 plugin_gnsrecord_conversation.c 42 plugin_gnsrecord_conversation.c
43libgnunet_plugin_gnsrecord_conversation_la_LIBADD = \ 43libgnunet_plugin_gnsrecord_conversation_la_LIBADD = \
44 $(top_builddir)/src/util/libgnunetutil.la \ 44 $(top_builddir)/src/lib/util/libgnunetutil.la \
45 $(LTLIBINTL) 45 $(LTLIBINTL)
46libgnunet_plugin_gnsrecord_conversation_la_LDFLAGS = \ 46libgnunet_plugin_gnsrecord_conversation_la_LDFLAGS = \
47 $(GN_PLUGIN_LDFLAGS) 47 $(GN_PLUGIN_LDFLAGS)
@@ -50,7 +50,7 @@ libgnunet_plugin_gnsrecord_conversation_la_LDFLAGS = \
50libgnunetmicrophone_la_SOURCES = \ 50libgnunetmicrophone_la_SOURCES = \
51 microphone.c 51 microphone.c
52libgnunetmicrophone_la_LIBADD = \ 52libgnunetmicrophone_la_LIBADD = \
53 $(top_builddir)/src/util/libgnunetutil.la 53 $(top_builddir)/src/lib/util/libgnunetutil.la
54libgnunetmicrophone_la_LDFLAGS = \ 54libgnunetmicrophone_la_LDFLAGS = \
55 $(GN_LIB_LDFLAGS) \ 55 $(GN_LIB_LDFLAGS) \
56 -version-info 0:0:0 56 -version-info 0:0:0
@@ -58,7 +58,7 @@ libgnunetmicrophone_la_LDFLAGS = \
58libgnunetspeaker_la_SOURCES = \ 58libgnunetspeaker_la_SOURCES = \
59 speaker.c 59 speaker.c
60libgnunetspeaker_la_LIBADD = \ 60libgnunetspeaker_la_LIBADD = \
61 $(top_builddir)/src/util/libgnunetutil.la 61 $(top_builddir)/src/lib/util/libgnunetutil.la
62libgnunetspeaker_la_LDFLAGS = \ 62libgnunetspeaker_la_LDFLAGS = \
63 $(GN_LIB_LDFLAGS) \ 63 $(GN_LIB_LDFLAGS) \
64 -version-info 0:0:0 64 -version-info 0:0:0
@@ -70,10 +70,10 @@ libgnunetconversation_la_SOURCES = \
70 conversation.h 70 conversation.h
71libgnunetconversation_la_LIBADD = \ 71libgnunetconversation_la_LIBADD = \
72 $(top_builddir)/src/gns/libgnunetgns.la \ 72 $(top_builddir)/src/gns/libgnunetgns.la \
73 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 73 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
74 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 74 $(top_builddir)/src/namestore/libgnunetnamestore.la \
75 $(top_builddir)/src/identity/libgnunetidentity.la \ 75 $(top_builddir)/src/identity/libgnunetidentity.la \
76 $(top_builddir)/src/util/libgnunetutil.la 76 $(top_builddir)/src/lib/util/libgnunetutil.la
77 77
78libgnunetconversation_la_LDFLAGS = \ 78libgnunetconversation_la_LDFLAGS = \
79 $(GN_LIB_LDFLAGS) \ 79 $(GN_LIB_LDFLAGS) \
@@ -113,7 +113,7 @@ if BUILD_PULSE_HELPERS
113gnunet_helper_audio_record_SOURCES = \ 113gnunet_helper_audio_record_SOURCES = \
114 gnunet-helper-audio-record.c 114 gnunet-helper-audio-record.c
115gnunet_helper_audio_record_LDADD = \ 115gnunet_helper_audio_record_LDADD = \
116 $(top_builddir)/src/util/libgnunetutil.la \ 116 $(top_builddir)/src/lib/util/libgnunetutil.la \
117 -lpulse -lopus -logg \ 117 -lpulse -lopus -logg \
118 $(INTLLIBS) 118 $(INTLLIBS)
119#gnunet_helper_audio_record_LDFLAGS = \ 119#gnunet_helper_audio_record_LDFLAGS = \
@@ -122,7 +122,7 @@ gnunet_helper_audio_record_LDADD = \
122gnunet_helper_audio_playback_SOURCES = \ 122gnunet_helper_audio_playback_SOURCES = \
123 gnunet-helper-audio-playback.c 123 gnunet-helper-audio-playback.c
124gnunet_helper_audio_playback_LDADD = \ 124gnunet_helper_audio_playback_LDADD = \
125 $(top_builddir)/src/util/libgnunetutil.la \ 125 $(top_builddir)/src/lib/util/libgnunetutil.la \
126 -lpulse -lopus -logg \ 126 -lpulse -lopus -logg \
127 $(INTLLIBS) 127 $(INTLLIBS)
128#gnunet_helper_audio_playback_LDFLAGS = \ 128#gnunet_helper_audio_playback_LDFLAGS = \
@@ -132,7 +132,7 @@ if BUILD_GST_HELPERS
132gnunet_helper_audio_record_SOURCES = \ 132gnunet_helper_audio_record_SOURCES = \
133 gnunet-helper-audio-record-gst.c 133 gnunet-helper-audio-record-gst.c
134gnunet_helper_audio_record_LDADD = \ 134gnunet_helper_audio_record_LDADD = \
135 $(top_builddir)/src/util/libgnunetutil.la \ 135 $(top_builddir)/src/lib/util/libgnunetutil.la \
136 $(GST_LIBS) \ 136 $(GST_LIBS) \
137 $(INTLLIBS) 137 $(INTLLIBS)
138gnunet_helper_audio_record_LDFLAGS = \ 138gnunet_helper_audio_record_LDFLAGS = \
@@ -143,7 +143,7 @@ gnunet_helper_audio_record_CFLAGS = \
143gnunet_helper_audio_playback_SOURCES = \ 143gnunet_helper_audio_playback_SOURCES = \
144 gnunet-helper-audio-playback-gst.c 144 gnunet-helper-audio-playback-gst.c
145gnunet_helper_audio_playback_LDADD = \ 145gnunet_helper_audio_playback_LDADD = \
146 $(top_builddir)/src/util/libgnunetutil.la \ 146 $(top_builddir)/src/lib/util/libgnunetutil.la \
147 $(GST_LIBS) \ 147 $(GST_LIBS) \
148 $(INTLLIBS) 148 $(INTLLIBS)
149gnunet_helper_audio_playback_LDFLAGS = \ 149gnunet_helper_audio_playback_LDFLAGS = \
@@ -155,7 +155,7 @@ if BUILD_EXPERIMENTAL_HELPERS
155gnunet_helper_audio_record_SOURCES = \ 155gnunet_helper_audio_record_SOURCES = \
156 gnunet_gst_test.c gnunet_gst.c 156 gnunet_gst_test.c gnunet_gst.c
157gnunet_helper_audio_record_LDADD = \ 157gnunet_helper_audio_record_LDADD = \
158 $(top_builddir)/src/util/libgnunetutil.la \ 158 $(top_builddir)/src/lib/util/libgnunetutil.la \
159 $(GST_LIBS) \ 159 $(GST_LIBS) \
160 $(INTLLIBS) 160 $(INTLLIBS)
161gnunet_helper_audio_record_LDFLAGS = \ 161gnunet_helper_audio_record_LDFLAGS = \
@@ -166,7 +166,7 @@ gnunet_helper_audio_record_CFLAGS = \
166gnunet_helper_audio_playback_SOURCES = \ 166gnunet_helper_audio_playback_SOURCES = \
167 gnunet_gst_test.c gnunet_gst.c 167 gnunet_gst_test.c gnunet_gst.c
168gnunet_helper_audio_playback_LDADD = \ 168gnunet_helper_audio_playback_LDADD = \
169 $(top_builddir)/src/util/libgnunetutil.la \ 169 $(top_builddir)/src/lib/util/libgnunetutil.la \
170 $(GST_LIBS) \ 170 $(GST_LIBS) \
171 $(INTLLIBS) 171 $(INTLLIBS)
172gnunet_helper_audio_playback_LDFLAGS = \ 172gnunet_helper_audio_playback_LDFLAGS = \
@@ -184,7 +184,7 @@ gnunet_service_conversation_LDADD = \
184 libgnunetspeaker.la \ 184 libgnunetspeaker.la \
185 libgnunetmicrophone.la \ 185 libgnunetmicrophone.la \
186 $(top_builddir)/src/cadet/libgnunetcadet.la \ 186 $(top_builddir)/src/cadet/libgnunetcadet.la \
187 $(top_builddir)/src/util/libgnunetutil.la \ 187 $(top_builddir)/src/lib/util/libgnunetutil.la \
188 $(top_builddir)/src/identity/libgnunetidentity.la \ 188 $(top_builddir)/src/identity/libgnunetidentity.la \
189 $(INTLLIBS) 189 $(INTLLIBS)
190#gnunet_service_conversation_LDFLAGS = \ 190#gnunet_service_conversation_LDFLAGS = \
@@ -197,10 +197,10 @@ gnunet_conversation_LDADD = \
197 libgnunetspeaker.la \ 197 libgnunetspeaker.la \
198 libgnunetconversation.la \ 198 libgnunetconversation.la \
199 $(top_builddir)/src/gns/libgnunetgns.la \ 199 $(top_builddir)/src/gns/libgnunetgns.la \
200 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 200 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
201 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 201 $(top_builddir)/src/namestore/libgnunetnamestore.la \
202 $(top_builddir)/src/identity/libgnunetidentity.la \ 202 $(top_builddir)/src/identity/libgnunetidentity.la \
203 $(top_builddir)/src/util/libgnunetutil.la \ 203 $(top_builddir)/src/lib/util/libgnunetutil.la \
204 $(INTLLIBS) 204 $(INTLLIBS)
205#gnunet_conversation_LDFLAGS = \ 205#gnunet_conversation_LDFLAGS = \
206# 206#
@@ -210,7 +210,7 @@ gnunet_conversation_test_SOURCES = \
210gnunet_conversation_test_LDADD = \ 210gnunet_conversation_test_LDADD = \
211 libgnunetmicrophone.la \ 211 libgnunetmicrophone.la \
212 libgnunetspeaker.la \ 212 libgnunetspeaker.la \
213 $(top_builddir)/src/util/libgnunetutil.la \ 213 $(top_builddir)/src/lib/util/libgnunetutil.la \
214 $(INTLLIBS) 214 $(INTLLIBS)
215#gnunet_conversation_test_LDFLAGS = \ 215#gnunet_conversation_test_LDFLAGS = \
216# 216#
@@ -222,11 +222,11 @@ test_conversation_api_LDADD = \
222 libgnunetconversation.la \ 222 libgnunetconversation.la \
223 libgnunetspeaker.la \ 223 libgnunetspeaker.la \
224 libgnunetmicrophone.la \ 224 libgnunetmicrophone.la \
225 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 225 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
226 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 226 $(top_builddir)/src/namestore/libgnunetnamestore.la \
227 $(top_builddir)/src/identity/libgnunetidentity.la \ 227 $(top_builddir)/src/identity/libgnunetidentity.la \
228 $(top_builddir)/src/testing/libgnunettesting.la \ 228 $(top_builddir)/src/testing/libgnunettesting.la \
229 $(top_builddir)/src/util/libgnunetutil.la 229 $(top_builddir)/src/lib/util/libgnunetutil.la
230test_conversation_api_LDFLAGS = \ 230test_conversation_api_LDFLAGS = \
231 -export-dynamic 231 -export-dynamic
232 232
@@ -236,11 +236,11 @@ test_conversation_api_twocalls_LDADD = \
236 libgnunetconversation.la \ 236 libgnunetconversation.la \
237 libgnunetspeaker.la \ 237 libgnunetspeaker.la \
238 libgnunetmicrophone.la \ 238 libgnunetmicrophone.la \
239 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 239 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
240 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 240 $(top_builddir)/src/namestore/libgnunetnamestore.la \
241 $(top_builddir)/src/identity/libgnunetidentity.la \ 241 $(top_builddir)/src/identity/libgnunetidentity.la \
242 $(top_builddir)/src/testing/libgnunettesting.la \ 242 $(top_builddir)/src/testing/libgnunettesting.la \
243 $(top_builddir)/src/util/libgnunetutil.la 243 $(top_builddir)/src/lib/util/libgnunetutil.la
244test_conversation_api_twocalls_LDFLAGS = \ 244test_conversation_api_twocalls_LDFLAGS = \
245 -export-dynamic 245 -export-dynamic
246 246
@@ -250,11 +250,11 @@ test_conversation_api_reject_LDADD = \
250 libgnunetconversation.la \ 250 libgnunetconversation.la \
251 libgnunetspeaker.la \ 251 libgnunetspeaker.la \
252 libgnunetmicrophone.la \ 252 libgnunetmicrophone.la \
253 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 253 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
254 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 254 $(top_builddir)/src/namestore/libgnunetnamestore.la \
255 $(top_builddir)/src/identity/libgnunetidentity.la \ 255 $(top_builddir)/src/identity/libgnunetidentity.la \
256 $(top_builddir)/src/testing/libgnunettesting.la \ 256 $(top_builddir)/src/testing/libgnunettesting.la \
257 $(top_builddir)/src/util/libgnunetutil.la 257 $(top_builddir)/src/lib/util/libgnunetutil.la
258test_conversation_api_reject_LDFLAGS = \ 258test_conversation_api_reject_LDFLAGS = \
259 -export-dynamic 259 -export-dynamic
260 260