aboutsummaryrefslogtreecommitdiff
path: root/src/datastore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/datastore/Makefile.am')
-rw-r--r--src/datastore/Makefile.am44
1 files changed, 22 insertions, 22 deletions
diff --git a/src/datastore/Makefile.am b/src/datastore/Makefile.am
index 595c7da3d..e8ede4b3e 100644
--- a/src/datastore/Makefile.am
+++ b/src/datastore/Makefile.am
@@ -29,7 +29,7 @@ libgnunetdatastore_la_SOURCES = \
29 datastore_api.c datastore.h 29 datastore_api.c datastore.h
30libgnunetdatastore_la_LIBADD = \ 30libgnunetdatastore_la_LIBADD = \
31 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 31 $(top_builddir)/src/statistics/libgnunetstatistics.la \
32 $(top_builddir)/src/util/libgnunetutil.la \ 32 $(top_builddir)/src/lib/util/libgnunetutil.la \
33 $(GN_LIBINTL) 33 $(GN_LIBINTL)
34libgnunetdatastore_la_LDFLAGS = \ 34libgnunetdatastore_la_LDFLAGS = \
35 $(GN_LIB_LDFLAGS) \ 35 $(GN_LIB_LDFLAGS) \
@@ -45,14 +45,14 @@ gnunet_service_datastore_SOURCES = \
45 gnunet-service-datastore.c 45 gnunet-service-datastore.c
46gnunet_service_datastore_LDADD = \ 46gnunet_service_datastore_LDADD = \
47 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 47 $(top_builddir)/src/statistics/libgnunetstatistics.la \
48 $(top_builddir)/src/util/libgnunetutil.la \ 48 $(top_builddir)/src/lib/util/libgnunetutil.la \
49 $(GN_LIBINTL) 49 $(GN_LIBINTL)
50 50
51gnunet_datastore_SOURCES = \ 51gnunet_datastore_SOURCES = \
52 gnunet-datastore.c 52 gnunet-datastore.c
53gnunet_datastore_LDADD = \ 53gnunet_datastore_LDADD = \
54 libgnunetdatastore.la \ 54 libgnunetdatastore.la \
55 $(top_builddir)/src/util/libgnunetutil.la \ 55 $(top_builddir)/src/lib/util/libgnunetutil.la \
56 $(GN_LIBINTL) 56 $(GN_LIBINTL)
57 57
58 58
@@ -99,7 +99,7 @@ libgnunet_plugin_datastore_sqlite_la_SOURCES = \
99libgnunet_plugin_datastore_sqlite_la_LIBADD = \ 99libgnunet_plugin_datastore_sqlite_la_LIBADD = \
100 $(top_builddir)/src/sq/libgnunetsq.la \ 100 $(top_builddir)/src/sq/libgnunetsq.la \
101 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 101 $(top_builddir)/src/statistics/libgnunetstatistics.la \
102 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lsqlite3 \ 102 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIBS) -lsqlite3 \
103 $(LTLIBINTL) 103 $(LTLIBINTL)
104libgnunet_plugin_datastore_sqlite_la_LDFLAGS = \ 104libgnunet_plugin_datastore_sqlite_la_LDFLAGS = \
105 $(GN_PLUGIN_LDFLAGS) 105 $(GN_PLUGIN_LDFLAGS)
@@ -108,7 +108,7 @@ libgnunet_plugin_datastore_sqlite_la_LDFLAGS = \
108libgnunet_plugin_datastore_heap_la_SOURCES = \ 108libgnunet_plugin_datastore_heap_la_SOURCES = \
109 plugin_datastore_heap.c 109 plugin_datastore_heap.c
110libgnunet_plugin_datastore_heap_la_LIBADD = \ 110libgnunet_plugin_datastore_heap_la_LIBADD = \
111 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \ 111 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIBS) \
112 $(LTLIBINTL) 112 $(LTLIBINTL)
113libgnunet_plugin_datastore_heap_la_LDFLAGS = \ 113libgnunet_plugin_datastore_heap_la_LDFLAGS = \
114 $(GN_PLUGIN_LDFLAGS) 114 $(GN_PLUGIN_LDFLAGS)
@@ -119,7 +119,7 @@ libgnunet_plugin_datastore_postgres_la_SOURCES = \
119libgnunet_plugin_datastore_postgres_la_LIBADD = \ 119libgnunet_plugin_datastore_postgres_la_LIBADD = \
120 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 120 $(top_builddir)/src/statistics/libgnunetstatistics.la \
121 $(top_builddir)/src/pq/libgnunetpq.la \ 121 $(top_builddir)/src/pq/libgnunetpq.la \
122 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lpq 122 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIBS) -lpq
123libgnunet_plugin_datastore_postgres_la_LDFLAGS = \ 123libgnunet_plugin_datastore_postgres_la_LDFLAGS = \
124 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS) 124 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS)
125libgnunet_plugin_datastore_postgres_la_CPPFLAGS = \ 125libgnunet_plugin_datastore_postgres_la_CPPFLAGS = \
@@ -129,7 +129,7 @@ libgnunet_plugin_datastore_postgres_la_CPPFLAGS = \
129libgnunet_plugin_datastore_template_la_SOURCES = \ 129libgnunet_plugin_datastore_template_la_SOURCES = \
130 plugin_datastore_template.c 130 plugin_datastore_template.c
131libgnunet_plugin_datastore_template_la_LIBADD = \ 131libgnunet_plugin_datastore_template_la_LIBADD = \
132 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \ 132 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIBS) \
133 $(LTLIBINTL) 133 $(LTLIBINTL)
134libgnunet_plugin_datastore_template_la_LDFLAGS = \ 134libgnunet_plugin_datastore_template_la_LDFLAGS = \
135 $(GN_PLUGIN_LDFLAGS) 135 $(GN_PLUGIN_LDFLAGS)
@@ -153,33 +153,33 @@ test_datastore_api_heap_SOURCES = \
153test_datastore_api_heap_LDADD = \ 153test_datastore_api_heap_LDADD = \
154 $(top_builddir)/src/testing/libgnunettesting.la \ 154 $(top_builddir)/src/testing/libgnunettesting.la \
155 libgnunetdatastore.la \ 155 libgnunetdatastore.la \
156 $(top_builddir)/src/util/libgnunetutil.la 156 $(top_builddir)/src/lib/util/libgnunetutil.la
157 157
158test_datastore_api_management_heap_SOURCES = \ 158test_datastore_api_management_heap_SOURCES = \
159 test_datastore_api_management.c 159 test_datastore_api_management.c
160test_datastore_api_management_heap_LDADD = \ 160test_datastore_api_management_heap_LDADD = \
161 $(top_builddir)/src/testing/libgnunettesting.la \ 161 $(top_builddir)/src/testing/libgnunettesting.la \
162 libgnunetdatastore.la \ 162 libgnunetdatastore.la \
163 $(top_builddir)/src/util/libgnunetutil.la 163 $(top_builddir)/src/lib/util/libgnunetutil.la
164 164
165perf_datastore_api_heap_SOURCES = \ 165perf_datastore_api_heap_SOURCES = \
166 perf_datastore_api.c 166 perf_datastore_api.c
167perf_datastore_api_heap_LDADD = \ 167perf_datastore_api_heap_LDADD = \
168 $(top_builddir)/src/testing/libgnunettesting.la \ 168 $(top_builddir)/src/testing/libgnunettesting.la \
169 libgnunetdatastore.la \ 169 libgnunetdatastore.la \
170 $(top_builddir)/src/util/libgnunetutil.la 170 $(top_builddir)/src/lib/util/libgnunetutil.la
171 171
172perf_plugin_datastore_heap_SOURCES = \ 172perf_plugin_datastore_heap_SOURCES = \
173 perf_plugin_datastore.c 173 perf_plugin_datastore.c
174perf_plugin_datastore_heap_LDADD = \ 174perf_plugin_datastore_heap_LDADD = \
175 $(top_builddir)/src/testing/libgnunettesting.la \ 175 $(top_builddir)/src/testing/libgnunettesting.la \
176 $(top_builddir)/src/util/libgnunetutil.la 176 $(top_builddir)/src/lib/util/libgnunetutil.la
177 177
178test_plugin_datastore_heap_SOURCES = \ 178test_plugin_datastore_heap_SOURCES = \
179 test_plugin_datastore.c 179 test_plugin_datastore.c
180test_plugin_datastore_heap_LDADD = \ 180test_plugin_datastore_heap_LDADD = \
181 $(top_builddir)/src/testing/libgnunettesting.la \ 181 $(top_builddir)/src/testing/libgnunettesting.la \
182 $(top_builddir)/src/util/libgnunetutil.la 182 $(top_builddir)/src/lib/util/libgnunetutil.la
183 183
184 184
185test_datastore_api_sqlite_SOURCES = \ 185test_datastore_api_sqlite_SOURCES = \
@@ -187,33 +187,33 @@ test_datastore_api_sqlite_SOURCES = \
187test_datastore_api_sqlite_LDADD = \ 187test_datastore_api_sqlite_LDADD = \
188 $(top_builddir)/src/testing/libgnunettesting.la \ 188 $(top_builddir)/src/testing/libgnunettesting.la \
189 libgnunetdatastore.la \ 189 libgnunetdatastore.la \
190 $(top_builddir)/src/util/libgnunetutil.la 190 $(top_builddir)/src/lib/util/libgnunetutil.la
191 191
192test_datastore_api_management_sqlite_SOURCES = \ 192test_datastore_api_management_sqlite_SOURCES = \
193 test_datastore_api_management.c 193 test_datastore_api_management.c
194test_datastore_api_management_sqlite_LDADD = \ 194test_datastore_api_management_sqlite_LDADD = \
195 $(top_builddir)/src/testing/libgnunettesting.la \ 195 $(top_builddir)/src/testing/libgnunettesting.la \
196 libgnunetdatastore.la \ 196 libgnunetdatastore.la \
197 $(top_builddir)/src/util/libgnunetutil.la 197 $(top_builddir)/src/lib/util/libgnunetutil.la
198 198
199perf_datastore_api_sqlite_SOURCES = \ 199perf_datastore_api_sqlite_SOURCES = \
200 perf_datastore_api.c 200 perf_datastore_api.c
201perf_datastore_api_sqlite_LDADD = \ 201perf_datastore_api_sqlite_LDADD = \
202 $(top_builddir)/src/testing/libgnunettesting.la \ 202 $(top_builddir)/src/testing/libgnunettesting.la \
203 libgnunetdatastore.la \ 203 libgnunetdatastore.la \
204 $(top_builddir)/src/util/libgnunetutil.la 204 $(top_builddir)/src/lib/util/libgnunetutil.la
205 205
206perf_plugin_datastore_sqlite_SOURCES = \ 206perf_plugin_datastore_sqlite_SOURCES = \
207 perf_plugin_datastore.c 207 perf_plugin_datastore.c
208perf_plugin_datastore_sqlite_LDADD = \ 208perf_plugin_datastore_sqlite_LDADD = \
209 $(top_builddir)/src/testing/libgnunettesting.la \ 209 $(top_builddir)/src/testing/libgnunettesting.la \
210 $(top_builddir)/src/util/libgnunetutil.la 210 $(top_builddir)/src/lib/util/libgnunetutil.la
211 211
212test_plugin_datastore_sqlite_SOURCES = \ 212test_plugin_datastore_sqlite_SOURCES = \
213 test_plugin_datastore.c 213 test_plugin_datastore.c
214test_plugin_datastore_sqlite_LDADD = \ 214test_plugin_datastore_sqlite_LDADD = \
215 $(top_builddir)/src/testing/libgnunettesting.la \ 215 $(top_builddir)/src/testing/libgnunettesting.la \
216 $(top_builddir)/src/util/libgnunetutil.la 216 $(top_builddir)/src/lib/util/libgnunetutil.la
217 217
218 218
219test_datastore_api_postgres_SOURCES = \ 219test_datastore_api_postgres_SOURCES = \
@@ -221,33 +221,33 @@ test_datastore_api_postgres_SOURCES = \
221test_datastore_api_postgres_LDADD = \ 221test_datastore_api_postgres_LDADD = \
222 $(top_builddir)/src/testing/libgnunettesting.la \ 222 $(top_builddir)/src/testing/libgnunettesting.la \
223 libgnunetdatastore.la \ 223 libgnunetdatastore.la \
224 $(top_builddir)/src/util/libgnunetutil.la 224 $(top_builddir)/src/lib/util/libgnunetutil.la
225 225
226test_datastore_api_management_postgres_SOURCES = \ 226test_datastore_api_management_postgres_SOURCES = \
227 test_datastore_api_management.c 227 test_datastore_api_management.c
228test_datastore_api_management_postgres_LDADD = \ 228test_datastore_api_management_postgres_LDADD = \
229 $(top_builddir)/src/testing/libgnunettesting.la \ 229 $(top_builddir)/src/testing/libgnunettesting.la \
230 libgnunetdatastore.la \ 230 libgnunetdatastore.la \
231 $(top_builddir)/src/util/libgnunetutil.la 231 $(top_builddir)/src/lib/util/libgnunetutil.la
232 232
233perf_datastore_api_postgres_SOURCES = \ 233perf_datastore_api_postgres_SOURCES = \
234 perf_datastore_api.c 234 perf_datastore_api.c
235perf_datastore_api_postgres_LDADD = \ 235perf_datastore_api_postgres_LDADD = \
236 $(top_builddir)/src/testing/libgnunettesting.la \ 236 $(top_builddir)/src/testing/libgnunettesting.la \
237 libgnunetdatastore.la \ 237 libgnunetdatastore.la \
238 $(top_builddir)/src/util/libgnunetutil.la 238 $(top_builddir)/src/lib/util/libgnunetutil.la
239 239
240test_plugin_datastore_postgres_SOURCES = \ 240test_plugin_datastore_postgres_SOURCES = \
241 test_plugin_datastore.c 241 test_plugin_datastore.c
242test_plugin_datastore_postgres_LDADD = \ 242test_plugin_datastore_postgres_LDADD = \
243 $(top_builddir)/src/testing/libgnunettesting.la \ 243 $(top_builddir)/src/testing/libgnunettesting.la \
244 $(top_builddir)/src/util/libgnunetutil.la 244 $(top_builddir)/src/lib/util/libgnunetutil.la
245 245
246perf_plugin_datastore_postgres_SOURCES = \ 246perf_plugin_datastore_postgres_SOURCES = \
247 perf_plugin_datastore.c 247 perf_plugin_datastore.c
248perf_plugin_datastore_postgres_LDADD = \ 248perf_plugin_datastore_postgres_LDADD = \
249 $(top_builddir)/src/testing/libgnunettesting.la \ 249 $(top_builddir)/src/testing/libgnunettesting.la \
250 $(top_builddir)/src/util/libgnunetutil.la 250 $(top_builddir)/src/lib/util/libgnunetutil.la
251 251
252 252
253EXTRA_DIST = \ 253EXTRA_DIST = \