aboutsummaryrefslogtreecommitdiff
path: root/src/dht/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/dht/Makefile.am')
-rw-r--r--src/dht/Makefile.am30
1 files changed, 15 insertions, 15 deletions
diff --git a/src/dht/Makefile.am b/src/dht/Makefile.am
index 62b093c5d..1e3a5f8f8 100644
--- a/src/dht/Makefile.am
+++ b/src/dht/Makefile.am
@@ -21,7 +21,7 @@ lib_LTLIBRARIES = \
21libgnunetdht_la_SOURCES = \ 21libgnunetdht_la_SOURCES = \
22 dht_api.c dht.h 22 dht_api.c dht.h
23libgnunetdht_la_LIBADD = \ 23libgnunetdht_la_LIBADD = \
24 $(top_builddir)/src/util/libgnunetutil.la \ 24 $(top_builddir)/src/lib/util/libgnunetutil.la \
25 $(XLIB) \ 25 $(XLIB) \
26 $(LTLIBINTL) 26 $(LTLIBINTL)
27libgnunetdht_la_LDFLAGS = \ 27libgnunetdht_la_LDFLAGS = \
@@ -35,10 +35,10 @@ plugin_LTLIBRARIES = \
35libgnunet_plugin_block_dht_la_SOURCES = \ 35libgnunet_plugin_block_dht_la_SOURCES = \
36 plugin_block_dht.c 36 plugin_block_dht.c
37libgnunet_plugin_block_dht_la_LIBADD = \ 37libgnunet_plugin_block_dht_la_LIBADD = \
38 $(top_builddir)/src/hello/libgnunethello.la \ 38 $(top_builddir)/src/lib/hello/libgnunethello.la \
39 $(top_builddir)/src/block/libgnunetblock.la \ 39 $(top_builddir)/src/lib/block/libgnunetblock.la \
40 $(top_builddir)/src/block/libgnunetblockgroup.la \ 40 $(top_builddir)/src/lib/block/libgnunetblockgroup.la \
41 $(top_builddir)/src/util/libgnunetutil.la \ 41 $(top_builddir)/src/lib/util/libgnunetutil.la \
42 $(LTLIBINTL) 42 $(LTLIBINTL)
43libgnunet_plugin_block_dht_la_LDFLAGS = \ 43libgnunet_plugin_block_dht_la_LDFLAGS = \
44 $(GN_PLUGIN_LDFLAGS) 44 $(GN_PLUGIN_LDFLAGS)
@@ -64,11 +64,11 @@ gnunet_service_dht_LDADD = \
64 $(top_builddir)/src/core/libgnunetcore.la \ 64 $(top_builddir)/src/core/libgnunetcore.la \
65 $(top_builddir)/src/nse/libgnunetnse.la \ 65 $(top_builddir)/src/nse/libgnunetnse.la \
66 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \ 66 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
67 $(top_builddir)/src/hello/libgnunethello.la \ 67 $(top_builddir)/src/lib/hello/libgnunethello.la \
68 $(top_builddir)/src/block/libgnunetblock.la \ 68 $(top_builddir)/src/lib/block/libgnunetblock.la \
69 $(top_builddir)/src/block/libgnunetblockgroup.la \ 69 $(top_builddir)/src/lib/block/libgnunetblockgroup.la \
70 $(top_builddir)/src/datacache/libgnunetdatacache.la \ 70 $(top_builddir)/src/datacache/libgnunetdatacache.la \
71 $(top_builddir)/src/util/libgnunetutil.la \ 71 $(top_builddir)/src/lib/util/libgnunetutil.la \
72 -lm 72 -lm
73gnunet_service_dht_LDFLAGS = \ 73gnunet_service_dht_LDFLAGS = \
74 $(GN_LIBINTL) 74 $(GN_LIBINTL)
@@ -77,7 +77,7 @@ gnunet_dht_get_SOURCES = \
77 gnunet-dht-get.c 77 gnunet-dht-get.c
78gnunet_dht_get_LDADD = \ 78gnunet_dht_get_LDADD = \
79 libgnunetdht.la \ 79 libgnunetdht.la \
80 $(top_builddir)/src/util/libgnunetutil.la 80 $(top_builddir)/src/lib/util/libgnunetutil.la
81gnunet_dht_get_LDFLAGS = \ 81gnunet_dht_get_LDFLAGS = \
82 $(GN_LIBINTL) 82 $(GN_LIBINTL)
83 83
@@ -85,7 +85,7 @@ gnunet_dht_hello_SOURCES = \
85 gnunet-dht-hello.c 85 gnunet-dht-hello.c
86gnunet_dht_hello_LDADD = \ 86gnunet_dht_hello_LDADD = \
87 libgnunetdht.la \ 87 libgnunetdht.la \
88 $(top_builddir)/src/util/libgnunetutil.la 88 $(top_builddir)/src/lib/util/libgnunetutil.la
89gnunet_dht_hello_LDFLAGS = \ 89gnunet_dht_hello_LDFLAGS = \
90 $(GN_LIBINTL) 90 $(GN_LIBINTL)
91 91
@@ -93,7 +93,7 @@ gnunet_dht_put_SOURCES = \
93 gnunet-dht-put.c 93 gnunet-dht-put.c
94gnunet_dht_put_LDADD = \ 94gnunet_dht_put_LDADD = \
95 libgnunetdht.la \ 95 libgnunetdht.la \
96 $(top_builddir)/src/util/libgnunetutil.la 96 $(top_builddir)/src/lib/util/libgnunetutil.la
97gnunet_dht_put_LDFLAGS = \ 97gnunet_dht_put_LDFLAGS = \
98 $(GN_LIBINTL) 98 $(GN_LIBINTL)
99 99
@@ -101,7 +101,7 @@ gnunet_dht_monitor_SOURCES = \
101 gnunet-dht-monitor.c 101 gnunet-dht-monitor.c
102gnunet_dht_monitor_LDADD = \ 102gnunet_dht_monitor_LDADD = \
103 libgnunetdht.la \ 103 libgnunetdht.la \
104 $(top_builddir)/src/util/libgnunetutil.la 104 $(top_builddir)/src/lib/util/libgnunetutil.la
105gnunet_dht_monitor_LDFLAGS = \ 105gnunet_dht_monitor_LDFLAGS = \
106 $(GN_LIBINTL) 106 $(GN_LIBINTL)
107 107
@@ -112,9 +112,9 @@ endif
112test_dht_api_SOURCES = \ 112test_dht_api_SOURCES = \
113 test_dht_api.c 113 test_dht_api.c
114test_dht_api_LDADD = \ 114test_dht_api_LDADD = \
115 $(top_builddir)/src/util/libgnunetutil.la \ 115 $(top_builddir)/src/lib/util/libgnunetutil.la \
116 $(top_builddir)/src/testing/libgnunettesting.la \ 116 $(top_builddir)/src/testing/libgnunettesting.la \
117 $(top_builddir)/src/hello/libgnunethello.la \ 117 $(top_builddir)/src/lib/hello/libgnunethello.la \
118 libgnunetdht.la 118 libgnunetdht.la
119 119
120EXTRA_DIST = \ 120EXTRA_DIST = \