aboutsummaryrefslogtreecommitdiff
path: root/src/fs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/fs/Makefile.am')
-rw-r--r--src/fs/Makefile.am29
1 files changed, 28 insertions, 1 deletions
diff --git a/src/fs/Makefile.am b/src/fs/Makefile.am
index 59361b03e..42c78532a 100644
--- a/src/fs/Makefile.am
+++ b/src/fs/Makefile.am
@@ -106,8 +106,11 @@ check_PROGRAMS = \
106 test_fs_collection \ 106 test_fs_collection \
107 test_fs_directory \ 107 test_fs_directory \
108 test_fs_download \ 108 test_fs_download \
109 test_fs_file_information \
109 test_fs_getopt \ 110 test_fs_getopt \
111 test_fs_list_indexed \
110 test_fs_namespace \ 112 test_fs_namespace \
113 test_fs_publish \
111 test_fs_search \ 114 test_fs_search \
112 test_fs_start_stop \ 115 test_fs_start_stop \
113 test_fs_unindex \ 116 test_fs_unindex \
@@ -115,7 +118,8 @@ check_PROGRAMS = \
115 118
116TESTS = \ 119TESTS = \
117 test_fs_directory \ 120 test_fs_directory \
118 test_fs_download \ 121 test_fs_download \
122 test_fs_file_information \
119 test_fs_search \ 123 test_fs_search \
120 test_fs_start_stop \ 124 test_fs_start_stop \
121 test_fs_unindex \ 125 test_fs_unindex \
@@ -141,12 +145,25 @@ test_fs_download_LDADD = \
141 $(top_builddir)/src/arm/libgnunetarm.la \ 145 $(top_builddir)/src/arm/libgnunetarm.la \
142 $(top_builddir)/src/util/libgnunetutil.la 146 $(top_builddir)/src/util/libgnunetutil.la
143 147
148test_fs_file_information_SOURCES = \
149 test_fs_file_information.c
150test_fs_file_information_LDADD = \
151 $(top_builddir)/src/fs/libgnunetfs.la \
152 $(top_builddir)/src/util/libgnunetutil.la
153
144test_fs_getopt_SOURCES = \ 154test_fs_getopt_SOURCES = \
145 test_fs_getopt.c 155 test_fs_getopt.c
146test_fs_getopt_LDADD = \ 156test_fs_getopt_LDADD = \
147 $(top_builddir)/src/fs/libgnunetfs.la \ 157 $(top_builddir)/src/fs/libgnunetfs.la \
148 $(top_builddir)/src/util/libgnunetutil.la 158 $(top_builddir)/src/util/libgnunetutil.la
149 159
160test_fs_list_indexed_SOURCES = \
161 test_fs_list_indexed.c
162test_fs_list_indexed_LDADD = \
163 $(top_builddir)/src/fs/libgnunetfs.la \
164 $(top_builddir)/src/arm/libgnunetarm.la \
165 $(top_builddir)/src/util/libgnunetutil.la
166
150test_fs_namespace_SOURCES = \ 167test_fs_namespace_SOURCES = \
151 test_fs_namespace.c 168 test_fs_namespace.c
152test_fs_namespace_LDADD = \ 169test_fs_namespace_LDADD = \
@@ -154,6 +171,13 @@ test_fs_namespace_LDADD = \
154 $(top_builddir)/src/arm/libgnunetarm.la \ 171 $(top_builddir)/src/arm/libgnunetarm.la \
155 $(top_builddir)/src/util/libgnunetutil.la 172 $(top_builddir)/src/util/libgnunetutil.la
156 173
174test_fs_publish_SOURCES = \
175 test_fs_publish.c
176test_fs_publish_LDADD = \
177 $(top_builddir)/src/fs/libgnunetfs.la \
178 $(top_builddir)/src/arm/libgnunetarm.la \
179 $(top_builddir)/src/util/libgnunetutil.la
180
157test_fs_search_SOURCES = \ 181test_fs_search_SOURCES = \
158 test_fs_search.c 182 test_fs_search.c
159test_fs_search_LDADD = $(top_builddir)/src/fs/libgnunetfs.la \ 183test_fs_search_LDADD = $(top_builddir)/src/fs/libgnunetfs.la \
@@ -184,7 +208,10 @@ EXTRA_DIST = \
184 test_fs_data.conf \ 208 test_fs_data.conf \
185 test_fs_collection_data.conf \ 209 test_fs_collection_data.conf \
186 test_fs_download_data.conf \ 210 test_fs_download_data.conf \
211 test_fs_file_information_data.conf \
212 test_fs_list_indexed_data.conf \
187 test_fs_namespace_data.conf \ 213 test_fs_namespace_data.conf \
214 test_fs_publish_data.conf \
188 test_fs_search_data.conf \ 215 test_fs_search_data.conf \
189 test_fs_unindex_data.conf \ 216 test_fs_unindex_data.conf \
190 test_fs_uri_data.conf 217 test_fs_uri_data.conf