aboutsummaryrefslogtreecommitdiff
path: root/src/fs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/fs/Makefile.am')
-rw-r--r--src/fs/Makefile.am46
1 files changed, 30 insertions, 16 deletions
diff --git a/src/fs/Makefile.am b/src/fs/Makefile.am
index 266baa836..99b631668 100644
--- a/src/fs/Makefile.am
+++ b/src/fs/Makefile.am
@@ -27,39 +27,53 @@ libgnunetfs_la_LDFLAGS = \
27 -version-info 0:0:0 27 -version-info 0:0:0
28 28
29 29
30#bin_PROGRAMS = \ 30#bin_PROGRAMS =
31# gnunet-directory \ 31# gnunet-directory
32# gnunet-download \ 32# gnunet-download
33# gnunet-pseudonym \ 33# gnunet-pseudonym
34# gnunet-search \ 34# gnunet-search
35# gnunet-share \ 35# gnunet-share
36# gnunet-unindex 36# gnunet-unindex
37 37
38#gnunet_directory_SOURCES = \ 38#gnunet_directory_SOURCES =
39# gnunet-directory.c 39# gnunet-directory.c
40#gnunet_directory_LDADD = \ 40#gnunet_directory_LDADD =
41# $(top_builddir)/src/fs/libgnunetfs.la \ 41# $(top_builddir)/src/fs/libgnunetfs.la
42# $(top_builddir)/src/util/libgnunetutil.la \ 42# $(top_builddir)/src/util/libgnunetutil.la
43# $(GN_LIBINTL) 43# $(GN_LIBINTL)
44 44
45 45
46check_PROGRAMS = \ 46check_PROGRAMS = \
47 test_fs_collection \
48 test_fs_directory \
47 test_fs_getopt \ 49 test_fs_getopt \
48 test_fs_uri 50 test_fs_uri
49 51
50TESTS = $(check_PROGRAMS) 52TESTS = $(check_PROGRAMS)
51 53
52test_fs_uri_SOURCES = \ 54test_fs_collection_SOURCES = \
53 test_fs_uri.c 55 test_fs_collection.c
54test_fs_LDADD = \ 56test_fs_collection_LDADD = \
57 $(top_builddir)/src/fs/libgnunetfs.la \
58 $(top_builddir)/src/util/libgnunetutil.la
59
60test_fs_directory_SOURCES = \
61 test_fs_directory.c
62test_fs_directory_LDADD = \
55 $(top_builddir)/src/fs/libgnunetfs.la \ 63 $(top_builddir)/src/fs/libgnunetfs.la \
56 $(top_builddir)/src/util/libgnunetutil.la 64 $(top_builddir)/src/util/libgnunetutil.la
57 65
58test_fs_getopt_SOURCES = \ 66test_fs_getopt_SOURCES = \
59 test_fs_getopt.c 67 test_fs_getopt.c
60test_fs_LDADD = \ 68test_fs_getopt_LDADD = \
69 $(top_builddir)/src/fs/libgnunetfs.la \
70 $(top_builddir)/src/util/libgnunetutil.la
71
72test_fs_uri_SOURCES = \
73 test_fs_uri.c
74test_fs_uri_LDADD = \
61 $(top_builddir)/src/fs/libgnunetfs.la \ 75 $(top_builddir)/src/fs/libgnunetfs.la \
62 $(top_builddir)/src/util/libgnunetutil.la 76 $(top_builddir)/src/util/libgnunetutil.la
63 77
64#EXTRA_DIST = \ 78EXTRA_DIST = \
65# test_fs_data.conf 79 test_fs_uri_data.conf