aboutsummaryrefslogtreecommitdiff
path: root/src/gns/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gns/Makefile.am')
-rw-r--r--src/gns/Makefile.am26
1 files changed, 22 insertions, 4 deletions
diff --git a/src/gns/Makefile.am b/src/gns/Makefile.am
index 315b4dbf3..d49e0c5c8 100644
--- a/src/gns/Makefile.am
+++ b/src/gns/Makefile.am
@@ -155,6 +155,7 @@ gnunet_dns2gns_LDADD = \
155 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 155 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
156 libgnunetgns.la \ 156 libgnunetgns.la \
157 $(top_builddir)/src/util/libgnunetutil.la \ 157 $(top_builddir)/src/util/libgnunetutil.la \
158 $(USE_VPN) \
158 $(top_builddir)/src/identity/libgnunetidentity.la \ 159 $(top_builddir)/src/identity/libgnunetidentity.la \
159 $(GN_LIBINTL) 160 $(GN_LIBINTL)
160 161
@@ -218,7 +219,6 @@ gnunet_service_gns_LDADD = \
218 $(top_builddir)/src/dht/libgnunetdht.la \ 219 $(top_builddir)/src/dht/libgnunetdht.la \
219 $(top_builddir)/src/namecache/libgnunetnamecache.la \ 220 $(top_builddir)/src/namecache/libgnunetnamecache.la \
220 $(LIBIDN) $(LIBIDN2) \ 221 $(LIBIDN) $(LIBIDN2) \
221 $(USE_VPN) \
222 $(GN_LIBINTL) 222 $(GN_LIBINTL)
223 223
224 224
@@ -270,8 +270,7 @@ check_SCRIPTS = \
270 test_gns_rel_expiration.sh\ 270 test_gns_rel_expiration.sh\
271 test_gns_soa_lookup.sh\ 271 test_gns_soa_lookup.sh\
272 test_gns_revocation.sh\ 272 test_gns_revocation.sh\
273 test_gns_cname_lookup.sh\ 273 test_gns_redirect_lookup.sh
274 test_proxy.sh
275 274
276if HAVE_GNUTLS 275if HAVE_GNUTLS
277if HAVE_LIBGNURL 276if HAVE_LIBGNURL
@@ -292,7 +291,26 @@ EXTRA_DIST = \
292 zonefiles/J7POEUT41A8PBFS7KVVDRF88GBOU4HK8PSU5QKVLVE3R9T91E99G.zkey \ 291 zonefiles/J7POEUT41A8PBFS7KVVDRF88GBOU4HK8PSU5QKVLVE3R9T91E99G.zkey \
293 zonefiles/OEFL7A4VEF1B40QLEMTG5D8G1CN6EN16QUSG5R2DT71GRJN34LSG.zkey \ 292 zonefiles/OEFL7A4VEF1B40QLEMTG5D8G1CN6EN16QUSG5R2DT71GRJN34LSG.zkey \
294 zonefiles/test_zonekey \ 293 zonefiles/test_zonekey \
295 $(check_SCRIPTS) \ 294 test_gns_lookup.sh \
295 test_gns_config_lookup.sh \
296 test_gns_ipv6_lookup.sh\
297 test_gns_txt_lookup.sh\
298 test_gns_caa_lookup.sh\
299 test_gns_mx_lookup.sh \
300 test_gns_gns2dns_lookup.sh \
301 test_gns_gns2dns_zkey_lookup.sh \
302 test_gns_gns2dns_cname_lookup.sh \
303 test_gns_dht_lookup.sh\
304 test_gns_delegated_lookup.sh \
305 test_gns_at_lookup.sh\
306 test_gns_zkey_lookup.sh\
307 test_gns_rel_expiration.sh\
308 test_gns_soa_lookup.sh\
309 test_gns_revocation.sh\
310 test_gns_redirect_lookup.sh\
311 test_proxy.sh\
312 test_plugin_rest_gns.sh\
313 test_proxy.sh \
296 $(pkgdata_DATA) \ 314 $(pkgdata_DATA) \
297 test_gnunet_gns.sh.in 315 test_gnunet_gns.sh.in
298 316