aboutsummaryrefslogtreecommitdiff
path: root/src/identity-token/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/identity-token/Makefile.am')
-rw-r--r--src/identity-token/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/src/identity-token/Makefile.am b/src/identity-token/Makefile.am
new file mode 100644
index 000000000..a5c36aff2
--- /dev/null
+++ b/src/identity-token/Makefile.am
@@ -0,0 +1,48 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4 plugindir = $(libdir)/gnunet
5
6if MINGW
7 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
8endif
9
10if USE_COVERAGE
11 AM_CFLAGS = --coverage -O0
12 XLIB = -lgcov
13endif
14
15pkgcfgdir= $(pkgdatadir)/config.d/
16
17libexecdir= $(pkglibdir)/libexec/
18
19pkgcfg_DATA = \
20 identity-token.conf
21
22if HAVE_REST
23lib_LTLIBRARIES = \
24 libgnunet_plugin_rest_identity_token.la
25endif
26
27bin_PROGRAMS = \
28 gnunet-identity-token
29
30libgnunet_plugin_rest_identity_token_la_SOURCES = \
31 plugin_rest_identity_token.c
32libgnunet_plugin_rest_identity_token_la_LIBADD = \
33 $(top_builddir)/src/identity/libgnunetidentity.la \
34 $(top_builddir)/src/namestore/libgnunetnamestore.la \
35 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
36 $(LTLIBINTL) -ljansson -lmicrohttpd
37libgnunet_plugin_rest_identity_token_la_LDFLAGS = \
38 $(GN_PLUGIN_LDFLAGS)
39
40
41gnunet_identity_token_SOURCES = \
42 gnunet-identity-token.c
43gnunet_identity_token_LDADD = \
44 $(top_builddir)/src/util/libgnunetutil.la \
45 -ljansson -lmicrohttpd \
46 $(GN_LIBINTL)
47
48