aboutsummaryrefslogtreecommitdiff
path: root/src/identity/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/identity/Makefile.am')
-rw-r--r--src/identity/Makefile.am21
1 files changed, 20 insertions, 1 deletions
diff --git a/src/identity/Makefile.am b/src/identity/Makefile.am
index 1f21fc65d..5c1af8e19 100644
--- a/src/identity/Makefile.am
+++ b/src/identity/Makefile.am
@@ -12,6 +12,12 @@ if USE_COVERAGE
12 XLIB = -lgcov 12 XLIB = -lgcov
13endif 13endif
14 14
15if HAVE_MHD
16if HAVE_JSON
17REST_PLUGIN = libgnunet_plugin_rest_identity.la
18endif
19endif
20
15pkgcfgdir= $(pkgdatadir)/config.d/ 21pkgcfgdir= $(pkgdatadir)/config.d/
16 22
17libexecdir= $(pkglibdir)/libexec/ 23libexecdir= $(pkglibdir)/libexec/
@@ -20,7 +26,20 @@ pkgcfg_DATA = \
20 identity.conf 26 identity.conf
21 27
22lib_LTLIBRARIES = \ 28lib_LTLIBRARIES = \
23 libgnunetidentity.la 29 libgnunetidentity.la \
30 $(REST_PLUGIN)
31
32
33libgnunet_plugin_rest_identity_la_SOURCES = \
34 plugin_rest_identity.c
35libgnunet_plugin_rest_identity_la_LIBADD = \
36 libgnunetidentity.la \
37 $(top_builddir)/src/rest/libgnunetrest.la \
38 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
39 $(LTLIBINTL) -ljansson -lmicrohttpd
40libgnunet_plugin_rest_identity_la_LDFLAGS = \
41 $(GN_PLUGIN_LDFLAGS)
42
24 43
25libgnunetidentity_la_SOURCES = \ 44libgnunetidentity_la_SOURCES = \
26 identity_api.c \ 45 identity_api.c \