aboutsummaryrefslogtreecommitdiff
path: root/src/json/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/json/Makefile.am')
-rw-r--r--src/json/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/json/Makefile.am b/src/json/Makefile.am
new file mode 100644
index 000000000..83cd6dd2d
--- /dev/null
+++ b/src/json/Makefile.am
@@ -0,0 +1,35 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6 XLIB = -lgcov
7endif
8
9lib_LTLIBRARIES = \
10 libgnunetjson.la
11
12libgnunetjson_la_LDFLAGS = \
13 -version-info 0:0:0 \
14 -no-undefined
15libgnunetjson_la_SOURCES = \
16 json.c \
17 json_generator.c \
18 json_helper.c
19libgnunetjson_la_LIBADD = \
20 -lgnunetutil \
21 -ljansson \
22 $(XLIB)
23
24check_PROGRAMS = \
25 test_json
26
27TESTS = \
28 $(check_PROGRAMS)
29
30test_json_SOURCES = \
31 test_json.c
32test_json_LDADD = \
33 libgnunetjson.la \
34 -lgnunetutil \
35 -ljansson