aboutsummaryrefslogtreecommitdiff
path: root/src/lib/hello/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/hello/Makefile.am')
-rw-r--r--src/lib/hello/Makefile.am57
1 files changed, 57 insertions, 0 deletions
diff --git a/src/lib/hello/Makefile.am b/src/lib/hello/Makefile.am
new file mode 100644
index 000000000..4435dba42
--- /dev/null
+++ b/src/lib/hello/Makefile.am
@@ -0,0 +1,57 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6 XLIB = -lgcov
7endif
8
9lib_LTLIBRARIES = libgnunethello.la
10
11libgnunethello_la_SOURCES = \
12 address.c \
13 hello-ng.c \
14 hello-uri.c
15libgnunethello_la_LIBADD = \
16 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIB) \
17 $(LTLIBINTL)
18libgnunethello_la_LDFLAGS = \
19 $(GN_LIB_LDFLAGS) \
20 -version-info 1:0:1
21
22check_PROGRAMS = \
23 test_hello \
24 test_hello-uri \
25 test_friend_hello \
26 test_hello-ng
27
28if ENABLE_TEST_RUN
29AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
30TESTS = $(check_PROGRAMS)
31endif
32
33test_hello_SOURCES = \
34 test_hello.c
35test_hello_LDADD = \
36 libgnunethello.la \
37 $(top_builddir)/src/lib/util/libgnunetutil.la
38
39test_hello_ng_SOURCES = \
40 test_hello-ng.c
41test_hello_ng_LDADD = \
42 libgnunethello.la \
43 $(top_builddir)/src/lib/util/libgnunetutil.la
44
45test_hello_uri_SOURCES = \
46 test_hello-uri.c
47test_hello_uri_LDADD = \
48 libgnunethello.la \
49 $(top_builddir)/src/lib/util/libgnunetutil.la \
50 -lgcrypt
51
52
53test_friend_hello_SOURCES = \
54 test_friend_hello.c
55test_friend_hello_LDADD = \
56 libgnunethello.la \
57 $(top_builddir)/src/lib/util/libgnunetutil.la