aboutsummaryrefslogtreecommitdiff
path: root/src/lib/hello/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/hello/meson.build')
-rw-r--r--src/lib/hello/meson.build33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/lib/hello/meson.build b/src/lib/hello/meson.build
new file mode 100644
index 000000000..c0df8b76c
--- /dev/null
+++ b/src/lib/hello/meson.build
@@ -0,0 +1,33 @@
1libgnunethello_src = [#'hello.c',
2 'address.c',
3 'hello-ng.c',
4 'hello-uri.c']
5
6if get_option('monolith')
7 foreach p : libgnunethello_src
8 gnunet_src += 'hello/' + p
9 endforeach
10 subdir_done()
11endif
12
13libgnunethello = library('gnunethello',
14 libgnunethello_src,
15 soversion: '0',
16 version: '0.1.0',
17 dependencies: libgnunetutil_dep,
18 include_directories: [incdir, configuration_inc],
19 install: true,
20 install_dir: get_option('libdir'))
21libgnunethello_dep = declare_dependency(link_with : libgnunethello)
22pkg.generate(libgnunethello, url: 'https://www.gnunet.org',
23 description : 'Helper library for handling GNUnet HELLO messages')
24
25
26# TNG
27#executable ('gnunet-hello',
28# ['gnunet-hello.c'],
29# dependencies: [libgnunethello_dep, libgnunetutil_dep],
30# include_directories: [incdir, configuration_inc],
31# install: true,
32# install_dir: get_option('bindir'))
33