aboutsummaryrefslogtreecommitdiff
path: root/src/multicast/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/multicast/Makefile.am')
-rw-r--r--src/multicast/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/multicast/Makefile.am b/src/multicast/Makefile.am
index fd1df191d..64c0bfe1d 100644
--- a/src/multicast/Makefile.am
+++ b/src/multicast/Makefile.am
@@ -52,7 +52,8 @@ gnunet_service_multicast_LDADD = \
52 52
53 53
54check_PROGRAMS = \ 54check_PROGRAMS = \
55 test_multicast 55 test_multicast \
56 test_multicast_multipeer
56 57
57if ENABLE_TEST_RUN 58if ENABLE_TEST_RUN
58AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH; 59AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
@@ -66,3 +67,11 @@ test_multicast_LDADD = \
66 $(top_builddir)/src/testing/libgnunettesting.la \ 67 $(top_builddir)/src/testing/libgnunettesting.la \
67 $(top_builddir)/src/util/libgnunetutil.la \ 68 $(top_builddir)/src/util/libgnunetutil.la \
68 $(top_builddir)/src/core/libgnunetcore.la 69 $(top_builddir)/src/core/libgnunetcore.la
70
71test_multicast_multipeer_SOURCE = \
72 test_multicast_multipeer.c
73test_multicast_multipeer_LDADD = \
74 libgnunetmulticast.la \
75 $(top_builddir)/src/testbed/libgnunettestbed.la \
76 $(top_builddir)/src/util/libgnunetutil.la \
77 $(top_builddir)/src/core/libgnunetcore.la