aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am41
1 files changed, 33 insertions, 8 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index 5f18506a7..b925261b7 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -20,29 +20,28 @@ if USE_COVERAGE
20 XLIBS = -lgcov 20 XLIBS = -lgcov
21endif 21endif
22 22
23if HAVE_EXPERIMENTAL
24FLAT_PLUGIN = libgnunet_plugin_namestore_flat.la 23FLAT_PLUGIN = libgnunet_plugin_namestore_flat.la
25if HAVE_TESTING 24if HAVE_TESTING
26FLAT_TESTS = test_plugin_namestore_flat 25FLAT_TESTS = test_plugin_namestore_flat \
27endif 26 perf_namestore_api_zone_iteration_flat
28endif 27endif
29 28
30if HAVE_SQLITE 29if HAVE_SQLITE
31SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la 30SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
32if HAVE_TESTING 31if HAVE_TESTING
33SQLITE_TESTS = test_plugin_namestore_sqlite 32SQLITE_TESTS = test_plugin_namestore_sqlite \
33 perf_namestore_api_zone_iteration_sqlite
34endif 34endif
35endif 35endif
36 36
37if HAVE_POSTGRESQL 37if HAVE_POSTGRESQL
38# postgres doesn't even build yet; thus: experimental!
39POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la 38POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la
40if HAVE_TESTING 39if HAVE_TESTING
41POSTGRES_TESTS = test_plugin_namestore_postgres 40POSTGRES_TESTS = test_plugin_namestore_postgres \
41 perf_namestore_api_zone_iteration_postgres
42endif 42endif
43endif 43endif
44 44
45# testcases do not even build yet; thus: experimental!
46if HAVE_TESTING 45if HAVE_TESTING
47TESTING_TESTS = \ 46TESTING_TESTS = \
48 test_namestore_api_store.nc \ 47 test_namestore_api_store.nc \
@@ -81,7 +80,6 @@ test_namestore_api_zone_iteration_specific_zone.log: test_namestore_api_zone_ite
81test_namestore_api_zone_iteration_stop.log: test_namestore_api_monitoring.log 80test_namestore_api_zone_iteration_stop.log: test_namestore_api_monitoring.log
82test_namestore_api_monitoring.log: test_namestore_api_monitoring_existing.log 81test_namestore_api_monitoring.log: test_namestore_api_monitoring_existing.log
83 82
84
85if HAVE_SQLITE 83if HAVE_SQLITE
86check_PROGRAMS = \ 84check_PROGRAMS = \
87 $(SQLITE_TESTS) \ 85 $(SQLITE_TESTS) \
@@ -341,6 +339,30 @@ test_namestore_api_zone_iteration_nc_LDADD = \
341 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 339 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
342 libgnunetnamestore.la 340 libgnunetnamestore.la
343 341
342perf_namestore_api_zone_iteration_postgres_SOURCES = \
343 perf_namestore_api_zone_iteration.c
344perf_namestore_api_zone_iteration_postgres_LDADD = \
345 $(top_builddir)/src/testing/libgnunettesting.la \
346 $(top_builddir)/src/util/libgnunetutil.la \
347 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
348 libgnunetnamestore.la
349
350perf_namestore_api_zone_iteration_sqlite_SOURCES = \
351 perf_namestore_api_zone_iteration.c
352perf_namestore_api_zone_iteration_sqlite_LDADD = \
353 $(top_builddir)/src/testing/libgnunettesting.la \
354 $(top_builddir)/src/util/libgnunetutil.la \
355 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
356 libgnunetnamestore.la
357
358perf_namestore_api_zone_iteration_flat_SOURCES = \
359 perf_namestore_api_zone_iteration.c
360perf_namestore_api_zone_iteration_flat_LDADD = \
361 $(top_builddir)/src/testing/libgnunettesting.la \
362 $(top_builddir)/src/util/libgnunetutil.la \
363 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
364 libgnunetnamestore.la
365
344test_namestore_api_zone_iteration_nick_nc_SOURCES = \ 366test_namestore_api_zone_iteration_nick_nc_SOURCES = \
345 test_namestore_api_zone_iteration_nick.c 367 test_namestore_api_zone_iteration_nick.c
346test_namestore_api_zone_iteration_nick_nc_LDADD = \ 368test_namestore_api_zone_iteration_nick_nc_LDADD = \
@@ -391,6 +413,9 @@ check_SCRIPTS = \
391 413
392EXTRA_DIST = \ 414EXTRA_DIST = \
393 test_namestore_api.conf \ 415 test_namestore_api.conf \
416 test_namestore_api_postgres.conf \
417 test_namestore_api_sqlite.conf \
418 test_namestore_api_flat.conf \
394 test_plugin_namestore_sqlite.conf \ 419 test_plugin_namestore_sqlite.conf \
395 test_plugin_namestore_postgres.conf \ 420 test_plugin_namestore_postgres.conf \
396 test_plugin_namestore_flat.conf \ 421 test_plugin_namestore_flat.conf \