aboutsummaryrefslogtreecommitdiff
path: root/src/nat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/nat/Makefile.am')
-rw-r--r--src/nat/Makefile.am18
1 files changed, 13 insertions, 5 deletions
diff --git a/src/nat/Makefile.am b/src/nat/Makefile.am
index 7b738df4e..5aafdb240 100644
--- a/src/nat/Makefile.am
+++ b/src/nat/Makefile.am
@@ -54,7 +54,8 @@ libgnunetnat_la_LDFLAGS = \
54 -version-info 0:0:0 54 -version-info 0:0:0
55 55
56check_PROGRAMS = \ 56check_PROGRAMS = \
57 test-nat 57 test_nat \
58 test_nat_test
58 59
59if ENABLE_TEST_RUN 60if ENABLE_TEST_RUN
60 TESTS = $(check_PROGRAMS) 61 TESTS = $(check_PROGRAMS)
@@ -62,11 +63,18 @@ endif
62 63
63test_nat_SOURCES = \ 64test_nat_SOURCES = \
64 test_nat.c 65 test_nat.c
65
66test_nat_LDADD = \ 66test_nat_LDADD = \
67 $(top_builddir)/src/nat/libgnunetnat.la \ 67 $(top_builddir)/src/nat/libgnunetnat.la \
68 $(top_builddir)/src/util/libgnunetutil.la \ 68 $(top_builddir)/src/util/libgnunetutil.la
69 @LIBCURL@ 69
70
71test_nat_test_SOURCES = \
72 test_nat_test.c
73test_nat_test_LDADD = \
74 $(top_builddir)/src/nat/libgnunetnat.la \
75 $(top_builddir)/src/util/libgnunetutil.la
76
70 77
71EXTRA_DIST = \ 78EXTRA_DIST = \
72 test_nat_data.conf 79 test_nat_data.conf \
80 test_nat_test_data.conf \ No newline at end of file