aboutsummaryrefslogtreecommitdiff
path: root/src/nse/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/nse/Makefile.am')
-rw-r--r--src/nse/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/nse/Makefile.am b/src/nse/Makefile.am
index a67ffeaf8..971d4c1b1 100644
--- a/src/nse/Makefile.am
+++ b/src/nse/Makefile.am
@@ -53,7 +53,7 @@ gnunet_service_nse_LDADD = \
53 $(top_builddir)/src/util/libgnunetutil.la \ 53 $(top_builddir)/src/util/libgnunetutil.la \
54 $(top_builddir)/src/core/libgnunetcore.la \ 54 $(top_builddir)/src/core/libgnunetcore.la \
55 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 55 $(top_builddir)/src/statistics/libgnunetstatistics.la \
56 -lm \ 56 -lm -lgcrypt \
57 $(GN_LIBINTL) 57 $(GN_LIBINTL)
58gnunet_service_nse_DEPENDENCIES = \ 58gnunet_service_nse_DEPENDENCIES = \
59 libgnunetnse.la 59 libgnunetnse.la
@@ -64,6 +64,7 @@ endif
64 64
65check_PROGRAMS = \ 65check_PROGRAMS = \
66 test_nse_api \ 66 test_nse_api \
67 perf_kdf \
67 $(MULTIPEER_TEST) 68 $(MULTIPEER_TEST)
68 69
69 70
@@ -86,6 +87,12 @@ test_nse_multipeer_LDADD = \
86 $(top_builddir)/src/testbed/libgnunettestbed.la \ 87 $(top_builddir)/src/testbed/libgnunettestbed.la \
87 -lm 88 -lm
88 89
90perf_kdf_SOURCES = \
91 perf_kdf.c
92perf_kdf_LDADD = \
93 $(top_builddir)/src/util/libgnunetutil.la \
94 -lgcrypt
95
89EXTRA_DIST = \ 96EXTRA_DIST = \
90 test_nse.conf \ 97 test_nse.conf \
91 nse_profiler_test.conf 98 nse_profiler_test.conf