summaryrefslogtreecommitdiff
path: root/src/nse/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/nse/Makefile.am')
-rw-r--r--src/nse/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/nse/Makefile.am b/src/nse/Makefile.am
index 80886433a..728f23935 100644
--- a/src/nse/Makefile.am
+++ b/src/nse/Makefile.am
@@ -32,8 +32,10 @@ libgnunetnse_la_LDFLAGS = \
32libexec_PROGRAMS = \ 32libexec_PROGRAMS = \
33 gnunet-service-nse 33 gnunet-service-nse
34 34
35if HAVE_TESTING
35noinst_PROGRAMS = \ 36noinst_PROGRAMS = \
36 gnunet-nse-profiler 37 gnunet-nse-profiler
38endif
37 39
38gnunet_nse_profiler_SOURCES = \ 40gnunet_nse_profiler_SOURCES = \
39 gnunet-nse-profiler.c 41 gnunet-nse-profiler.c
@@ -69,11 +71,12 @@ if HAVE_BENCHMARKS
69 MULTIPEER_TEST = test_nse_multipeer 71 MULTIPEER_TEST = test_nse_multipeer
70endif 72endif
71 73
74if HAVE_TESTING
72check_PROGRAMS = \ 75check_PROGRAMS = \
73 test_nse_api \ 76 test_nse_api \
74 perf_kdf \ 77 perf_kdf \
75 $(MULTIPEER_TEST) 78 $(MULTIPEER_TEST)
76 79endif
77 80
78if ENABLE_TEST_RUN 81if ENABLE_TEST_RUN
79TESTS = $(check_PROGRAMS) 82TESTS = $(check_PROGRAMS)