aboutsummaryrefslogtreecommitdiff
path: root/src/peerinfo-tool/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/peerinfo-tool/Makefile.am')
-rw-r--r--src/peerinfo-tool/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/src/peerinfo-tool/Makefile.am b/src/peerinfo-tool/Makefile.am
index 1fc088ad9..8b74efefb 100644
--- a/src/peerinfo-tool/Makefile.am
+++ b/src/peerinfo-tool/Makefile.am
@@ -20,8 +20,19 @@ gnunet_peerinfo_LDADD = \
20 $(top_builddir)/src/util/libgnunetutil.la 20 $(top_builddir)/src/util/libgnunetutil.la
21 21
22if HAVE_PYTHON_PEXPECT 22if HAVE_PYTHON_PEXPECT
23TESTS_ENVIRONMENT = $(PYTHON) 23check_SCRIPTS = \
24TESTS = \
25 test_gnunet_peerinfo.py 24 test_gnunet_peerinfo.py
26endif 25endif
27 26
27TESTS = $(check_SCRIPTS)
28
29do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
30
31test_gnunet_peerinfo.py: test_gnunet_peerinfo.py.in Makefile
32 $(do_subst) < $(srcdir)/test_gnunet_peerinfo.py.in > test_gnunet_peerinfo.py
33 chmod +x test_gnunet_peerinfo.py
34
35EXTRADIST = \
36 test_gnunet_peerinfo.py.in
37
38CLEANFILES = $(check_SCRIPTS)