aboutsummaryrefslogtreecommitdiff
path: root/src/peerstore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/peerstore/Makefile.am')
-rw-r--r--src/peerstore/Makefile.am28
1 files changed, 14 insertions, 14 deletions
diff --git a/src/peerstore/Makefile.am b/src/peerstore/Makefile.am
index 7220492f2..e9835eb31 100644
--- a/src/peerstore/Makefile.am
+++ b/src/peerstore/Makefile.am
@@ -27,7 +27,7 @@ lib_LTLIBRARIES = \
27gnunet_peerstore_SOURCES = \ 27gnunet_peerstore_SOURCES = \
28 gnunet-peerstore.c 28 gnunet-peerstore.c
29gnunet_peerstore_LDADD = \ 29gnunet_peerstore_LDADD = \
30 $(top_builddir)/src/util/libgnunetutil.la \ 30 $(top_builddir)/src/lib/util/libgnunetutil.la \
31 libgnunetpeerstore.la \ 31 libgnunetpeerstore.la \
32 $(GN_LIBINTL) 32 $(GN_LIBINTL)
33 33
@@ -37,16 +37,16 @@ gnunet_service_peerstore_SOURCES = \
37 peerstore.h 37 peerstore.h
38gnunet_service_peerstore_CFLAGS = $(AM_CFLAGS) 38gnunet_service_peerstore_CFLAGS = $(AM_CFLAGS)
39gnunet_service_peerstore_LDADD = \ 39gnunet_service_peerstore_LDADD = \
40 $(top_builddir)/src/util/libgnunetutil.la \ 40 $(top_builddir)/src/lib/util/libgnunetutil.la \
41 $(top_builddir)/src/hello/libgnunethello.la \ 41 $(top_builddir)/src/lib/hello/libgnunethello.la \
42 $(GN_LIBINTL) 42 $(GN_LIBINTL)
43 43
44libgnunetpeerstore_la_SOURCES = \ 44libgnunetpeerstore_la_SOURCES = \
45 peerstore_api.c \ 45 peerstore_api.c \
46 peerstore_common.c 46 peerstore_common.c
47libgnunetpeerstore_la_LIBADD = \ 47libgnunetpeerstore_la_LIBADD = \
48 $(top_builddir)/src/util/libgnunetutil.la \ 48 $(top_builddir)/src/lib/util/libgnunetutil.la \
49 $(top_builddir)/src/hello/libgnunethello.la 49 $(top_builddir)/src/lib/hello/libgnunethello.la
50libgnunetpeerstore_la_LDFLAGS = \ 50libgnunetpeerstore_la_LDFLAGS = \
51 $(GN_LIBINTL) \ 51 $(GN_LIBINTL) \
52 $(GN_LIB_LDFLAGS) 52 $(GN_LIB_LDFLAGS)
@@ -58,7 +58,7 @@ libgnunet_plugin_peerstore_flat_la_SOURCES = \
58 plugin_peerstore_flat.c 58 plugin_peerstore_flat.c
59libgnunet_plugin_peerstore_flat_la_LIBADD = \ 59libgnunet_plugin_peerstore_flat_la_LIBADD = \
60 libgnunetpeerstore.la \ 60 libgnunetpeerstore.la \
61 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \ 61 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIBS) \
62 $(LTLIBINTL) 62 $(LTLIBINTL)
63libgnunet_plugin_peerstore_flat_la_LDFLAGS = \ 63libgnunet_plugin_peerstore_flat_la_LDFLAGS = \
64 $(GN_PLUGIN_LDFLAGS) 64 $(GN_PLUGIN_LDFLAGS)
@@ -72,7 +72,7 @@ libgnunet_plugin_peerstore_sqlite_la_SOURCES = \
72libgnunet_plugin_peerstore_sqlite_la_LIBADD = \ 72libgnunet_plugin_peerstore_sqlite_la_LIBADD = \
73 libgnunetpeerstore.la \ 73 libgnunetpeerstore.la \
74 $(top_builddir)/src/sq/libgnunetsq.la \ 74 $(top_builddir)/src/sq/libgnunetsq.la \
75 $(top_builddir)/src/util/libgnunetutil.la \ 75 $(top_builddir)/src/lib/util/libgnunetutil.la \
76 $(XLIBS) -lsqlite3 \ 76 $(XLIBS) -lsqlite3 \
77 $(LTLIBINTL) 77 $(LTLIBINTL)
78libgnunet_plugin_peerstore_sqlite_la_LDFLAGS = \ 78libgnunet_plugin_peerstore_sqlite_la_LDFLAGS = \
@@ -87,13 +87,13 @@ test_plugin_peerstore_sqlite_SOURCES = \
87 test_plugin_peerstore.c 87 test_plugin_peerstore.c
88test_plugin_peerstore_sqlite_LDADD = \ 88test_plugin_peerstore_sqlite_LDADD = \
89 $(top_builddir)/src/testing/libgnunettesting.la \ 89 $(top_builddir)/src/testing/libgnunettesting.la \
90 $(top_builddir)/src/util/libgnunetutil.la 90 $(top_builddir)/src/lib/util/libgnunetutil.la
91 91
92test_plugin_peerstore_flat_SOURCES = \ 92test_plugin_peerstore_flat_SOURCES = \
93 test_plugin_peerstore.c 93 test_plugin_peerstore.c
94test_plugin_peerstore_flat_LDADD = \ 94test_plugin_peerstore_flat_LDADD = \
95 $(top_builddir)/src/testing/libgnunettesting.la \ 95 $(top_builddir)/src/testing/libgnunettesting.la \
96 $(top_builddir)/src/util/libgnunetutil.la 96 $(top_builddir)/src/lib/util/libgnunetutil.la
97 97
98check_PROGRAMS = \ 98check_PROGRAMS = \
99 test_peerstore_api_store \ 99 test_peerstore_api_store \
@@ -119,32 +119,32 @@ test_peerstore_api_store_SOURCES = \
119test_peerstore_api_store_LDADD = \ 119test_peerstore_api_store_LDADD = \
120 libgnunetpeerstore.la \ 120 libgnunetpeerstore.la \
121 $(top_builddir)/src/testing/libgnunettesting.la \ 121 $(top_builddir)/src/testing/libgnunettesting.la \
122 $(top_builddir)/src/util/libgnunetutil.la 122 $(top_builddir)/src/lib/util/libgnunetutil.la
123 123
124test_peerstore_api_iterate_SOURCES = \ 124test_peerstore_api_iterate_SOURCES = \
125 test_peerstore_api_iterate.c 125 test_peerstore_api_iterate.c
126test_peerstore_api_iterate_LDADD = \ 126test_peerstore_api_iterate_LDADD = \
127 libgnunetpeerstore.la \ 127 libgnunetpeerstore.la \
128 $(top_builddir)/src/testing/libgnunettesting.la \ 128 $(top_builddir)/src/testing/libgnunettesting.la \
129 $(top_builddir)/src/util/libgnunetutil.la 129 $(top_builddir)/src/lib/util/libgnunetutil.la
130 130
131test_peerstore_api_watch_SOURCES = \ 131test_peerstore_api_watch_SOURCES = \
132 test_peerstore_api_watch.c 132 test_peerstore_api_watch.c
133test_peerstore_api_watch_LDADD = \ 133test_peerstore_api_watch_LDADD = \
134 libgnunetpeerstore.la \ 134 libgnunetpeerstore.la \
135 $(top_builddir)/src/testing/libgnunettesting.la \ 135 $(top_builddir)/src/testing/libgnunettesting.la \
136 $(top_builddir)/src/util/libgnunetutil.la 136 $(top_builddir)/src/lib/util/libgnunetutil.la
137 137
138test_peerstore_api_sync_SOURCES = \ 138test_peerstore_api_sync_SOURCES = \
139 test_peerstore_api_sync.c 139 test_peerstore_api_sync.c
140test_peerstore_api_sync_LDADD = \ 140test_peerstore_api_sync_LDADD = \
141 libgnunetpeerstore.la \ 141 libgnunetpeerstore.la \
142 $(top_builddir)/src/testing/libgnunettesting.la \ 142 $(top_builddir)/src/testing/libgnunettesting.la \
143 $(top_builddir)/src/util/libgnunetutil.la 143 $(top_builddir)/src/lib/util/libgnunetutil.la
144 144
145perf_peerstore_store_SOURCES = \ 145perf_peerstore_store_SOURCES = \
146 perf_peerstore_store.c 146 perf_peerstore_store.c
147perf_peerstore_store_LDADD = \ 147perf_peerstore_store_LDADD = \
148 libgnunetpeerstore.la \ 148 libgnunetpeerstore.la \
149 $(top_builddir)/src/testing/libgnunettesting.la \ 149 $(top_builddir)/src/testing/libgnunettesting.la \
150 $(top_builddir)/src/util/libgnunetutil.la 150 $(top_builddir)/src/lib/util/libgnunetutil.la