aboutsummaryrefslogtreecommitdiff
path: root/src/plugin/namestore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugin/namestore/Makefile.am')
-rw-r--r--src/plugin/namestore/Makefile.am439
1 files changed, 439 insertions, 0 deletions
diff --git a/src/plugin/namestore/Makefile.am b/src/plugin/namestore/Makefile.am
new file mode 100644
index 000000000..3c8e9d170
--- /dev/null
+++ b/src/plugin/namestore/Makefile.am
@@ -0,0 +1,439 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include $(POSTGRESQL_CPPFLAGS)
3
4plugindir = $(libdir)/gnunet
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8libexecdir= $(pkglibdir)/libexec/
9
10sqldir = $(prefix)/share/gnunet/sql/
11
12sql_DATA = \
13 namestore-0001.sql \
14 namestore-drop.sql
15
16if USE_COVERAGE
17 AM_CFLAGS = --coverage -O0
18 XLIBS = -lgcov
19endif
20
21
22if HAVE_SQLITE
23SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
24SQLITE_TESTS = test_plugin_namestore_sqlite \
25 test_namestore_api_store_sqlite \
26 test_namestore_api_store_update_sqlite \
27 test_namestore_api_zone_iteration_sqlite \
28 test_namestore_api_remove_sqlite \
29 test_namestore_api_lookup_nick_sqlite \
30 test_namestore_api_monitoring_sqlite \
31 test_namestore_api_remove_not_existing_record_sqlite \
32 test_namestore_api_zone_iteration_nick_sqlite \
33 test_namestore_api_zone_iteration_specific_zone_sqlite \
34 test_namestore_api_zone_iteration_stop_sqlite \
35 test_namestore_api_monitoring_existing_sqlite \
36 test_namestore_api_zone_to_name_sqlite \
37 perf_namestore_api_zone_iteration_sqlite \
38 perf_namestore_api_import_sqlite \
39 perf_namestore_api_import_postgres \
40 test_namestore_api_tx_rollback_sqlite
41endif
42
43
44if HAVE_POSTGRESQL
45POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la
46POSTGRES_TESTS = test_plugin_namestore_postgres \
47 test_namestore_api_store_postgres \
48 test_namestore_api_store_update_postgres \
49 test_namestore_api_remove_postgres \
50 test_namestore_api_zone_iteration_postgres \
51 test_namestore_api_lookup_nick_postgres \
52 test_namestore_api_monitoring_postgres \
53 test_namestore_api_remove_not_existing_record_postgres \
54 test_namestore_api_zone_iteration_nick_postgres \
55 test_namestore_api_zone_iteration_specific_zone_postgres \
56 test_namestore_api_zone_iteration_stop_postgres \
57 test_namestore_api_monitoring_existing_postgres \
58 test_namestore_api_zone_to_name_postgres \
59 perf_namestore_api_zone_iteration_postgres \
60 test_namestore_api_tx_rollback_postgres
61if HAVE_EXPERIMENTAL
62POSTGRES_TESTS += test_namestore_api_edit_records_postgres
63endif
64endif
65
66if HAVE_SQLITE
67check_PROGRAMS = \
68 $(SQLITE_TESTS) \
69 $(POSTGRES_TESTS)
70endif
71
72if ENABLE_TEST_RUN
73AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
74TESTS = \
75 $(check_PROGRAMS) \
76 $(check_SCRIPTS)
77endif
78
79REST_PLUGIN = libgnunet_plugin_rest_namestore.la
80
81plugin_LTLIBRARIES = \
82 $(SQLITE_PLUGIN) \
83 $(POSTGRES_PLUGIN) \
84 $(REST_PLUGIN)
85
86
87libgnunet_plugin_rest_namestore_la_SOURCES = \
88 plugin_rest_namestore.c
89libgnunet_plugin_rest_namestore_la_LIBADD = \
90 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
91 $(top_builddir)/src/service/rest/libgnunetrest.la \
92 $(top_builddir)/src/service/identity/libgnunetidentity.la \
93 $(top_builddir)/src/lib/json/libgnunetjson.la \
94 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
95 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecordjson.la \
96 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIBS) \
97 $(LTLIBINTL) -ljansson $(MHD_LIBS)
98libgnunet_plugin_rest_namestore_la_LDFLAGS = \
99 $(GN_PLUGIN_LDFLAGS)
100libgnunet_plugin_rest_namestore_la_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)
101
102
103libgnunet_plugin_namestore_sqlite_la_SOURCES = \
104 plugin_namestore_sqlite.c
105libgnunet_plugin_namestore_sqlite_la_LIBADD = \
106 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
107 $(top_builddir)/src/service/identity/libgnunetidentity.la \
108 $(top_builddir)/src/lib/sq/libgnunetsq.la \
109 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
110 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIBS) -lsqlite3 \
111 $(LTLIBINTL)
112libgnunet_plugin_namestore_sqlite_la_LDFLAGS = \
113 $(GN_PLUGIN_LDFLAGS)
114
115libgnunet_plugin_namestore_postgres_la_SOURCES = \
116 plugin_namestore_postgres.c
117libgnunet_plugin_namestore_postgres_la_LIBADD = \
118 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
119 $(top_builddir)/src/service/identity/libgnunetidentity.la \
120 $(top_builddir)/src/lib/pq/libgnunetpq.la \
121 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
122 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIBS) -lpq \
123 $(LTLIBINTL)
124libgnunet_plugin_namestore_postgres_la_LDFLAGS = \
125 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS)
126
127test_namestore_api_store_sqlite_SOURCES = \
128 test_namestore_api_store.c
129test_namestore_api_store_sqlite_LDADD = \
130 $(top_builddir)/src/service/testing/libgnunettesting.la \
131 $(top_builddir)/src/lib/util/libgnunetutil.la \
132 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
133 $(top_builddir)/src/service/identity/libgnunetidentity.la \
134 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
135
136test_namestore_api_store_postgres_SOURCES = \
137 test_namestore_api_store.c
138test_namestore_api_store_postgres_LDADD = \
139 $(top_builddir)/src/service/testing/libgnunettesting.la \
140 $(top_builddir)/src/lib/util/libgnunetutil.la \
141 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
142 $(top_builddir)/src/service/identity/libgnunetidentity.la \
143 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
144
145test_namestore_api_store_update_sqlite_SOURCES = \
146 test_namestore_api_store_update.c
147test_namestore_api_store_update_sqlite_LDADD = \
148 $(top_builddir)/src/service/testing/libgnunettesting.la \
149 $(top_builddir)/src/lib/util/libgnunetutil.la \
150 $(top_builddir)/src/service/identity/libgnunetidentity.la \
151 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
152 $(top_builddir)/src/service/namecache/libgnunetnamecache.la \
153 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
154
155test_namestore_api_store_update_postgres_SOURCES = \
156 test_namestore_api_store_update.c
157test_namestore_api_store_update_postgres_LDADD = \
158 $(top_builddir)/src/service/testing/libgnunettesting.la \
159 $(top_builddir)/src/lib/util/libgnunetutil.la \
160 $(top_builddir)/src/service/identity/libgnunetidentity.la \
161 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
162 $(top_builddir)/src/service/namecache/libgnunetnamecache.la \
163 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
164
165test_namestore_api_lookup_nick_sqlite_SOURCES = \
166 test_namestore_api_lookup_nick.c
167test_namestore_api_lookup_nick_sqlite_LDADD = \
168 $(top_builddir)/src/service/testing/libgnunettesting.la \
169 $(top_builddir)/src/lib/util/libgnunetutil.la \
170 $(top_builddir)/src/service/identity/libgnunetidentity.la \
171 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
172 $(top_builddir)/src/service/namecache/libgnunetnamecache.la \
173 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
174
175test_namestore_api_lookup_nick_postgres_SOURCES = \
176 test_namestore_api_lookup_nick.c
177test_namestore_api_lookup_nick_postgres_LDADD = \
178 $(top_builddir)/src/service/testing/libgnunettesting.la \
179 $(top_builddir)/src/lib/util/libgnunetutil.la \
180 $(top_builddir)/src/service/identity/libgnunetidentity.la \
181 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
182 $(top_builddir)/src/service/namecache/libgnunetnamecache.la \
183 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
184
185test_namestore_api_remove_sqlite_SOURCES = \
186 test_namestore_api_remove.c
187test_namestore_api_remove_sqlite_LDADD = \
188 $(top_builddir)/src/service/identity/libgnunetidentity.la \
189 $(top_builddir)/src/service/testing/libgnunettesting.la \
190 $(top_builddir)/src/lib/util/libgnunetutil.la \
191 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
192 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
193
194test_namestore_api_remove_postgres_SOURCES = \
195 test_namestore_api_remove.c
196test_namestore_api_remove_postgres_LDADD = \
197 $(top_builddir)/src/service/identity/libgnunetidentity.la \
198 $(top_builddir)/src/service/testing/libgnunettesting.la \
199 $(top_builddir)/src/lib/util/libgnunetutil.la \
200 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
201 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
202
203test_namestore_api_remove_not_existing_record_sqlite_SOURCES = \
204 test_namestore_api_remove_not_existing_record.c
205test_namestore_api_remove_not_existing_record_sqlite_LDADD = \
206 $(top_builddir)/src/service/testing/libgnunettesting.la \
207 $(top_builddir)/src/lib/util/libgnunetutil.la \
208 $(top_builddir)/src/service/identity/libgnunetidentity.la \
209 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
210 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
211
212test_namestore_api_remove_not_existing_record_postgres_SOURCES = \
213 test_namestore_api_remove_not_existing_record.c
214test_namestore_api_remove_not_existing_record_postgres_LDADD = \
215 $(top_builddir)/src/service/testing/libgnunettesting.la \
216 $(top_builddir)/src/service/identity/libgnunetidentity.la \
217 $(top_builddir)/src/lib/util/libgnunetutil.la \
218 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
219 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
220
221test_namestore_api_zone_to_name_sqlite_SOURCES = \
222 test_namestore_api_zone_to_name.c
223test_namestore_api_zone_to_name_sqlite_LDADD = \
224 $(top_builddir)/src/service/identity/libgnunetidentity.la \
225 $(top_builddir)/src/service/testing/libgnunettesting.la \
226 $(top_builddir)/src/lib/util/libgnunetutil.la \
227 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
228
229test_namestore_api_zone_to_name_postgres_SOURCES = \
230 test_namestore_api_zone_to_name.c
231test_namestore_api_zone_to_name_postgres_LDADD = \
232 $(top_builddir)/src/service/identity/libgnunetidentity.la \
233 $(top_builddir)/src/service/testing/libgnunettesting.la \
234 $(top_builddir)/src/lib/util/libgnunetutil.la \
235 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
236
237test_namestore_api_monitoring_sqlite_SOURCES = \
238 test_namestore_api_monitoring.c
239test_namestore_api_monitoring_sqlite_LDADD = \
240 $(top_builddir)/src/service/identity/libgnunetidentity.la \
241 $(top_builddir)/src/service/testing/libgnunettesting.la \
242 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
243 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
244 $(top_builddir)/src/lib/util/libgnunetutil.la
245
246test_namestore_api_monitoring_postgres_SOURCES = \
247 test_namestore_api_monitoring.c
248test_namestore_api_monitoring_postgres_LDADD = \
249 $(top_builddir)/src/service/testing/libgnunettesting.la \
250 $(top_builddir)/src/service/identity/libgnunetidentity.la \
251 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
252 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
253 $(top_builddir)/src/lib/util/libgnunetutil.la
254
255test_namestore_api_monitoring_existing_sqlite_SOURCES = \
256 test_namestore_api_monitoring_existing.c
257test_namestore_api_monitoring_existing_sqlite_LDADD = \
258 $(top_builddir)/src/service/testing/libgnunettesting.la \
259 $(top_builddir)/src/service/identity/libgnunetidentity.la \
260 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
261 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
262 $(top_builddir)/src/lib/util/libgnunetutil.la
263
264test_namestore_api_monitoring_existing_postgres_SOURCES = \
265 test_namestore_api_monitoring_existing.c
266test_namestore_api_monitoring_existing_postgres_LDADD = \
267 $(top_builddir)/src/service/testing/libgnunettesting.la \
268 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
269 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
270 $(top_builddir)/src/service/identity/libgnunetidentity.la \
271 $(top_builddir)/src/lib/util/libgnunetutil.la
272
273test_namestore_api_tx_rollback_sqlite_SOURCES = \
274 test_namestore_api_tx_rollback.c
275test_namestore_api_tx_rollback_sqlite_LDADD = \
276 $(top_builddir)/src/service/testing/libgnunettesting.la \
277 $(top_builddir)/src/service/identity/libgnunetidentity.la \
278 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
279 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
280 $(top_builddir)/src/lib/util/libgnunetutil.la
281
282test_namestore_api_tx_rollback_postgres_SOURCES = \
283 test_namestore_api_tx_rollback.c
284test_namestore_api_tx_rollback_postgres_LDADD = \
285 $(top_builddir)/src/service/testing/libgnunettesting.la \
286 $(top_builddir)/src/service/identity/libgnunetidentity.la \
287 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
288 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
289 $(top_builddir)/src/lib/util/libgnunetutil.la
290
291if HAVE_EXPERIMENTAL
292test_namestore_api_edit_records_postgres_SOURCES = \
293 test_namestore_api_edit_records.c
294test_namestore_api_edit_records_postgres_LDADD = \
295 $(top_builddir)/src/service/testing/libgnunettesting.la \
296 $(top_builddir)/src/service/identity/libgnunetidentity.la \
297 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
298 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
299 $(top_builddir)/src/lib/util/libgnunetutil.la
300endif
301
302test_namestore_api_zone_iteration_sqlite_SOURCES = \
303 test_namestore_api_zone_iteration.c
304test_namestore_api_zone_iteration_sqlite_LDADD = \
305 $(top_builddir)/src/service/testing/libgnunettesting.la \
306 $(top_builddir)/src/service/identity/libgnunetidentity.la \
307 $(top_builddir)/src/lib/util/libgnunetutil.la \
308 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
309 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
310
311test_namestore_api_zone_iteration_postgres_SOURCES = \
312 test_namestore_api_zone_iteration.c
313test_namestore_api_zone_iteration_postgres_LDADD = \
314 $(top_builddir)/src/service/testing/libgnunettesting.la \
315 $(top_builddir)/src/service/identity/libgnunetidentity.la \
316 $(top_builddir)/src/lib/util/libgnunetutil.la \
317 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
318 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
319
320perf_namestore_api_zone_iteration_postgres_SOURCES = \
321 perf_namestore_api_zone_iteration.c
322perf_namestore_api_zone_iteration_postgres_LDADD = \
323 $(top_builddir)/src/service/testing/libgnunettesting.la \
324 $(top_builddir)/src/lib/util/libgnunetutil.la \
325 $(top_builddir)/src/service/identity/libgnunetidentity.la \
326 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
327 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
328
329perf_namestore_api_import_sqlite_SOURCES = \
330 perf_namestore_api_import.c
331perf_namestore_api_import_sqlite_LDADD = \
332 $(top_builddir)/src/service/testing/libgnunettesting.la \
333 $(top_builddir)/src/lib/util/libgnunetutil.la \
334 $(top_builddir)/src/service/identity/libgnunetidentity.la \
335 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
336 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
337
338perf_namestore_api_import_postgres_SOURCES = \
339 perf_namestore_api_import.c
340perf_namestore_api_import_postgres_LDADD = \
341 $(top_builddir)/src/service/testing/libgnunettesting.la \
342 $(top_builddir)/src/lib/util/libgnunetutil.la \
343 $(top_builddir)/src/service/identity/libgnunetidentity.la \
344 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
345 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
346
347
348perf_namestore_api_zone_iteration_sqlite_SOURCES = \
349 perf_namestore_api_zone_iteration.c
350perf_namestore_api_zone_iteration_sqlite_LDADD = \
351 $(top_builddir)/src/service/testing/libgnunettesting.la \
352 $(top_builddir)/src/service/identity/libgnunetidentity.la \
353 $(top_builddir)/src/lib/util/libgnunetutil.la \
354 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
355 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
356
357test_namestore_api_zone_iteration_nick_sqlite_SOURCES = \
358 test_namestore_api_zone_iteration_nick.c
359test_namestore_api_zone_iteration_nick_sqlite_LDADD = \
360 $(top_builddir)/src/service/testing/libgnunettesting.la \
361 $(top_builddir)/src/service/identity/libgnunetidentity.la \
362 $(top_builddir)/src/lib/util/libgnunetutil.la \
363 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
364 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
365
366test_namestore_api_zone_iteration_nick_postgres_SOURCES = \
367 test_namestore_api_zone_iteration_nick.c
368test_namestore_api_zone_iteration_nick_postgres_LDADD = \
369 $(top_builddir)/src/service/testing/libgnunettesting.la \
370 $(top_builddir)/src/service/identity/libgnunetidentity.la \
371 $(top_builddir)/src/lib/util/libgnunetutil.la \
372 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
373 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
374
375test_namestore_api_zone_iteration_specific_zone_sqlite_SOURCES = \
376 test_namestore_api_zone_iteration_specific_zone.c
377test_namestore_api_zone_iteration_specific_zone_sqlite_LDADD = \
378 $(top_builddir)/src/service/testing/libgnunettesting.la \
379 $(top_builddir)/src/service/identity/libgnunetidentity.la \
380 $(top_builddir)/src/lib/util/libgnunetutil.la \
381 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
382 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
383
384test_namestore_api_zone_iteration_specific_zone_postgres_SOURCES = \
385 test_namestore_api_zone_iteration_specific_zone.c
386test_namestore_api_zone_iteration_specific_zone_postgres_LDADD = \
387 $(top_builddir)/src/service/testing/libgnunettesting.la \
388 $(top_builddir)/src/service/identity/libgnunetidentity.la \
389 $(top_builddir)/src/lib/util/libgnunetutil.la \
390 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
391 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
392
393test_namestore_api_zone_iteration_stop_sqlite_SOURCES = \
394 test_namestore_api_zone_iteration_stop.c
395test_namestore_api_zone_iteration_stop_sqlite_LDADD = \
396 $(top_builddir)/src/service/testing/libgnunettesting.la \
397 $(top_builddir)/src/service/identity/libgnunetidentity.la \
398 $(top_builddir)/src/lib/util/libgnunetutil.la \
399 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
400 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
401
402test_namestore_api_zone_iteration_stop_postgres_SOURCES = \
403 test_namestore_api_zone_iteration_stop.c
404test_namestore_api_zone_iteration_stop_postgres_LDADD = \
405 $(top_builddir)/src/service/testing/libgnunettesting.la \
406 $(top_builddir)/src/service/identity/libgnunetidentity.la \
407 $(top_builddir)/src/lib/util/libgnunetutil.la \
408 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
409 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
410
411test_plugin_namestore_sqlite_SOURCES = \
412 test_plugin_namestore.c
413test_plugin_namestore_sqlite_LDADD = \
414 $(top_builddir)/src/service/testing/libgnunettesting.la \
415 $(top_builddir)/src/service/identity/libgnunetidentity.la \
416 $(top_builddir)/src/lib/util/libgnunetutil.la
417
418test_plugin_namestore_postgres_SOURCES = \
419 test_plugin_namestore.c
420test_plugin_namestore_postgres_LDADD = \
421 $(top_builddir)/src/service/identity/libgnunetidentity.la \
422 $(top_builddir)/src/service/testing/libgnunettesting.la \
423 $(top_builddir)/src/lib/util/libgnunetutil.la
424
425check_SCRIPTS = \
426 test_plugin_rest_namestore.sh
427
428EXTRA_DIST = \
429 test_common.c \
430 test_namestore_api.conf \
431 test_namestore_api_postgres.conf \
432 test_namestore_api_sqlite.conf \
433 perf_namestore_api_postgres.conf \
434 perf_namestore_api_sqlite.conf \
435 test_plugin_namestore_sqlite.conf \
436 test_plugin_namestore_postgres.conf \
437 test_hostkey \
438 $(check_SCRIPTS) \
439 $(sql_DATA)