aboutsummaryrefslogtreecommitdiff
path: root/src/plugin/peerstore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugin/peerstore/Makefile.am')
-rw-r--r--src/plugin/peerstore/Makefile.am25
1 files changed, 2 insertions, 23 deletions
diff --git a/src/plugin/peerstore/Makefile.am b/src/plugin/peerstore/Makefile.am
index 225e9a71e..7202aef84 100644
--- a/src/plugin/peerstore/Makefile.am
+++ b/src/plugin/peerstore/Makefile.am
@@ -11,18 +11,6 @@ if USE_COVERAGE
11 AM_CFLAGS = -fprofile-arcs -ftest-coverage 11 AM_CFLAGS = -fprofile-arcs -ftest-coverage
12endif 12endif
13 13
14if HAVE_EXPERIMENTAL
15FLAT_PLUGIN = libgnunet_plugin_peerstore_flat.la
16FLAT_TESTS = test_plugin_peerstore_flat
17libgnunet_plugin_peerstore_flat_la_SOURCES = \
18 plugin_peerstore_flat.c
19libgnunet_plugin_peerstore_flat_la_LIBADD = \
20 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIBS) \
21 $(LTLIBINTL)
22libgnunet_plugin_peerstore_flat_la_LDFLAGS = \
23 $(GN_PLUGIN_LDFLAGS)
24endif
25
26if HAVE_SQLITE 14if HAVE_SQLITE
27SQLITE_PLUGIN = libgnunet_plugin_peerstore_sqlite.la 15SQLITE_PLUGIN = libgnunet_plugin_peerstore_sqlite.la
28SQLITE_TESTS = test_plugin_peerstore_sqlite 16SQLITE_TESTS = test_plugin_peerstore_sqlite
@@ -38,8 +26,7 @@ libgnunet_plugin_peerstore_sqlite_la_LDFLAGS = \
38endif 26endif
39 27
40plugin_LTLIBRARIES = \ 28plugin_LTLIBRARIES = \
41 $(SQLITE_PLUGIN) \ 29 $(SQLITE_PLUGIN)
42 $(FLAT_PLUGIN)
43 30
44test_plugin_peerstore_sqlite_SOURCES = \ 31test_plugin_peerstore_sqlite_SOURCES = \
45 test_plugin_peerstore.c 32 test_plugin_peerstore.c
@@ -47,18 +34,10 @@ test_plugin_peerstore_sqlite_LDADD = \
47 $(top_builddir)/src/service/testing/libgnunettesting.la \ 34 $(top_builddir)/src/service/testing/libgnunettesting.la \
48 $(top_builddir)/src/lib/util/libgnunetutil.la 35 $(top_builddir)/src/lib/util/libgnunetutil.la
49 36
50test_plugin_peerstore_flat_SOURCES = \
51 test_plugin_peerstore.c
52test_plugin_peerstore_flat_LDADD = \
53 $(top_builddir)/src/service/testing/libgnunettesting.la \
54 $(top_builddir)/src/lib/util/libgnunetutil.la
55
56check_PROGRAMS = \ 37check_PROGRAMS = \
57 $(SQLITE_TESTS) \ 38 $(SQLITE_TESTS)
58 $(FLAT_TESTS)
59 39
60EXTRA_DIST = \ 40EXTRA_DIST = \
61 test_plugin_peerstore_flat.conf \
62 test_plugin_peerstore_sqlite.conf 41 test_plugin_peerstore_sqlite.conf
63 42
64if ENABLE_TEST_RUN 43if ENABLE_TEST_RUN