aboutsummaryrefslogtreecommitdiff
path: root/src/psycstore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/psycstore/Makefile.am')
-rw-r--r--src/psycstore/Makefile.am72
1 files changed, 72 insertions, 0 deletions
diff --git a/src/psycstore/Makefile.am b/src/psycstore/Makefile.am
new file mode 100644
index 000000000..461ec6c4e
--- /dev/null
+++ b/src/psycstore/Makefile.am
@@ -0,0 +1,72 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = --coverage -O0
9 XLIB = -lgcov
10endif
11
12pkgcfgdir= $(pkgdatadir)/config.d/
13
14libexecdir= $(pkglibdir)/libexec/
15
16pkgcfg_DATA = \
17 psycstore.conf
18
19
20lib_LTLIBRARIES = libgnunetpsycstore.la
21
22libgnunetpsycstore_la_SOURCES = \
23 psycstore_api.c \
24 psycstore.h
25libgnunetpsycstore_la_LIBADD = \
26 $(top_builddir)/src/util/libgnunetutil.la \
27 $(GN_LIBINTL) $(XLIB)
28libgnunetpsycstore_la_LDFLAGS = \
29 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
30 -version-info 0:0:0
31libgnunetpsycstore_la_DEPENDENCIES = \
32 $(top_builddir)/src/util/libgnunetutil.la
33
34bin_PROGRAMS =
35
36libexec_PROGRAMS = \
37 gnunet-service-psycstore
38
39gnunet_service_psycstore_SOURCES = \
40 gnunet-service-psycstore.c
41gnunet_service_psycstore_LDADD = \
42 $(top_builddir)/src/statistics/libgnunetstatistics.la \
43 $(top_builddir)/src/util/libgnunetutil.la \
44 $(GN_LIBINTL)
45gnunet_service_psycstore_DEPENDENCIES = \
46 $(top_builddir)/src/statistics/libgnunetstatistics.la \
47 $(top_builddir)/src/util/libgnunetutil.la
48
49if HAVE_TESTING
50check_PROGRAMS = \
51 test_psycstore
52endif
53
54if ENABLE_TEST_RUN
55TESTS = $(check_PROGRAMS)
56endif
57
58test_psycstore_SOURCES = \
59 test_psycstore.c
60test_psycstore_LDADD = \
61 libgnunetpsycstore.la \
62 $(top_builddir)/src/testing/libgnunettesting.la \
63 $(top_builddir)/src/util/libgnunetutil.la
64test_psycstore_DEPENDENCIES = \
65 libgnunetpsycstore.la \
66 $(top_builddir)/src/testing/libgnunettesting.la \
67 $(top_builddir)/src/util/libgnunetutil.la
68
69EXTRA_DIST = \
70 test_psycstore.conf
71
72