aboutsummaryrefslogtreecommitdiff
path: root/src/pt/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/pt/Makefile.am')
-rw-r--r--src/pt/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/pt/Makefile.am b/src/pt/Makefile.am
new file mode 100644
index 000000000..c43787133
--- /dev/null
+++ b/src/pt/Makefile.am
@@ -0,0 +1,29 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = --coverage -O0
9endif
10
11pkgcfgdir= $(pkgdatadir)/config.d/
12
13plugindir = $(libdir)/gnunet
14
15dist_pkgcfg_DATA = \
16 pt.conf
17
18bin_PROGRAMS = \
19 gnunet-daemon-pt $(PTBIN)
20
21gnunet_daemon_pt_SOURCES = \
22 gnunet-daemon-pt.c
23gnunet_daemon_pt_LDADD = \
24 $(top_builddir)/src/vpn/libgnunetvpn.la \
25 $(top_builddir)/src/dns/libgnunetdns.la \
26 $(top_builddir)/src/statistics/libgnunetstatistics.la \
27 $(top_builddir)/src/util/libgnunetutil.la \
28 $(top_builddir)/src/mesh/libgnunetmesh.la \
29 $(GN_LIBINTL)