aboutsummaryrefslogtreecommitdiff
path: root/src/pt/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/pt/Makefile.am')
-rw-r--r--src/pt/Makefile.am36
1 files changed, 18 insertions, 18 deletions
diff --git a/src/pt/Makefile.am b/src/pt/Makefile.am
index aff43b2ef..76d5d8c80 100644
--- a/src/pt/Makefile.am
+++ b/src/pt/Makefile.am
@@ -18,10 +18,10 @@ dist_pkgcfg_DATA = \
18 pt.conf 18 pt.conf
19 19
20libexec_PROGRAMS = \ 20libexec_PROGRAMS = \
21 gnunet-daemon-pt 21 gnunet-daemon-pt
22 22
23gnunet_daemon_pt_SOURCES = \ 23gnunet_daemon_pt_SOURCES = \
24 gnunet-daemon-pt.c 24 gnunet-daemon-pt.c
25gnunet_daemon_pt_LDADD = \ 25gnunet_daemon_pt_LDADD = \
26 $(top_builddir)/src/vpn/libgnunetvpn.la \ 26 $(top_builddir)/src/vpn/libgnunetvpn.la \
27 $(top_builddir)/src/mesh/libgnunetmesh.la \ 27 $(top_builddir)/src/mesh/libgnunetmesh.la \
@@ -34,7 +34,7 @@ gnunet_daemon_pt_LDADD = \
34 34
35if HAVE_TESTING 35if HAVE_TESTING
36if HAVE_MHD 36if HAVE_MHD
37if HAVE_LIBCURL 37if HAVE_LIBGNURL
38if LINUX 38if LINUX
39 VPN_TEST = \ 39 VPN_TEST = \
40 test_gnunet_vpn-4_to_6 \ 40 test_gnunet_vpn-4_to_6 \
@@ -48,7 +48,7 @@ if MINGW
48 test_gnunet_vpn-4_to_6 \ 48 test_gnunet_vpn-4_to_6 \
49 test_gnunet_vpn-6_to_4 \ 49 test_gnunet_vpn-6_to_4 \
50 test_gnunet_vpn-6_over \ 50 test_gnunet_vpn-6_over \
51 test_gnunet_vpn-4_over 51 test_gnunet_vpn-4_over
52endif 52endif
53endif 53endif
54endif 54endif
@@ -68,47 +68,47 @@ EXTRA_DIST = \
68 68
69test_gns_vpn_SOURCES = \ 69test_gns_vpn_SOURCES = \
70 test_gns_vpn.c 70 test_gns_vpn.c
71test_gns_vpn_LDADD = -lmicrohttpd @LIBCURL@ \ 71test_gns_vpn_LDADD = -lmicrohttpd @LIBGNURL@ \
72 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 72 $(top_builddir)/src/namestore/libgnunetnamestore.la \
73 $(top_builddir)/src/testing/libgnunettesting.la \ 73 $(top_builddir)/src/testing/libgnunettesting.la \
74 $(top_builddir)/src/util/libgnunetutil.la 74 $(top_builddir)/src/util/libgnunetutil.la
75test_gns_vpn_CPPFLAGS = \ 75test_gns_vpn_CPPFLAGS = \
76 @LIBCURL_CPPFLAGS@ $(AM_CPPFLAGS) 76 @LIBGNURL_CPPFLAGS@ $(AM_CPPFLAGS)
77 77
78test_gnunet_vpn_4_over_SOURCES = \ 78test_gnunet_vpn_4_over_SOURCES = \
79 test_gnunet_vpn.c 79 test_gnunet_vpn.c
80test_gnunet_vpn_4_over_LDADD = -lmicrohttpd @LIBCURL@ \ 80test_gnunet_vpn_4_over_LDADD = -lmicrohttpd @LIBGNURL@ \
81 $(top_builddir)/src/vpn/libgnunetvpn.la \ 81 $(top_builddir)/src/vpn/libgnunetvpn.la \
82 $(top_builddir)/src/testing/libgnunettesting.la \ 82 $(top_builddir)/src/testing/libgnunettesting.la \
83 $(top_builddir)/src/util/libgnunetutil.la 83 $(top_builddir)/src/util/libgnunetutil.la
84test_gnunet_vpn_4_over_CPPFLAGS = \ 84test_gnunet_vpn_4_over_CPPFLAGS = \
85 @LIBCURL_CPPFLAGS@ $(AM_CPPFLAGS) 85 @LIBGNURL_CPPFLAGS@ $(AM_CPPFLAGS)
86 86
87test_gnunet_vpn_6_over_SOURCES = \ 87test_gnunet_vpn_6_over_SOURCES = \
88 test_gnunet_vpn.c 88 test_gnunet_vpn.c
89test_gnunet_vpn_6_over_LDADD = -lmicrohttpd @LIBCURL@ \ 89test_gnunet_vpn_6_over_LDADD = -lmicrohttpd @LIBGNURL@ \
90 $(top_builddir)/src/vpn/libgnunetvpn.la \ 90 $(top_builddir)/src/vpn/libgnunetvpn.la \
91 $(top_builddir)/src/testing/libgnunettesting.la \ 91 $(top_builddir)/src/testing/libgnunettesting.la \
92 $(top_builddir)/src/util/libgnunetutil.la 92 $(top_builddir)/src/util/libgnunetutil.la
93test_gnunet_vpn_6_over_CPPFLAGS = \ 93test_gnunet_vpn_6_over_CPPFLAGS = \
94 @LIBCURL_CPPFLAGS@ $(AM_CPPFLAGS) 94 @LIBGNURL_CPPFLAGS@ $(AM_CPPFLAGS)
95 95
96test_gnunet_vpn_4_to_6_SOURCES = \ 96test_gnunet_vpn_4_to_6_SOURCES = \
97 test_gnunet_vpn.c 97 test_gnunet_vpn.c
98test_gnunet_vpn_4_to_6_LDADD = -lmicrohttpd @LIBCURL@ \ 98test_gnunet_vpn_4_to_6_LDADD = -lmicrohttpd @LIBGNURL@ \
99 $(top_builddir)/src/vpn/libgnunetvpn.la \ 99 $(top_builddir)/src/vpn/libgnunetvpn.la \
100 $(top_builddir)/src/testing/libgnunettesting.la \ 100 $(top_builddir)/src/testing/libgnunettesting.la \
101 $(top_builddir)/src/util/libgnunetutil.la 101 $(top_builddir)/src/util/libgnunetutil.la
102test_gnunet_vpn_4_to_6_CPPFLAGS = \ 102test_gnunet_vpn_4_to_6_CPPFLAGS = \
103 @LIBCURL_CPPFLAGS@ $(AM_CPPFLAGS) 103 @LIBGNURL_CPPFLAGS@ $(AM_CPPFLAGS)
104 104
105test_gnunet_vpn_6_to_4_SOURCES = \ 105test_gnunet_vpn_6_to_4_SOURCES = \
106 test_gnunet_vpn.c 106 test_gnunet_vpn.c
107test_gnunet_vpn_6_to_4_LDADD = -lmicrohttpd @LIBCURL@ \ 107test_gnunet_vpn_6_to_4_LDADD = -lmicrohttpd @LIBGNURL@ \
108 $(top_builddir)/src/vpn/libgnunetvpn.la \ 108 $(top_builddir)/src/vpn/libgnunetvpn.la \
109 $(top_builddir)/src/testing/libgnunettesting.la \ 109 $(top_builddir)/src/testing/libgnunettesting.la \
110 $(top_builddir)/src/util/libgnunetutil.la 110 $(top_builddir)/src/util/libgnunetutil.la
111test_gnunet_vpn_6_to_4_CPPFLAGS = \ 111test_gnunet_vpn_6_to_4_CPPFLAGS = \
112 @LIBCURL_CPPFLAGS@ $(AM_CPPFLAGS) 112 @LIBGNURL_CPPFLAGS@ $(AM_CPPFLAGS)
113 113
114 114