aboutsummaryrefslogtreecommitdiff
path: root/src/rest/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/rest/Makefile.am')
-rw-r--r--src/rest/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/src/rest/Makefile.am b/src/rest/Makefile.am
index acb95140b..8fe48198f 100644
--- a/src/rest/Makefile.am
+++ b/src/rest/Makefile.am
@@ -23,9 +23,11 @@ lib_LTLIBRARIES = \
23 libgnunetrest.la 23 libgnunetrest.la
24 24
25libexec_PROGRAMS = \ 25libexec_PROGRAMS = \
26 gnunet-rest-server 26 gnunet-rest-server
27 27
28plugin_LTLIBRARIES = libgnunet_plugin_rest_copying.la 28plugin_LTLIBRARIES = \
29 libgnunet_plugin_rest_copying.la \
30 libgnunet_plugin_rest_config.la
29 31
30EXTRA_DIST = \ 32EXTRA_DIST = \
31 rest.conf 33 rest.conf
@@ -39,6 +41,15 @@ libgnunet_plugin_rest_copying_la_LIBADD = \
39libgnunet_plugin_rest_copying_la_LDFLAGS = \ 41libgnunet_plugin_rest_copying_la_LDFLAGS = \
40 $(GN_PLUGIN_LDFLAGS) 42 $(GN_PLUGIN_LDFLAGS)
41 43
44libgnunet_plugin_rest_config_la_SOURCES = \
45 plugin_rest_config.c
46libgnunet_plugin_rest_config_la_LIBADD = \
47 libgnunetrest.la \
48 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
49 $(LTLIBINTL) -lmicrohttpd -ljansson
50libgnunet_plugin_rest_config_la_LDFLAGS = \
51 $(GN_PLUGIN_LDFLAGS)
52
42 53
43 54
44gnunet_rest_server_SOURCES = \ 55gnunet_rest_server_SOURCES = \