aboutsummaryrefslogtreecommitdiff
path: root/src/rest/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/rest/Makefile.am')
-rw-r--r--src/rest/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/rest/Makefile.am b/src/rest/Makefile.am
index 00021cce2..8ea87fc6a 100644
--- a/src/rest/Makefile.am
+++ b/src/rest/Makefile.am
@@ -20,6 +20,9 @@ if USE_COVERAGE
20 XLIBS = -lgcov 20 XLIBS = -lgcov
21endif 21endif
22 22
23lib_LTLIBRARIES = \
24 libgnunetrest.la
25
23libexec_PROGRAMS = \ 26libexec_PROGRAMS = \
24 gnunet-rest-server 27 gnunet-rest-server
25 28
@@ -29,3 +32,12 @@ gnunet_rest_server_SOURCES = \
29gnunet_rest_server_LDADD = \ 32gnunet_rest_server_LDADD = \
30 $(top_builddir)/src/util/libgnunetutil.la \ 33 $(top_builddir)/src/util/libgnunetutil.la \
31 $(GN_LIBINTL) -lmicrohttpd 34 $(GN_LIBINTL) -lmicrohttpd
35
36libgnunetrest_la_SOURCES = \
37 rest.c
38libgnunetrest_la_LIBADD = \
39 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) \
40 $(GN_LIBINTL) -lmicrohttpd -ljansson
41libgnunetrest_la_LDFLAGS = \
42 $(GN_LIB_LDFLAGS) \
43 -version-info 0:0:0