summaryrefslogtreecommitdiff
path: root/src/rest/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/rest/Makefile.am')
-rw-r--r--src/rest/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/rest/Makefile.am b/src/rest/Makefile.am
new file mode 100644
index 000000000..00021cce2
--- /dev/null
+++ b/src/rest/Makefile.am
@@ -0,0 +1,31 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8libexecdir= $(pkglibdir)/libexec/
9
10pkgcfg_DATA = \
11 rest.conf
12
13
14if MINGW
15 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
16endif
17
18if USE_COVERAGE
19 AM_CFLAGS = --coverage -O0
20 XLIBS = -lgcov
21endif
22
23libexec_PROGRAMS = \
24 gnunet-rest-server
25
26gnunet_rest_server_SOURCES = \
27 gnunet-rest-server.c
28
29gnunet_rest_server_LDADD = \
30 $(top_builddir)/src/util/libgnunetutil.la \
31 $(GN_LIBINTL) -lmicrohttpd