aboutsummaryrefslogtreecommitdiff
path: root/src/rps/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/rps/Makefile.am')
-rw-r--r--src/rps/Makefile.am34
1 files changed, 20 insertions, 14 deletions
diff --git a/src/rps/Makefile.am b/src/rps/Makefile.am
index de7f853c1..e6c8cd929 100644
--- a/src/rps/Makefile.am
+++ b/src/rps/Makefile.am
@@ -100,22 +100,28 @@ AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PAT
100TESTS = $(check_PROGRAMS) 100TESTS = $(check_PROGRAMS)
101endif 101endif
102 102
103test_service_rps_view_SOURCES = gnunet-service-rps_view.h gnunet-service-rps_view.c \ 103test_service_rps_view_SOURCES = \
104 test_service_rps_view.c 104 gnunet-service-rps_view.h gnunet-service-rps_view.c \
105 test_service_rps_view.c
105test_service_rps_view_LDADD = $(top_builddir)/src/util/libgnunetutil.la 106test_service_rps_view_LDADD = $(top_builddir)/src/util/libgnunetutil.la
106 107
107test_service_rps_peers_SOURCES = gnunet-service-rps_peers.h gnunet-service-rps_peers.c \ 108test_service_rps_peers_SOURCES = \
108 test_service_rps_peers.c 109 gnunet-service-rps_peers.h gnunet-service-rps_peers.c \
109test_service_rps_peers_LDADD = $(top_builddir)/src/util/libgnunetutil.la \ 110 test_service_rps_peers.c
110 $(top_builddir)/src/cadet/libgnunetcadet.la 111test_service_rps_peers_LDADD = \
111 112 $(top_builddir)/src/util/libgnunetutil.la \
112test_service_rps_custommap_SOURCES = gnunet-service-rps_custommap.h gnunet-service-rps_custommap.c \ 113 $(top_builddir)/src/cadet/libgnunetcadet.la
113 test_service_rps_custommap.c 114
114test_service_rps_custommap_LDADD = $(top_builddir)/src/util/libgnunetutil.la 115test_service_rps_custommap_SOURCES = \
115 116 gnunet-service-rps_custommap.h gnunet-service-rps_custommap.c \
116test_service_rps_sampler_elem_SOURCES = gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \ 117 test_service_rps_custommap.c
117 rps-test_util.h rps-test_util.c \ 118test_service_rps_custommap_LDADD = \
118 test_service_rps_sampler_elem.c 119 $(top_builddir)/src/util/libgnunetutil.la
120
121test_service_rps_sampler_elem_SOURCES = \
122 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
123 rps-test_util.h rps-test_util.c \
124 test_service_rps_sampler_elem.c
119test_service_rps_sampler_elem_LDADD = $(top_builddir)/src/util/libgnunetutil.la 125test_service_rps_sampler_elem_LDADD = $(top_builddir)/src/util/libgnunetutil.la
120 126
121test_rps_malicious_1_SOURCES = $(rps_test_src) 127test_rps_malicious_1_SOURCES = $(rps_test_src)