aboutsummaryrefslogtreecommitdiff
path: root/src/rps/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/rps/Makefile.am')
-rw-r--r--src/rps/Makefile.am40
1 files changed, 24 insertions, 16 deletions
diff --git a/src/rps/Makefile.am b/src/rps/Makefile.am
index e973bb7ca..a356d3dbc 100644
--- a/src/rps/Makefile.am
+++ b/src/rps/Makefile.am
@@ -20,8 +20,6 @@ pkgcfg_DATA = \
20bin_PROGRAMS = gnunet-rps 20bin_PROGRAMS = gnunet-rps
21 21
22gnunet_rps_SOURCES = \ 22gnunet_rps_SOURCES = \
23 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
24 rps-sampler_common.h rps-sampler_common.c \
25 gnunet-rps.c 23 gnunet-rps.c
26 24
27gnunet_rps_LDADD = \ 25gnunet_rps_LDADD = \
@@ -32,6 +30,9 @@ gnunet_rps_LDADD = \
32lib_LTLIBRARIES = libgnunetrps.la 30lib_LTLIBRARIES = libgnunetrps.la
33 31
34libgnunetrps_la_SOURCES = \ 32libgnunetrps_la_SOURCES = \
33 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
34 rps-test_util.h rps-test_util.c \
35 rps-sampler_common.h rps-sampler_common.c \
35 rps-sampler_client.h rps-sampler_client.c \ 36 rps-sampler_client.h rps-sampler_client.c \
36 rps_api.c rps.h 37 rps_api.c rps.h
37libgnunetrps_la_LIBADD = \ 38libgnunetrps_la_LIBADD = \
@@ -40,6 +41,8 @@ libgnunetrps_la_LIBADD = \
40libgnunetrps_la_LDFLAGS = \ 41libgnunetrps_la_LDFLAGS = \
41 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 42 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
42 -version-info 0:0:0 43 -version-info 0:0:0
44# Fix 'created both with libtool and without' error:
45libgnunetrps_la_CFLAGS = $(AM_CFLAGS)
43 46
44 47
45libexec_PROGRAMS = \ 48libexec_PROGRAMS = \
@@ -69,6 +72,7 @@ gnunet_service_rps_LDADD = \
69 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \ 72 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
70 $(top_builddir)/src/nse/libgnunetnse.la \ 73 $(top_builddir)/src/nse/libgnunetnse.la \
71 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 74 $(top_builddir)/src/statistics/libgnunetstatistics.la \
75 $(top_builddir)/src/core/libgnunetcore.la \
72 $(LIBGCRYPT_LIBS) \ 76 $(LIBGCRYPT_LIBS) \
73 -lm -lgcrypt \ 77 -lm -lgcrypt \
74 $(GN_LIBINTL) 78 $(GN_LIBINTL)
@@ -79,14 +83,15 @@ check_PROGRAMS = \
79 test_service_rps_view \ 83 test_service_rps_view \
80 test_service_rps_custommap \ 84 test_service_rps_custommap \
81 test_service_rps_sampler_elem \ 85 test_service_rps_sampler_elem \
82 test_rps_malicious_1 \
83 test_rps_malicious_2 \
84 test_rps_malicious_3 \
85 test_rps_seed_request \
86 test_rps_single_req \ 86 test_rps_single_req \
87 test_rps_req_cancel \ 87 test_rps_req_cancel \
88 test_rps_sub \
89 test_rps_seed_request \
88 test_rps_seed_big \ 90 test_rps_seed_big \
89 test_rps_churn 91 test_rps_churn \
92 test_rps_malicious_1 \
93 test_rps_malicious_2 \
94 test_rps_malicious_3
90endif 95endif
91 96
92rps_test_src = \ 97rps_test_src = \
@@ -125,15 +130,6 @@ test_service_rps_sampler_elem_SOURCES = \
125 test_service_rps_sampler_elem.c 130 test_service_rps_sampler_elem.c
126test_service_rps_sampler_elem_LDADD = $(top_builddir)/src/util/libgnunetutil.la 131test_service_rps_sampler_elem_LDADD = $(top_builddir)/src/util/libgnunetutil.la
127 132
128test_rps_malicious_1_SOURCES = $(rps_test_src)
129test_rps_malicious_1_LDADD = $(ld_rps_test_lib)
130
131test_rps_malicious_2_SOURCES = $(rps_test_src)
132test_rps_malicious_2_LDADD = $(ld_rps_test_lib)
133
134test_rps_malicious_3_SOURCES = $(rps_test_src)
135test_rps_malicious_3_LDADD = $(ld_rps_test_lib)
136
137test_rps_single_req_SOURCES = $(rps_test_src) 133test_rps_single_req_SOURCES = $(rps_test_src)
138test_rps_single_req_LDADD = $(ld_rps_test_lib) 134test_rps_single_req_LDADD = $(ld_rps_test_lib)
139 135
@@ -143,12 +139,24 @@ test_rps_seed_request_LDADD = $(ld_rps_test_lib)
143test_rps_req_cancel_SOURCES = $(rps_test_src) 139test_rps_req_cancel_SOURCES = $(rps_test_src)
144test_rps_req_cancel_LDADD = $(ld_rps_test_lib) 140test_rps_req_cancel_LDADD = $(ld_rps_test_lib)
145 141
142test_rps_sub_SOURCES = $(rps_test_src)
143test_rps_sub_LDADD = $(ld_rps_test_lib)
144
146test_rps_seed_big_SOURCES = $(rps_test_src) 145test_rps_seed_big_SOURCES = $(rps_test_src)
147test_rps_seed_big_LDADD = $(ld_rps_test_lib) 146test_rps_seed_big_LDADD = $(ld_rps_test_lib)
148 147
149test_rps_churn_SOURCES = $(rps_test_src) 148test_rps_churn_SOURCES = $(rps_test_src)
150test_rps_churn_LDADD = $(ld_rps_test_lib) 149test_rps_churn_LDADD = $(ld_rps_test_lib)
151 150
151test_rps_malicious_1_SOURCES = $(rps_test_src)
152test_rps_malicious_1_LDADD = $(ld_rps_test_lib)
153
154test_rps_malicious_2_SOURCES = $(rps_test_src)
155test_rps_malicious_2_LDADD = $(ld_rps_test_lib)
156
157test_rps_malicious_3_SOURCES = $(rps_test_src)
158test_rps_malicious_3_LDADD = $(ld_rps_test_lib)
159
152gnunet_rps_profiler_SOURCES = \ 160gnunet_rps_profiler_SOURCES = \
153 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \ 161 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
154 rps-sampler_common.h rps-sampler_common.c \ 162 rps-sampler_common.h rps-sampler_common.c \