aboutsummaryrefslogtreecommitdiff
path: root/src/testbed/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testbed/Makefile.am')
-rw-r--r--src/testbed/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/src/testbed/Makefile.am b/src/testbed/Makefile.am
index 7230888dc..93ea4cf45 100644
--- a/src/testbed/Makefile.am
+++ b/src/testbed/Makefile.am
@@ -97,7 +97,8 @@ check_PROGRAMS = \
97 test_testbed_api_testbed_run_topologyring \ 97 test_testbed_api_testbed_run_topologyring \
98 test_testbed_api_testbed_run_topologysmallworldring \ 98 test_testbed_api_testbed_run_topologysmallworldring \
99 test_testbed_api_testbed_run_topology2dtorus \ 99 test_testbed_api_testbed_run_topology2dtorus \
100 test_testbed_api_testbed_run_topologysmallworld 100 test_testbed_api_testbed_run_topologysmallworld \
101 test_testbed_api_testbed_run_topologyfromfile
101 102
102if ENABLE_TEST_RUN 103if ENABLE_TEST_RUN
103 TESTS = \ 104 TESTS = \
@@ -118,7 +119,8 @@ if ENABLE_TEST_RUN
118 test_testbed_api_testbed_run_topologyring \ 119 test_testbed_api_testbed_run_topologyring \
119 test_testbed_api_testbed_run_topologysmallworldring \ 120 test_testbed_api_testbed_run_topologysmallworldring \
120 test_testbed_api_testbed_run_topology2dtorus \ 121 test_testbed_api_testbed_run_topology2dtorus \
121 test_testbed_api_testbed_run_topologysmallworld 122 test_testbed_api_testbed_run_topologysmallworld \
123 test_testbed_api_testbed_run_topologyfromfile
122endif 124endif
123 125
124test_testbed_api_hosts_SOURCES = \ 126test_testbed_api_hosts_SOURCES = \
@@ -234,6 +236,12 @@ test_testbed_api_testbed_run_topologysmallworld_LDADD = \
234 $(top_builddir)/src/util/libgnunetutil.la \ 236 $(top_builddir)/src/util/libgnunetutil.la \
235 libgnunettestbed.la 237 libgnunettestbed.la
236 238
239test_testbed_api_testbed_run_topologyfromfile_SOURCES = \
240 test_testbed_api_testbed_run.c
241test_testbed_api_testbed_run_topologyfromfile_LDADD = \
242 $(top_builddir)/src/util/libgnunetutil.la \
243 libgnunettestbed.la
244
237EXTRA_DIST = \ 245EXTRA_DIST = \
238 test_testbed_api.conf \ 246 test_testbed_api.conf \
239 test_testbed_api_testbed_run_topologyring.conf \ 247 test_testbed_api_testbed_run_topologyring.conf \
@@ -243,4 +251,6 @@ EXTRA_DIST = \
243 test_testbed_api_testbed_run_topologysmallworldring.conf \ 251 test_testbed_api_testbed_run_topologysmallworldring.conf \
244 test_testbed_api_testbed_run_topology2dtorus.conf \ 252 test_testbed_api_testbed_run_topology2dtorus.conf \
245 test_testbed_api_testbed_run_topologysmallworld.conf \ 253 test_testbed_api_testbed_run_topologysmallworld.conf \
254 test_testbed_api_testbed_run_topologyfromfile.conf \
255 overlay_topology.txt \
246 sample_hosts.txt \ No newline at end of file 256 sample_hosts.txt \ No newline at end of file