aboutsummaryrefslogtreecommitdiff
path: root/src/testbed/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testbed/Makefile.am')
-rw-r--r--src/testbed/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/testbed/Makefile.am b/src/testbed/Makefile.am
index 9c1bfcce6..16fe27fc0 100644
--- a/src/testbed/Makefile.am
+++ b/src/testbed/Makefile.am
@@ -142,6 +142,7 @@ check_PROGRAMS = \
142 test_testbed_api_topology_clique \ 142 test_testbed_api_topology_clique \
143 test_testbed_api_testbed_run_topologyrandom \ 143 test_testbed_api_testbed_run_topologyrandom \
144 test_testbed_api_testbed_run_topologyline \ 144 test_testbed_api_testbed_run_topologyline \
145 test_testbed_api_testbed_run_topologystar \
145 test_testbed_api_testbed_run_topologyclique \ 146 test_testbed_api_testbed_run_topologyclique \
146 test_testbed_api_testbed_run_topologyring \ 147 test_testbed_api_testbed_run_topologyring \
147 test_testbed_api_testbed_run_topologysmallworldring \ 148 test_testbed_api_testbed_run_topologysmallworldring \
@@ -176,6 +177,7 @@ if ENABLE_TEST_RUN
176 test_testbed_api_topology_clique \ 177 test_testbed_api_topology_clique \
177 test_testbed_api_testbed_run_topologyrandom \ 178 test_testbed_api_testbed_run_topologyrandom \
178 test_testbed_api_testbed_run_topologyline \ 179 test_testbed_api_testbed_run_topologyline \
180 test_testbed_api_testbed_run_topologystar \
179 test_testbed_api_testbed_run_topologyclique \ 181 test_testbed_api_testbed_run_topologyclique \
180 test_testbed_api_testbed_run_topologyring \ 182 test_testbed_api_testbed_run_topologyring \
181 test_testbed_api_testbed_run_topology2dtorus \ 183 test_testbed_api_testbed_run_topology2dtorus \
@@ -282,6 +284,12 @@ test_testbed_api_testbed_run_topologyline_LDADD = \
282 $(top_builddir)/src/util/libgnunetutil.la \ 284 $(top_builddir)/src/util/libgnunetutil.la \
283 libgnunettestbed.la 285 libgnunettestbed.la
284 286
287test_testbed_api_testbed_run_topologystar_SOURCES = \
288 test_testbed_api_testbed_run.c
289test_testbed_api_testbed_run_topologystar_LDADD = \
290 $(top_builddir)/src/util/libgnunetutil.la \
291 libgnunettestbed.la
292
285test_testbed_api_testbed_run_topologyclique_SOURCES = \ 293test_testbed_api_testbed_run_topologyclique_SOURCES = \
286 test_testbed_api_testbed_run.c 294 test_testbed_api_testbed_run.c
287test_testbed_api_testbed_run_topologyclique_LDADD = \ 295test_testbed_api_testbed_run_topologyclique_LDADD = \
@@ -374,6 +382,7 @@ EXTRA_DIST = \
374 test_testbed_api_test_timeout.conf \ 382 test_testbed_api_test_timeout.conf \
375 test_testbed_api_template.conf \ 383 test_testbed_api_template.conf \
376 test_testbed_api_testbed_run_topologyring.conf \ 384 test_testbed_api_testbed_run_topologyring.conf \
385 test_testbed_api_testbed_run_topologystar.conf \
377 test_testbed_api_testbed_run_topologyclique.conf \ 386 test_testbed_api_testbed_run_topologyclique.conf \
378 test_testbed_api_testbed_run_topologyline.conf \ 387 test_testbed_api_testbed_run_topologyline.conf \
379 test_testbed_api_testbed_run_topologyrandom.conf \ 388 test_testbed_api_testbed_run_topologyrandom.conf \