aboutsummaryrefslogtreecommitdiff
path: root/src/topology/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/topology/Makefile.am')
-rw-r--r--src/topology/Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/src/topology/Makefile.am b/src/topology/Makefile.am
index 1094325ff..8c78d5c2c 100644
--- a/src/topology/Makefile.am
+++ b/src/topology/Makefile.am
@@ -12,12 +12,25 @@ dist_pkgcfg_DATA = \
12 topology.conf 12 topology.conf
13 13
14 14
15lib_LTLIBRARIES = libgnunetfriends.la
16
17libgnunetfriends_la_SOURCES = \
18 friends.c
19libgnunetfriends_la_LIBADD = \
20 $(top_builddir)/src/util/libgnunetutil.la
21 $(GN_LIBINTL) $(XLIB)
22libgnunetfriends_la_LDFLAGS = \
23 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
24 -version-info 0:0:0
25
26
15libexec_PROGRAMS = \ 27libexec_PROGRAMS = \
16 gnunet-daemon-topology 28 gnunet-daemon-topology
17 29
18gnunet_daemon_topology_SOURCES = \ 30gnunet_daemon_topology_SOURCES = \
19 gnunet-daemon-topology.c 31 gnunet-daemon-topology.c
20gnunet_daemon_topology_LDADD = \ 32gnunet_daemon_topology_LDADD = \
33 libgnunetfriends.la \
21 $(top_builddir)/src/core/libgnunetcore.la \ 34 $(top_builddir)/src/core/libgnunetcore.la \
22 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \ 35 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
23 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 36 $(top_builddir)/src/statistics/libgnunetstatistics.la \
@@ -40,7 +53,7 @@ test_gnunet_daemon_topology_SOURCES = \
40 test_gnunet_daemon_topology.c 53 test_gnunet_daemon_topology.c
41test_gnunet_daemon_topology_LDADD = \ 54test_gnunet_daemon_topology_LDADD = \
42 $(top_builddir)/src/testbed/libgnunettestbed.la \ 55 $(top_builddir)/src/testbed/libgnunettestbed.la \
43 $(top_builddir)/src/util/libgnunetutil.la 56 $(top_builddir)/src/util/libgnunetutil.la
44 57
45EXTRA_DIST = \ 58EXTRA_DIST = \
46 test_gnunet_daemon_topology_data.conf 59 test_gnunet_daemon_topology_data.conf