aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index cafdcdc31..13db3b5c2 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -106,7 +106,7 @@ gnunet_transport_DEPENDENCIES = \
106 libgnunettransport.la 106 libgnunettransport.la
107 107
108gnunet_service_transport_SOURCES = \ 108gnunet_service_transport_SOURCES = \
109 gnunet-service-transport.c 109 gnunet-service-transport.c
110gnunet_service_transport_LDADD = \ 110gnunet_service_transport_LDADD = \
111 $(top_builddir)/src/hello/libgnunethello.la \ 111 $(top_builddir)/src/hello/libgnunethello.la \
112 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \ 112 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
@@ -203,6 +203,7 @@ libgnunet_plugin_transport_https_la_CFLAGS = \
203 203
204 204
205check_PROGRAMS = \ 205check_PROGRAMS = \
206 test_transport_ats \
206 test_transport_api_tcp \ 207 test_transport_api_tcp \
207 test_transport_api_tcp_nat \ 208 test_transport_api_tcp_nat \
208 test_transport_api_udp \ 209 test_transport_api_udp \
@@ -233,6 +234,7 @@ check_PROGRAMS = \
233 234
234if !DISABLE_TEST_RUN 235if !DISABLE_TEST_RUN
235TESTS = \ 236TESTS = \
237 test_transport_ats \
236 test_transport_api_tcp \ 238 test_transport_api_tcp \
237 test_transport_api_tcp_nat \ 239 test_transport_api_tcp_nat \
238 test_transport_api_udp \ 240 test_transport_api_udp \
@@ -259,6 +261,13 @@ TESTS = \
259 $(HTTPS_QUOTA_TEST) 261 $(HTTPS_QUOTA_TEST)
260endif 262endif
261 263
264test_transport_ats_SOURCES = \
265 test_transport_ats.c
266test_transport_ats_LDADD = \
267 $(top_builddir)/src/transport/libgnunettransport.la \
268 $(top_builddir)/src/hello/libgnunethello.la \
269 $(top_builddir)/src/util/libgnunetutil.la
270
262test_transport_api_tcp_SOURCES = \ 271test_transport_api_tcp_SOURCES = \
263 test_transport_api.c 272 test_transport_api.c
264test_transport_api_tcp_LDADD = \ 273test_transport_api_tcp_LDADD = \