aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am34
1 files changed, 17 insertions, 17 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 193c70a19..c156d483f 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -12,7 +12,7 @@ if HAVE_MHD
12 HTTP_REL_TEST = test_transport_api_reliability_http 12 HTTP_REL_TEST = test_transport_api_reliability_http
13 HTTP_NAT_REL_TEST = test_transport_api_reliability_http_nat 13 HTTP_NAT_REL_TEST = test_transport_api_reliability_http_nat
14 HTTP_QUOTA_TEST = test_quota_compliance_http \ 14 HTTP_QUOTA_TEST = test_quota_compliance_http \
15 test_quota_compliance_http_asymmetric_recv_constant 15 test_quota_compliance_http_asymmetric
16 HTTPS_PLUGIN_LA = libgnunet_plugin_transport_https.la 16 HTTPS_PLUGIN_LA = libgnunet_plugin_transport_https.la
17 HTTPS_API_TEST = test_transport_api_https 17 HTTPS_API_TEST = test_transport_api_https
18 HTTPS_NAT_API_TEST = test_transport_api_https_nat 18 HTTPS_NAT_API_TEST = test_transport_api_https_nat
@@ -20,7 +20,7 @@ if HAVE_MHD
20 HTTPS_REL_TEST = test_transport_api_reliability_https 20 HTTPS_REL_TEST = test_transport_api_reliability_https
21 HTTPS_NAT_REL_TEST = test_transport_api_reliability_https_nat 21 HTTPS_NAT_REL_TEST = test_transport_api_reliability_https_nat
22 HTTPS_QUOTA_TEST = test_quota_compliance_https \ 22 HTTPS_QUOTA_TEST = test_quota_compliance_https \
23 test_quota_compliance_https_asymmetric_recv_constant 23 test_quota_compliance_https_asymmetric
24endif 24endif
25 25
26if USE_COVERAGE 26if USE_COVERAGE
@@ -52,7 +52,7 @@ UNIX_PLUGIN_LA = libgnunet_plugin_transport_unix.la
52UNIX_PLUGIN_TEST = test_transport_api_unix 52UNIX_PLUGIN_TEST = test_transport_api_unix
53UNIX_REL_TEST = test_transport_api_unreliability_unix 53UNIX_REL_TEST = test_transport_api_unreliability_unix
54UNIX_QUOTA_TEST = test_quota_compliance_unix \ 54UNIX_QUOTA_TEST = test_quota_compliance_unix \
55 test_quota_compliance_unix_asymmetric_recv_constant 55 test_quota_compliance_unix_asymmetric
56endif 56endif
57 57
58noinst_PROGRAMS = \ 58noinst_PROGRAMS = \
@@ -279,9 +279,9 @@ check_PROGRAMS = \
279 $(HTTPS_REL_TEST) \ 279 $(HTTPS_REL_TEST) \
280 $(HTTPS_NAT_REL_TEST) \ 280 $(HTTPS_NAT_REL_TEST) \
281 test_quota_compliance_tcp \ 281 test_quota_compliance_tcp \
282 test_quota_compliance_tcp_asymmetric_recv_constant \ 282 test_quota_compliance_tcp_asymmetric \
283 test_quota_compliance_udp \ 283 test_quota_compliance_udp \
284 test_quota_compliance_udp_asymmetric_recv_constant \ 284 test_quota_compliance_udp_asymmetric \
285 $(UNIX_QUOTA_TEST) \ 285 $(UNIX_QUOTA_TEST) \
286 $(HTTP_QUOTA_TEST) \ 286 $(HTTP_QUOTA_TEST) \
287 $(HTTPS_QUOTA_TEST) \ 287 $(HTTPS_QUOTA_TEST) \
@@ -318,9 +318,9 @@ TESTS = \
318 $(HTTPS_REL_TEST) \ 318 $(HTTPS_REL_TEST) \
319 $(HTTPS_NAT_REL_TEST) \ 319 $(HTTPS_NAT_REL_TEST) \
320 test_quota_compliance_tcp \ 320 test_quota_compliance_tcp \
321 test_quota_compliance_tcp_asymmetric_recv_constant \ 321 test_quota_compliance_tcp_asymmetric \
322 test_quota_compliance_udp \ 322 test_quota_compliance_udp \
323 test_quota_compliance_udp_asymmetric_recv_constant \ 323 test_quota_compliance_udp_asymmetric \
324 $(UNIX_QUOTA_TEST) \ 324 $(UNIX_QUOTA_TEST) \
325 $(HTTP_QUOTA_TEST) \ 325 $(HTTP_QUOTA_TEST) \
326 $(HTTPS_QUOTA_TEST) \ 326 $(HTTPS_QUOTA_TEST) \
@@ -580,9 +580,9 @@ test_quota_compliance_tcp_LDADD = \
580 $(top_builddir)/src/util/libgnunetutil.la \ 580 $(top_builddir)/src/util/libgnunetutil.la \
581 $(top_builddir)/src/transport/libgnunettransporttesting.la 581 $(top_builddir)/src/transport/libgnunettransporttesting.la
582 582
583test_quota_compliance_tcp_asymmetric_recv_constant_SOURCES = \ 583test_quota_compliance_tcp_asymmetric_SOURCES = \
584 test_quota_compliance.c 584 test_quota_compliance.c
585test_quota_compliance_tcp_asymmetric_recv_constant_LDADD = \ 585test_quota_compliance_tcp_asymmetric_LDADD = \
586 $(top_builddir)/src/transport/libgnunettransport.la \ 586 $(top_builddir)/src/transport/libgnunettransport.la \
587 $(top_builddir)/src/hello/libgnunethello.la \ 587 $(top_builddir)/src/hello/libgnunethello.la \
588 $(top_builddir)/src/util/libgnunetutil.la \ 588 $(top_builddir)/src/util/libgnunetutil.la \
@@ -602,9 +602,9 @@ test_quota_compliance_http_LDADD = \
602 $(top_builddir)/src/util/libgnunetutil.la \ 602 $(top_builddir)/src/util/libgnunetutil.la \
603 $(top_builddir)/src/transport/libgnunettransporttesting.la 603 $(top_builddir)/src/transport/libgnunettransporttesting.la
604 604
605 test_quota_compliance_http_asymmetric_recv_constant_SOURCES = \ 605 test_quota_compliance_http_asymmetric_SOURCES = \
606 test_quota_compliance.c 606 test_quota_compliance.c
607test_quota_compliance_http_asymmetric_recv_constant_LDADD = \ 607test_quota_compliance_http_asymmetric_LDADD = \
608 $(top_builddir)/src/transport/libgnunettransport.la \ 608 $(top_builddir)/src/transport/libgnunettransport.la \
609 $(top_builddir)/src/hello/libgnunethello.la \ 609 $(top_builddir)/src/hello/libgnunethello.la \
610 $(top_builddir)/src/util/libgnunetutil.la \ 610 $(top_builddir)/src/util/libgnunetutil.la \
@@ -624,9 +624,9 @@ test_quota_compliance_https_LDADD = \
624 $(top_builddir)/src/util/libgnunetutil.la \ 624 $(top_builddir)/src/util/libgnunetutil.la \
625 $(top_builddir)/src/transport/libgnunettransporttesting.la 625 $(top_builddir)/src/transport/libgnunettransporttesting.la
626 626
627 test_quota_compliance_https_asymmetric_recv_constant_SOURCES = \ 627 test_quota_compliance_https_asymmetric_SOURCES = \
628 test_quota_compliance.c 628 test_quota_compliance.c
629test_quota_compliance_https_asymmetric_recv_constant_LDADD = \ 629test_quota_compliance_https_asymmetric_LDADD = \
630 $(top_builddir)/src/transport/libgnunettransport.la \ 630 $(top_builddir)/src/transport/libgnunettransport.la \
631 $(top_builddir)/src/hello/libgnunethello.la \ 631 $(top_builddir)/src/hello/libgnunethello.la \
632 $(top_builddir)/src/util/libgnunetutil.la \ 632 $(top_builddir)/src/util/libgnunetutil.la \
@@ -646,9 +646,9 @@ test_quota_compliance_udp_LDADD = \
646 $(top_builddir)/src/util/libgnunetutil.la \ 646 $(top_builddir)/src/util/libgnunetutil.la \
647 $(top_builddir)/src/transport/libgnunettransporttesting.la 647 $(top_builddir)/src/transport/libgnunettransporttesting.la
648 648
649test_quota_compliance_udp_asymmetric_recv_constant_SOURCES = \ 649test_quota_compliance_udp_asymmetric_SOURCES = \
650 test_quota_compliance.c 650 test_quota_compliance.c
651test_quota_compliance_udp_asymmetric_recv_constant_LDADD = \ 651test_quota_compliance_udp_asymmetric_LDADD = \
652 $(top_builddir)/src/transport/libgnunettransport.la \ 652 $(top_builddir)/src/transport/libgnunettransport.la \
653 $(top_builddir)/src/hello/libgnunethello.la \ 653 $(top_builddir)/src/hello/libgnunethello.la \
654 $(top_builddir)/src/util/libgnunetutil.la \ 654 $(top_builddir)/src/util/libgnunetutil.la \
@@ -662,9 +662,9 @@ test_quota_compliance_unix_LDADD = \
662 $(top_builddir)/src/util/libgnunetutil.la \ 662 $(top_builddir)/src/util/libgnunetutil.la \
663 $(top_builddir)/src/transport/libgnunettransporttesting.la 663 $(top_builddir)/src/transport/libgnunettransporttesting.la
664 664
665test_quota_compliance_unix_asymmetric_recv_constant_SOURCES = \ 665test_quota_compliance_unix_asymmetric_SOURCES = \
666 test_quota_compliance.c 666 test_quota_compliance.c
667test_quota_compliance_unix_asymmetric_recv_constant_LDADD = \ 667test_quota_compliance_unix_asymmetric_LDADD = \
668 $(top_builddir)/src/transport/libgnunettransport.la \ 668 $(top_builddir)/src/transport/libgnunettransport.la \
669 $(top_builddir)/src/hello/libgnunethello.la \ 669 $(top_builddir)/src/hello/libgnunethello.la \
670 $(top_builddir)/src/util/libgnunetutil.la \ 670 $(top_builddir)/src/util/libgnunetutil.la \