aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am47
1 files changed, 15 insertions, 32 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 0f6251f96..fc8f424dc 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -39,6 +39,7 @@ libgnunetutil_la_SOURCES = \
39 bandwidth.c \ 39 bandwidth.c \
40 $(BENCHMARK) \ 40 $(BENCHMARK) \
41 bio.c \ 41 bio.c \
42 buffer.c \
42 client.c \ 43 client.c \
43 common_allocation.c \ 44 common_allocation.c \
44 common_endian.c \ 45 common_endian.c \
@@ -138,41 +139,11 @@ libgnunetutil_la_LDFLAGS = \
138 $(GN_LIB_LDFLAGS) \ 139 $(GN_LIB_LDFLAGS) \
139 -version-info 13:2:0 140 -version-info 13:2:0
140 141
141libgnunetutil_taler_wallet_la_SOURCES = \
142 common_allocation.c \
143 common_endian.c \
144 common_logging.c \
145 container_heap.c \
146 container_multihashmap.c \
147 container_multihashmap32.c \
148 crypto_symmetric.c \
149 crypto_crc.c \
150 crypto_ecc.c \
151 crypto_hash.c \
152 crypto_hkdf.c \
153 crypto_kdf.c \
154 crypto_mpi.c \
155 crypto_random.c \
156 crypto_rsa.c \
157 strings.c \
158 time.c
159
160libgnunetutil_taler_wallet_la_LIBADD = \
161 $(LIBGCRYPT_LIBS) \
162 -lunistring
163
164libgnunetutil_taler_wallet_la_LDFLAGS = \
165 $(GN_LIB_LDFLAGS) \
166 -version-info 0:0:0
167
168if HAVE_TESTING 142if HAVE_TESTING
169 GNUNET_ECC = gnunet-ecc 143 GNUNET_ECC = gnunet-ecc
170 GNUNET_SCRYPT = gnunet-scrypt 144 GNUNET_SCRYPT = gnunet-scrypt
171endif 145endif
172 146
173if TALER_ONLY
174lib_LTLIBRARIES = libgnunetutil_taler_wallet.la
175else
176lib_LTLIBRARIES = libgnunetutil.la 147lib_LTLIBRARIES = libgnunetutil.la
177 148
178libexec_PROGRAMS = \ 149libexec_PROGRAMS = \
@@ -182,6 +153,7 @@ libexec_PROGRAMS = \
182bin_PROGRAMS = \ 153bin_PROGRAMS = \
183 gnunet-resolver \ 154 gnunet-resolver \
184 gnunet-config \ 155 gnunet-config \
156 gnunet-crypto-tvg \
185 $(GNUNET_ECC) \ 157 $(GNUNET_ECC) \
186 $(GNUNET_SCRYPT) \ 158 $(GNUNET_SCRYPT) \
187 gnunet-uri 159 gnunet-uri
@@ -199,8 +171,6 @@ AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PAT
199TESTS = $(check_PROGRAMS) 171TESTS = $(check_PROGRAMS)
200endif 172endif
201 173
202endif
203
204gnunet_timeout_SOURCES = \ 174gnunet_timeout_SOURCES = \
205 gnunet-timeout.c 175 gnunet-timeout.c
206 176
@@ -220,6 +190,11 @@ gnunet_resolver_LDADD = \
220 libgnunetutil.la \ 190 libgnunetutil.la \
221 $(GN_LIBINTL) 191 $(GN_LIBINTL)
222 192
193gnunet_crypto_tvg_SOURCES = \
194 gnunet-crypto-tvg.c
195gnunet_crypto_tvg_LDADD = \
196 libgnunetutil.la \
197 $(GN_LIBINTL) -lgcrypt
223 198
224gnunet_ecc_SOURCES = \ 199gnunet_ecc_SOURCES = \
225 gnunet-ecc.c 200 gnunet-ecc.c
@@ -298,6 +273,7 @@ check_PROGRAMS = \
298 test_crypto_eddsa \ 273 test_crypto_eddsa \
299 test_crypto_ecdhe \ 274 test_crypto_ecdhe \
300 test_crypto_ecdh_eddsa \ 275 test_crypto_ecdh_eddsa \
276 test_crypto_ecdh_ecdsa \
301 test_crypto_ecc_dlog \ 277 test_crypto_ecc_dlog \
302 test_crypto_hash \ 278 test_crypto_hash \
303 test_crypto_hash_context \ 279 test_crypto_hash_context \
@@ -476,6 +452,13 @@ test_crypto_ecdh_eddsa_LDADD = \
476 libgnunetutil.la \ 452 libgnunetutil.la \
477 $(LIBGCRYPT_LIBS) 453 $(LIBGCRYPT_LIBS)
478 454
455test_crypto_ecdh_ecdsa_SOURCES = \
456 test_crypto_ecdh_ecdsa.c
457test_crypto_ecdh_ecdsa_LDADD = \
458 libgnunetutil.la \
459 $(LIBGCRYPT_LIBS)
460
461
479test_crypto_hash_SOURCES = \ 462test_crypto_hash_SOURCES = \
480 test_crypto_hash.c 463 test_crypto_hash.c
481test_crypto_hash_LDADD = \ 464test_crypto_hash_LDADD = \