aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am122
1 files changed, 68 insertions, 54 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 564204862..a9b4e09da 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -7,7 +7,7 @@ libexecdir= $(pkglibdir)/libexec/
7pkgcfgdir= $(pkgdatadir)/config.d/ 7pkgcfgdir= $(pkgdatadir)/config.d/
8 8
9dist_pkgcfg_DATA = \ 9dist_pkgcfg_DATA = \
10 util.conf 10 util.conf
11 11
12pkgcfg_DATA = \ 12pkgcfg_DATA = \
13 resolver.conf 13 resolver.conf
@@ -19,7 +19,7 @@ libgnunetutilwin_la_SOURCES = \
19 win.c \ 19 win.c \
20 winproc.c 20 winproc.c
21libgnunetutilwin_la_LDFLAGS = \ 21libgnunetutilwin_la_LDFLAGS = \
22 -no-undefined -Wl,--export-all-symbols 22 -no-undefined -Wl,--export-all-symbols
23libgnunetutilwin_la_LIBADD = \ 23libgnunetutilwin_la_LIBADD = \
24 -lshell32 -liconv -lstdc++ \ 24 -lshell32 -liconv -lstdc++ \
25 -lcomdlg32 -lgdi32 -liphlpapi 25 -lcomdlg32 -lgdi32 -liphlpapi
@@ -47,7 +47,7 @@ noinst_PROGRAMS = \
47gnunet_config_diff_SOURCES = \ 47gnunet_config_diff_SOURCES = \
48 gnunet-config-diff.c 48 gnunet-config-diff.c
49gnunet_config_diff_LDADD = \ 49gnunet_config_diff_LDADD = \
50 $(top_builddir)/src/util/libgnunetutil.la 50 $(top_builddir)/src/util/libgnunetutil.la
51gnunet_config_diff_DEPENDENCIES = \ 51gnunet_config_diff_DEPENDENCIES = \
52 libgnunetutil.la 52 libgnunetutil.la
53 53
@@ -114,7 +114,7 @@ libgnunetutil_la_LIBADD = \
114 $(LIBGCRYPT_LIBS) \ 114 $(LIBGCRYPT_LIBS) \
115 $(LTLIBICONV) \ 115 $(LTLIBICONV) \
116 $(LTLIBINTL) \ 116 $(LTLIBINTL) \
117 -lltdl $(Z_LIBS) -lunistring $(XLIB) 117 -lltdl $(Z_LIBS) -lunistring $(XLIB)
118 118
119libgnunetutil_la_LDFLAGS = \ 119libgnunetutil_la_LDFLAGS = \
120 $(GN_LIB_LDFLAGS) \ 120 $(GN_LIB_LDFLAGS) \
@@ -126,17 +126,17 @@ endif
126 126
127 127
128libexec_PROGRAMS = \ 128libexec_PROGRAMS = \
129 gnunet-service-resolver 129 gnunet-service-resolver
130 130
131bin_PROGRAMS = \ 131bin_PROGRAMS = \
132 gnunet-resolver \ 132 gnunet-resolver \
133 gnunet-config \ 133 gnunet-config \
134 $(GNUNET_ECC) \ 134 $(GNUNET_ECC) \
135 gnunet-uri 135 gnunet-uri
136 136
137 137
138gnunet_service_resolver_SOURCES = \ 138gnunet_service_resolver_SOURCES = \
139 gnunet-service-resolver.c 139 gnunet-service-resolver.c
140gnunet_service_resolver_LDADD = \ 140gnunet_service_resolver_LDADD = \
141 $(top_builddir)/src/util/libgnunetutil.la \ 141 $(top_builddir)/src/util/libgnunetutil.la \
142 $(GN_LIBINTL) 142 $(GN_LIBINTL)
@@ -145,7 +145,7 @@ gnunet_service_resolver_DEPENDENCIES = \
145 145
146 146
147gnunet_resolver_SOURCES = \ 147gnunet_resolver_SOURCES = \
148 gnunet-resolver.c 148 gnunet-resolver.c
149gnunet_resolver_LDADD = \ 149gnunet_resolver_LDADD = \
150 $(top_builddir)/src/util/libgnunetutil.la \ 150 $(top_builddir)/src/util/libgnunetutil.la \
151 $(GN_LIBINTL) 151 $(GN_LIBINTL)
@@ -154,7 +154,7 @@ gnunet_resolver_DEPENDENCIES = \
154 154
155 155
156gnunet_ecc_SOURCES = \ 156gnunet_ecc_SOURCES = \
157 gnunet-ecc.c 157 gnunet-ecc.c
158gnunet_ecc_LDADD = \ 158gnunet_ecc_LDADD = \
159 $(top_builddir)/src/util/libgnunetutil.la \ 159 $(top_builddir)/src/util/libgnunetutil.la \
160 $(GN_LIBINTL) -lgcrypt 160 $(GN_LIBINTL) -lgcrypt
@@ -163,7 +163,7 @@ gnunet_ecc_DEPENDENCIES = \
163 163
164 164
165gnunet_config_SOURCES = \ 165gnunet_config_SOURCES = \
166 gnunet-config.c 166 gnunet-config.c
167gnunet_config_LDADD = \ 167gnunet_config_LDADD = \
168 $(top_builddir)/src/util/libgnunetutil.la \ 168 $(top_builddir)/src/util/libgnunetutil.la \
169 $(GN_LIBINTL) 169 $(GN_LIBINTL)
@@ -172,7 +172,7 @@ gnunet_config_DEPENDENCIES = \
172 172
173 173
174gnunet_uri_SOURCES = \ 174gnunet_uri_SOURCES = \
175 gnunet-uri.c 175 gnunet-uri.c
176gnunet_uri_LDADD = \ 176gnunet_uri_LDADD = \
177 $(top_builddir)/src/util/libgnunetutil.la \ 177 $(top_builddir)/src/util/libgnunetutil.la \
178 $(GN_LIBINTL) 178 $(GN_LIBINTL)
@@ -210,7 +210,9 @@ check_PROGRAMS = \
210 test_container_slist \ 210 test_container_slist \
211 test_crypto_symmetric \ 211 test_crypto_symmetric \
212 test_crypto_crc \ 212 test_crypto_crc \
213 test_crypto_ecc \ 213 test_crypto_ecdsa \
214 test_crypto_eddsa \
215 test_crypto_ecdhe \
214 test_crypto_hash \ 216 test_crypto_hash \
215 test_crypto_hkdf \ 217 test_crypto_hkdf \
216 test_crypto_random \ 218 test_crypto_random \
@@ -265,22 +267,22 @@ test_os_start_process_DEPENDENCIES = \
265test_client_SOURCES = \ 267test_client_SOURCES = \
266 test_client.c 268 test_client.c
267test_client_LDADD = \ 269test_client_LDADD = \
268 $(top_builddir)/src/util/libgnunetutil.la 270 $(top_builddir)/src/util/libgnunetutil.la
269 271
270test_common_allocation_SOURCES = \ 272test_common_allocation_SOURCES = \
271 test_common_allocation.c 273 test_common_allocation.c
272test_common_allocation_LDADD = \ 274test_common_allocation_LDADD = \
273 $(top_builddir)/src/util/libgnunetutil.la 275 $(top_builddir)/src/util/libgnunetutil.la
274 276
275test_common_endian_SOURCES = \ 277test_common_endian_SOURCES = \
276 test_common_endian.c 278 test_common_endian.c
277test_common_endian_LDADD = \ 279test_common_endian_LDADD = \
278 $(top_builddir)/src/util/libgnunetutil.la 280 $(top_builddir)/src/util/libgnunetutil.la
279 281
280test_common_logging_SOURCES = \ 282test_common_logging_SOURCES = \
281 test_common_logging.c 283 test_common_logging.c
282test_common_logging_LDADD = \ 284test_common_logging_LDADD = \
283 $(top_builddir)/src/util/libgnunetutil.la 285 $(top_builddir)/src/util/libgnunetutil.la
284 286
285test_common_logging_runtime_loglevels_SOURCES = \ 287test_common_logging_runtime_loglevels_SOURCES = \
286 test_common_logging_runtime_loglevels.c 288 test_common_logging_runtime_loglevels.c
@@ -290,12 +292,12 @@ test_common_logging_runtime_loglevels_LDADD = \
290test_configuration_SOURCES = \ 292test_configuration_SOURCES = \
291 test_configuration.c 293 test_configuration.c
292test_configuration_LDADD = \ 294test_configuration_LDADD = \
293 $(top_builddir)/src/util/libgnunetutil.la 295 $(top_builddir)/src/util/libgnunetutil.la
294 296
295test_container_bloomfilter_SOURCES = \ 297test_container_bloomfilter_SOURCES = \
296 test_container_bloomfilter.c 298 test_container_bloomfilter.c
297test_container_bloomfilter_LDADD = \ 299test_container_bloomfilter_LDADD = \
298 $(top_builddir)/src/util/libgnunetutil.la 300 $(top_builddir)/src/util/libgnunetutil.la
299 301
300test_container_meta_data_SOURCES = \ 302test_container_meta_data_SOURCES = \
301 test_container_meta_data.c 303 test_container_meta_data.c
@@ -320,83 +322,95 @@ test_container_multipeermap_LDADD = \
320test_container_heap_SOURCES = \ 322test_container_heap_SOURCES = \
321 test_container_heap.c 323 test_container_heap.c
322test_container_heap_LDADD = \ 324test_container_heap_LDADD = \
323 $(top_builddir)/src/util/libgnunetutil.la 325 $(top_builddir)/src/util/libgnunetutil.la
324 326
325test_container_slist_SOURCES = \ 327test_container_slist_SOURCES = \
326 test_container_slist.c 328 test_container_slist.c
327test_container_slist_LDADD = \ 329test_container_slist_LDADD = \
328 $(top_builddir)/src/util/libgnunetutil.la 330 $(top_builddir)/src/util/libgnunetutil.la
329 331
330test_crypto_symmetric_SOURCES = \ 332test_crypto_symmetric_SOURCES = \
331 test_crypto_symmetric.c 333 test_crypto_symmetric.c
332test_crypto_symmetric_LDADD = \ 334test_crypto_symmetric_LDADD = \
333 $(top_builddir)/src/util/libgnunetutil.la 335 $(top_builddir)/src/util/libgnunetutil.la
334 336
335test_crypto_crc_SOURCES = \ 337test_crypto_crc_SOURCES = \
336 test_crypto_crc.c 338 test_crypto_crc.c
337test_crypto_crc_LDADD = \ 339test_crypto_crc_LDADD = \
338 $(top_builddir)/src/util/libgnunetutil.la 340 $(top_builddir)/src/util/libgnunetutil.la
339 341
340test_crypto_ecc_SOURCES = \ 342test_crypto_ecdsa_SOURCES = \
341 test_crypto_ecc.c 343 test_crypto_ecdsa.c
342test_crypto_ecc_LDADD = \ 344test_crypto_ecdsa_LDADD = \
345 $(top_builddir)/src/util/libgnunetutil.la \
346 $(LIBGCRYPT_LIBS)
347
348test_crypto_eddsa_SOURCES = \
349 test_crypto_eddsa.c
350test_crypto_eddsa_LDADD = \
351 $(top_builddir)/src/util/libgnunetutil.la \
352 $(LIBGCRYPT_LIBS)
353
354test_crypto_ecdhe_SOURCES = \
355 test_crypto_ecdhe.c
356test_crypto_ecdhe_LDADD = \
343 $(top_builddir)/src/util/libgnunetutil.la \ 357 $(top_builddir)/src/util/libgnunetutil.la \
344 $(LIBGCRYPT_LIBS) 358 $(LIBGCRYPT_LIBS)
345 359
346test_crypto_hash_SOURCES = \ 360test_crypto_hash_SOURCES = \
347 test_crypto_hash.c 361 test_crypto_hash.c
348test_crypto_hash_LDADD = \ 362test_crypto_hash_LDADD = \
349 $(top_builddir)/src/util/libgnunetutil.la 363 $(top_builddir)/src/util/libgnunetutil.la
350 364
351test_crypto_hkdf_SOURCES = \ 365test_crypto_hkdf_SOURCES = \
352 test_crypto_hkdf.c 366 test_crypto_hkdf.c
353test_crypto_hkdf_LDADD = \ 367test_crypto_hkdf_LDADD = \
354 $(top_builddir)/src/util/libgnunetutil.la 368 $(top_builddir)/src/util/libgnunetutil.la
355 369
356test_crypto_random_SOURCES = \ 370test_crypto_random_SOURCES = \
357 test_crypto_random.c 371 test_crypto_random.c
358test_crypto_random_LDADD = \ 372test_crypto_random_LDADD = \
359 $(top_builddir)/src/util/libgnunetutil.la 373 $(top_builddir)/src/util/libgnunetutil.la
360 374
361test_disk_SOURCES = \ 375test_disk_SOURCES = \
362 test_disk.c 376 test_disk.c
363test_disk_LDADD = \ 377test_disk_LDADD = \
364 $(top_builddir)/src/util/libgnunetutil.la 378 $(top_builddir)/src/util/libgnunetutil.la
365 379
366test_getopt_SOURCES = \ 380test_getopt_SOURCES = \
367 test_getopt.c 381 test_getopt.c
368test_getopt_LDADD = \ 382test_getopt_LDADD = \
369 $(top_builddir)/src/util/libgnunetutil.la 383 $(top_builddir)/src/util/libgnunetutil.la
370 384
371test_connection_SOURCES = \ 385test_connection_SOURCES = \
372 test_connection.c 386 test_connection.c
373test_connection_LDADD = \ 387test_connection_LDADD = \
374 $(top_builddir)/src/util/libgnunetutil.la 388 $(top_builddir)/src/util/libgnunetutil.la
375 389
376test_connection_addressing_SOURCES = \ 390test_connection_addressing_SOURCES = \
377 test_connection_addressing.c 391 test_connection_addressing.c
378test_connection_addressing_LDADD = \ 392test_connection_addressing_LDADD = \
379 $(top_builddir)/src/util/libgnunetutil.la 393 $(top_builddir)/src/util/libgnunetutil.la
380 394
381test_connection_receive_cancel_SOURCES = \ 395test_connection_receive_cancel_SOURCES = \
382 test_connection_receive_cancel.c 396 test_connection_receive_cancel.c
383test_connection_receive_cancel_LDADD = \ 397test_connection_receive_cancel_LDADD = \
384 $(top_builddir)/src/util/libgnunetutil.la 398 $(top_builddir)/src/util/libgnunetutil.la
385 399
386test_connection_timeout_SOURCES = \ 400test_connection_timeout_SOURCES = \
387 test_connection_timeout.c 401 test_connection_timeout.c
388test_connection_timeout_LDADD = \ 402test_connection_timeout_LDADD = \
389 $(top_builddir)/src/util/libgnunetutil.la 403 $(top_builddir)/src/util/libgnunetutil.la
390 404
391test_connection_timeout_no_connect_SOURCES = \ 405test_connection_timeout_no_connect_SOURCES = \
392 test_connection_timeout_no_connect.c 406 test_connection_timeout_no_connect.c
393test_connection_timeout_no_connect_LDADD = \ 407test_connection_timeout_no_connect_LDADD = \
394 $(top_builddir)/src/util/libgnunetutil.la 408 $(top_builddir)/src/util/libgnunetutil.la
395 409
396test_connection_transmit_cancel_SOURCES = \ 410test_connection_transmit_cancel_SOURCES = \
397 test_connection_transmit_cancel.c 411 test_connection_transmit_cancel.c
398test_connection_transmit_cancel_LDADD = \ 412test_connection_transmit_cancel_LDADD = \
399 $(top_builddir)/src/util/libgnunetutil.la 413 $(top_builddir)/src/util/libgnunetutil.la
400 414
401test_mq_SOURCES = \ 415test_mq_SOURCES = \
402 test_mq.c 416 test_mq.c
@@ -411,7 +425,7 @@ test_mq_client_LDADD = \
411test_os_network_SOURCES = \ 425test_os_network_SOURCES = \
412 test_os_network.c 426 test_os_network.c
413test_os_network_LDADD = \ 427test_os_network_LDADD = \
414 $(top_builddir)/src/util/libgnunetutil.la 428 $(top_builddir)/src/util/libgnunetutil.la
415 429
416test_peer_SOURCES = \ 430test_peer_SOURCES = \
417 test_peer.c 431 test_peer.c
@@ -421,63 +435,63 @@ $(top_builddir)/src/util/libgnunetutil.la -lgcrypt
421test_plugin_SOURCES = \ 435test_plugin_SOURCES = \
422 test_plugin.c 436 test_plugin.c
423test_plugin_LDADD = \ 437test_plugin_LDADD = \
424 $(top_builddir)/src/util/libgnunetutil.la 438 $(top_builddir)/src/util/libgnunetutil.la
425 439
426test_program_SOURCES = \ 440test_program_SOURCES = \
427 test_program.c 441 test_program.c
428test_program_LDADD = \ 442test_program_LDADD = \
429 $(top_builddir)/src/util/libgnunetutil.la 443 $(top_builddir)/src/util/libgnunetutil.la
430 444
431test_resolver_api_SOURCES = \ 445test_resolver_api_SOURCES = \
432 test_resolver_api.c 446 test_resolver_api.c
433test_resolver_api_LDADD = \ 447test_resolver_api_LDADD = \
434 $(top_builddir)/src/util/libgnunetutil.la 448 $(top_builddir)/src/util/libgnunetutil.la
435 449
436test_scheduler_SOURCES = \ 450test_scheduler_SOURCES = \
437 test_scheduler.c 451 test_scheduler.c
438test_scheduler_LDADD = \ 452test_scheduler_LDADD = \
439 $(top_builddir)/src/util/libgnunetutil.la 453 $(top_builddir)/src/util/libgnunetutil.la
440 454
441test_scheduler_delay_SOURCES = \ 455test_scheduler_delay_SOURCES = \
442 test_scheduler_delay.c 456 test_scheduler_delay.c
443test_scheduler_delay_LDADD = \ 457test_scheduler_delay_LDADD = \
444 $(top_builddir)/src/util/libgnunetutil.la 458 $(top_builddir)/src/util/libgnunetutil.la
445 459
446test_server_mst_interrupt_SOURCES = \ 460test_server_mst_interrupt_SOURCES = \
447 test_server_mst_interrupt.c 461 test_server_mst_interrupt.c
448test_server_mst_interrupt_LDADD = \ 462test_server_mst_interrupt_LDADD = \
449 $(top_builddir)/src/util/libgnunetutil.la 463 $(top_builddir)/src/util/libgnunetutil.la
450 464
451test_server_SOURCES = \ 465test_server_SOURCES = \
452 test_server.c 466 test_server.c
453test_server_LDADD = \ 467test_server_LDADD = \
454 $(top_builddir)/src/util/libgnunetutil.la 468 $(top_builddir)/src/util/libgnunetutil.la
455 469
456test_server_disconnect_SOURCES = \ 470test_server_disconnect_SOURCES = \
457 test_server_disconnect.c 471 test_server_disconnect.c
458test_server_disconnect_LDADD = \ 472test_server_disconnect_LDADD = \
459 $(top_builddir)/src/util/libgnunetutil.la 473 $(top_builddir)/src/util/libgnunetutil.la
460 474
461test_server_with_client_SOURCES = \ 475test_server_with_client_SOURCES = \
462 test_server_with_client.c 476 test_server_with_client.c
463test_server_with_client_LDADD = \ 477test_server_with_client_LDADD = \
464 $(top_builddir)/src/util/libgnunetutil.la 478 $(top_builddir)/src/util/libgnunetutil.la
465 479
466test_server_with_client_unix_SOURCES = \ 480test_server_with_client_unix_SOURCES = \
467 test_server_with_client_unix.c 481 test_server_with_client_unix.c
468test_server_with_client_unix_LDADD = \ 482test_server_with_client_unix_LDADD = \
469 $(top_builddir)/src/util/libgnunetutil.la 483 $(top_builddir)/src/util/libgnunetutil.la
470 484
471 485
472test_service_SOURCES = \ 486test_service_SOURCES = \
473 test_service.c 487 test_service.c
474test_service_LDADD = \ 488test_service_LDADD = \
475 $(top_builddir)/src/util/libgnunetutil.la 489 $(top_builddir)/src/util/libgnunetutil.la
476 490
477test_strings_SOURCES = \ 491test_strings_SOURCES = \
478 test_strings.c 492 test_strings.c
479test_strings_LDADD = \ 493test_strings_LDADD = \
480 $(top_builddir)/src/util/libgnunetutil.la 494 $(top_builddir)/src/util/libgnunetutil.la
481 495
482 496
483test_strings_to_data_SOURCES = \ 497test_strings_to_data_SOURCES = \
@@ -489,27 +503,27 @@ test_strings_to_data_LDADD = \
489test_time_SOURCES = \ 503test_time_SOURCES = \
490 test_time.c 504 test_time.c
491test_time_LDADD = \ 505test_time_LDADD = \
492 $(top_builddir)/src/util/libgnunetutil.la 506 $(top_builddir)/src/util/libgnunetutil.la
493 507
494test_speedup_SOURCES = \ 508test_speedup_SOURCES = \
495 test_speedup.c 509 test_speedup.c
496test_speedup_LDADD = \ 510test_speedup_LDADD = \
497 $(top_builddir)/src/util/libgnunetutil.la 511 $(top_builddir)/src/util/libgnunetutil.la
498 512
499perf_crypto_hash_SOURCES = \ 513perf_crypto_hash_SOURCES = \
500 perf_crypto_hash.c 514 perf_crypto_hash.c
501perf_crypto_hash_LDADD = \ 515perf_crypto_hash_LDADD = \
502 $(top_builddir)/src/util/libgnunetutil.la 516 $(top_builddir)/src/util/libgnunetutil.la
503 517
504perf_crypto_symmetric_SOURCES = \ 518perf_crypto_symmetric_SOURCES = \
505 perf_crypto_symmetric.c 519 perf_crypto_symmetric.c
506perf_crypto_symmetric_LDADD = \ 520perf_crypto_symmetric_LDADD = \
507 $(top_builddir)/src/util/libgnunetutil.la 521 $(top_builddir)/src/util/libgnunetutil.la
508 522
509perf_malloc_SOURCES = \ 523perf_malloc_SOURCES = \
510 perf_malloc.c 524 perf_malloc.c
511perf_malloc_LDADD = \ 525perf_malloc_LDADD = \
512 $(top_builddir)/src/util/libgnunetutil.la 526 $(top_builddir)/src/util/libgnunetutil.la
513 527
514 528
515EXTRA_DIST = \ 529EXTRA_DIST = \