aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am24
1 files changed, 23 insertions, 1 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index c26e3e84b..cc9ff4745 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -119,11 +119,22 @@ libgnunetutil_la_LIBADD = \
119 $(LTLIBINTL) \ 119 $(LTLIBINTL) \
120 -lltdl $(Z_LIBS) -lunistring $(XLIB) 120 -lltdl $(Z_LIBS) -lunistring $(XLIB)
121 121
122if HAVE_PBC
123if HAVE_ABE
124libgnunetutil_la_SOURCES += \
125 crypto_abe.c
126libgnunetutil_la_LIBADD += \
127 $(ABE_LIBADD) \
128 -lgabe \
129 -lpbc \
130 -lglib-2.0
131endif
132endif
133
122libgnunetutil_la_LDFLAGS = \ 134libgnunetutil_la_LDFLAGS = \
123 $(GN_LIB_LDFLAGS) \ 135 $(GN_LIB_LDFLAGS) \
124 -version-info 13:0:0 136 -version-info 13:0:0
125 137
126
127libgnunetutil_taler_wallet_la_SOURCES = \ 138libgnunetutil_taler_wallet_la_SOURCES = \
128 common_allocation.c \ 139 common_allocation.c \
129 common_endian.c \ 140 common_endian.c \
@@ -553,6 +564,17 @@ test_speedup_SOURCES = \
553test_speedup_LDADD = \ 564test_speedup_LDADD = \
554 libgnunetutil.la 565 libgnunetutil.la
555 566
567if HAVE_PBC
568if HAVE_ABE
569test_crypto_abe_SOURCES = \
570 test_crypto_abe.c
571test_crypto_abe_LDADD = \
572 libgnunetutil.la
573check_PROGRAMS += \
574 test_crypto_abe
575endif
576endif
577
556perf_crypto_hash_SOURCES = \ 578perf_crypto_hash_SOURCES = \
557 perf_crypto_hash.c 579 perf_crypto_hash.c
558perf_crypto_hash_LDADD = \ 580perf_crypto_hash_LDADD = \