aboutsummaryrefslogtreecommitdiff
path: root/src/util/libgnu/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/libgnu/Makefile.am')
-rw-r--r--src/util/libgnu/Makefile.am250
1 files changed, 0 insertions, 250 deletions
diff --git a/src/util/libgnu/Makefile.am b/src/util/libgnu/Makefile.am
deleted file mode 100644
index b373e5297..000000000
--- a/src/util/libgnu/Makefile.am
+++ /dev/null
@@ -1,250 +0,0 @@
1## DO NOT EDIT! GENERATED AUTOMATICALLY!
2## Process this file with automake to produce Makefile.in.
3# Copyright (C) 2002-2011 Free Software Foundation, Inc.
4#
5# This file is free software, distributed under the terms of the GNU
6# General Public License. As a special exception to the GNU General
7# Public License, this file may be distributed as part of a program
8# that contains a configuration script generated by Autoconf, under
9# the same distribution terms as the rest of that program.
10#
11# Generated by gnulib-tool.
12# Reproduce by: gnulib-tool --import --dir=/home/nils/workspace/gnunet --lib=libgnu --source-base=src/util/libgnu --m4-base=m4 --doc-base=doc --tests-base=tests --aux-dir=. --libtool --macro-prefix=gl strtok_r
13
14INCLUDES = -I$(top_srcdir)/src/include
15
16AUTOMAKE_OPTIONS = 1.5 gnits
17
18SUBDIRS =
19noinst_HEADERS =
20noinst_LIBRARIES =
21noinst_LTLIBRARIES =
22EXTRA_DIST =
23BUILT_SOURCES =
24SUFFIXES =
25MOSTLYCLEANFILES = core *.stackdump
26MOSTLYCLEANDIRS =
27CLEANFILES =
28DISTCLEANFILES =
29MAINTAINERCLEANFILES =
30
31AM_CPPFLAGS =
32AM_CFLAGS =
33
34noinst_LTLIBRARIES += libgnu.la
35
36libgnu_la_SOURCES =
37libgnu_la_LIBADD = $(gl_LTLIBOBJS)
38libgnu_la_DEPENDENCIES = $(gl_LTLIBOBJS)
39EXTRA_libgnu_la_SOURCES =
40libgnu_la_LDFLAGS = $(AM_LDFLAGS)
41libgnu_la_LDFLAGS += -no-undefined
42
43## begin gnulib module arg-nonnull
44
45# The BUILT_SOURCES created by this Makefile snippet are not used via #include
46# statements but through direct file reference. Therefore this snippet must be
47# present in all Makefile.am that need it. This is ensured by the applicability
48# 'all' defined above.
49
50BUILT_SOURCES += arg-nonnull.h
51# The arg-nonnull.h that gets inserted into generated .h files is the same as
52# build-aux/arg-nonnull.h, except that it has the copyright header cut off.
53arg-nonnull.h: $(top_srcdir)/src/include/arg-nonnull.h
54 $(AM_V_GEN)rm -f $@-t $@ && \
55 sed -n -e '/GL_ARG_NONNULL/,$$p' \
56 < $(top_srcdir)/src/include/arg-nonnull.h \
57 > $@-t && \
58 mv $@-t $@
59MOSTLYCLEANFILES += arg-nonnull.h arg-nonnull.h-t
60
61ARG_NONNULL_H=arg-nonnull.h
62
63EXTRA_DIST += $(top_srcdir)/src/include/arg-nonnull.h
64
65## end gnulib module arg-nonnull
66
67## begin gnulib module c++defs
68
69# The BUILT_SOURCES created by this Makefile snippet are not used via #include
70# statements but through direct file reference. Therefore this snippet must be
71# present in all Makefile.am that need it. This is ensured by the applicability
72# 'all' defined above.
73
74BUILT_SOURCES += c++defs.h
75# The c++defs.h that gets inserted into generated .h files is the same as
76# build-aux/c++defs.h, except that it has the copyright header cut off.
77c++defs.h: $(top_srcdir)/src/include/c++defs.h
78 $(AM_V_GEN)rm -f $@-t $@ && \
79 sed -n -e '/_GL_CXXDEFS/,$$p' \
80 < $(top_srcdir)/src/include/c++defs.h \
81 > $@-t && \
82 mv $@-t $@
83MOSTLYCLEANFILES += c++defs.h c++defs.h-t
84
85CXXDEFS_H=c++defs.h
86
87EXTRA_DIST += $(top_srcdir)/src/include/c++defs.h
88
89## end gnulib module c++defs
90
91## begin gnulib module stddef
92
93BUILT_SOURCES += $(STDDEF_H)
94
95# We need the following in order to create <stddef.h> when the system
96# doesn't have one that works with the given compiler.
97stddef.h: stddef.in.h
98 $(AM_V_GEN)rm -f $@-t $@ && \
99 { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */' && \
100 sed -e 's|@''INCLUDE_NEXT''@|$(INCLUDE_NEXT)|g' \
101 -e 's|@''PRAGMA_SYSTEM_HEADER''@|@PRAGMA_SYSTEM_HEADER@|g' \
102 -e 's|@''PRAGMA_COLUMNS''@|@PRAGMA_COLUMNS@|g' \
103 -e 's|@''NEXT_STDDEF_H''@|$(NEXT_STDDEF_H)|g' \
104 -e 's|@''HAVE_WCHAR_T''@|$(HAVE_WCHAR_T)|g' \
105 -e 's|@''REPLACE_NULL''@|$(REPLACE_NULL)|g' \
106 < $(srcdir)/stddef.in.h; \
107 } > $@-t && \
108 mv $@-t $@
109MOSTLYCLEANFILES += stddef.h stddef.h-t
110
111EXTRA_DIST += stddef.in.h
112
113## end gnulib module stddef
114
115## begin gnulib module string
116
117BUILT_SOURCES += string.h
118
119# We need the following in order to create <string.h> when the system
120# doesn't have one that works with the given compiler.
121string.h: string.in.h $(CXXDEFS_H) $(ARG_NONNULL_H) $(WARN_ON_USE_H)
122 $(AM_V_GEN)rm -f $@-t $@ && \
123 { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */' && \
124 sed -e 's|@''INCLUDE_NEXT''@|$(INCLUDE_NEXT)|g' \
125 -e 's|@''PRAGMA_SYSTEM_HEADER''@|@PRAGMA_SYSTEM_HEADER@|g' \
126 -e 's|@''PRAGMA_COLUMNS''@|@PRAGMA_COLUMNS@|g' \
127 -e 's|@''NEXT_STRING_H''@|$(NEXT_STRING_H)|g' \
128 -e 's|@''GNULIB_MBSLEN''@|$(GNULIB_MBSLEN)|g' \
129 -e 's|@''GNULIB_MBSNLEN''@|$(GNULIB_MBSNLEN)|g' \
130 -e 's|@''GNULIB_MBSCHR''@|$(GNULIB_MBSCHR)|g' \
131 -e 's|@''GNULIB_MBSRCHR''@|$(GNULIB_MBSRCHR)|g' \
132 -e 's|@''GNULIB_MBSSTR''@|$(GNULIB_MBSSTR)|g' \
133 -e 's|@''GNULIB_MBSCASECMP''@|$(GNULIB_MBSCASECMP)|g' \
134 -e 's|@''GNULIB_MBSNCASECMP''@|$(GNULIB_MBSNCASECMP)|g' \
135 -e 's|@''GNULIB_MBSPCASECMP''@|$(GNULIB_MBSPCASECMP)|g' \
136 -e 's|@''GNULIB_MBSCASESTR''@|$(GNULIB_MBSCASESTR)|g' \
137 -e 's|@''GNULIB_MBSCSPN''@|$(GNULIB_MBSCSPN)|g' \
138 -e 's|@''GNULIB_MBSPBRK''@|$(GNULIB_MBSPBRK)|g' \
139 -e 's|@''GNULIB_MBSSPN''@|$(GNULIB_MBSSPN)|g' \
140 -e 's|@''GNULIB_MBSSEP''@|$(GNULIB_MBSSEP)|g' \
141 -e 's|@''GNULIB_MBSTOK_R''@|$(GNULIB_MBSTOK_R)|g' \
142 -e 's|@''GNULIB_MEMCHR''@|$(GNULIB_MEMCHR)|g' \
143 -e 's|@''GNULIB_MEMMEM''@|$(GNULIB_MEMMEM)|g' \
144 -e 's|@''GNULIB_MEMPCPY''@|$(GNULIB_MEMPCPY)|g' \
145 -e 's|@''GNULIB_MEMRCHR''@|$(GNULIB_MEMRCHR)|g' \
146 -e 's|@''GNULIB_RAWMEMCHR''@|$(GNULIB_RAWMEMCHR)|g' \
147 -e 's|@''GNULIB_STPCPY''@|$(GNULIB_STPCPY)|g' \
148 -e 's|@''GNULIB_STPNCPY''@|$(GNULIB_STPNCPY)|g' \
149 -e 's|@''GNULIB_STRCHRNUL''@|$(GNULIB_STRCHRNUL)|g' \
150 -e 's|@''GNULIB_STRDUP''@|$(GNULIB_STRDUP)|g' \
151 -e 's|@''GNULIB_STRNCAT''@|$(GNULIB_STRNCAT)|g' \
152 -e 's|@''GNULIB_STRNDUP''@|$(GNULIB_STRNDUP)|g' \
153 -e 's|@''GNULIB_STRNLEN''@|$(GNULIB_STRNLEN)|g' \
154 -e 's|@''GNULIB_STRPBRK''@|$(GNULIB_STRPBRK)|g' \
155 -e 's|@''GNULIB_STRSEP''@|$(GNULIB_STRSEP)|g' \
156 -e 's|@''GNULIB_STRSTR''@|$(GNULIB_STRSTR)|g' \
157 -e 's|@''GNULIB_STRCASESTR''@|$(GNULIB_STRCASESTR)|g' \
158 -e 's|@''GNULIB_STRTOK_R''@|$(GNULIB_STRTOK_R)|g' \
159 -e 's|@''GNULIB_STRERROR''@|$(GNULIB_STRERROR)|g' \
160 -e 's|@''GNULIB_STRERROR_R''@|$(GNULIB_STRERROR_R)|g' \
161 -e 's|@''GNULIB_STRSIGNAL''@|$(GNULIB_STRSIGNAL)|g' \
162 -e 's|@''GNULIB_STRVERSCMP''@|$(GNULIB_STRVERSCMP)|g' \
163 < $(srcdir)/string.in.h | \
164 sed -e 's|@''HAVE_MBSLEN''@|$(HAVE_MBSLEN)|g' \
165 -e 's|@''HAVE_MEMCHR''@|$(HAVE_MEMCHR)|g' \
166 -e 's|@''HAVE_DECL_MEMMEM''@|$(HAVE_DECL_MEMMEM)|g' \
167 -e 's|@''HAVE_MEMPCPY''@|$(HAVE_MEMPCPY)|g' \
168 -e 's|@''HAVE_DECL_MEMRCHR''@|$(HAVE_DECL_MEMRCHR)|g' \
169 -e 's|@''HAVE_RAWMEMCHR''@|$(HAVE_RAWMEMCHR)|g' \
170 -e 's|@''HAVE_STPCPY''@|$(HAVE_STPCPY)|g' \
171 -e 's|@''HAVE_STPNCPY''@|$(HAVE_STPNCPY)|g' \
172 -e 's|@''HAVE_STRCHRNUL''@|$(HAVE_STRCHRNUL)|g' \
173 -e 's|@''HAVE_DECL_STRDUP''@|$(HAVE_DECL_STRDUP)|g' \
174 -e 's|@''HAVE_DECL_STRNDUP''@|$(HAVE_DECL_STRNDUP)|g' \
175 -e 's|@''HAVE_DECL_STRNLEN''@|$(HAVE_DECL_STRNLEN)|g' \
176 -e 's|@''HAVE_STRPBRK''@|$(HAVE_STRPBRK)|g' \
177 -e 's|@''HAVE_STRSEP''@|$(HAVE_STRSEP)|g' \
178 -e 's|@''HAVE_STRCASESTR''@|$(HAVE_STRCASESTR)|g' \
179 -e 's|@''HAVE_DECL_STRTOK_R''@|$(HAVE_DECL_STRTOK_R)|g' \
180 -e 's|@''HAVE_DECL_STRERROR_R''@|$(HAVE_DECL_STRERROR_R)|g' \
181 -e 's|@''HAVE_DECL_STRSIGNAL''@|$(HAVE_DECL_STRSIGNAL)|g' \
182 -e 's|@''HAVE_STRVERSCMP''@|$(HAVE_STRVERSCMP)|g' \
183 -e 's|@''REPLACE_STPNCPY''@|$(REPLACE_STPNCPY)|g' \
184 -e 's|@''REPLACE_MEMCHR''@|$(REPLACE_MEMCHR)|g' \
185 -e 's|@''REPLACE_MEMMEM''@|$(REPLACE_MEMMEM)|g' \
186 -e 's|@''REPLACE_STRCASESTR''@|$(REPLACE_STRCASESTR)|g' \
187 -e 's|@''REPLACE_STRDUP''@|$(REPLACE_STRDUP)|g' \
188 -e 's|@''REPLACE_STRSTR''@|$(REPLACE_STRSTR)|g' \
189 -e 's|@''REPLACE_STRERROR''@|$(REPLACE_STRERROR)|g' \
190 -e 's|@''REPLACE_STRERROR_R''@|$(REPLACE_STRERROR_R)|g' \
191 -e 's|@''REPLACE_STRNCAT''@|$(REPLACE_STRNCAT)|g' \
192 -e 's|@''REPLACE_STRNDUP''@|$(REPLACE_STRNDUP)|g' \
193 -e 's|@''REPLACE_STRNLEN''@|$(REPLACE_STRNLEN)|g' \
194 -e 's|@''REPLACE_STRSIGNAL''@|$(REPLACE_STRSIGNAL)|g' \
195 -e 's|@''REPLACE_STRTOK_R''@|$(REPLACE_STRTOK_R)|g' \
196 -e 's|@''UNDEFINE_STRTOK_R''@|$(UNDEFINE_STRTOK_R)|g' \
197 -e '/definitions of _GL_FUNCDECL_RPL/r $(CXXDEFS_H)' \
198 -e '/definition of _GL_ARG_NONNULL/r $(ARG_NONNULL_H)' \
199 -e '/definition of _GL_WARN_ON_USE/r $(WARN_ON_USE_H)'; \
200 < $(srcdir)/string.in.h; \
201 } > $@-t && \
202 mv $@-t $@
203MOSTLYCLEANFILES += string.h string.h-t
204
205EXTRA_DIST += string.in.h
206
207## end gnulib module string
208
209## begin gnulib module strtok_r
210
211
212EXTRA_DIST += strtok_r.c
213
214EXTRA_libgnu_la_SOURCES += strtok_r.c
215
216## end gnulib module strtok_r
217
218## begin gnulib module warn-on-use
219
220BUILT_SOURCES += warn-on-use.h
221# The warn-on-use.h that gets inserted into generated .h files is the same as
222# build-aux/warn-on-use.h, except that it has the copyright header cut off.
223warn-on-use.h: $(top_srcdir)/src/include/warn-on-use.h
224 $(AM_V_GEN)rm -f $@-t $@ && \
225 sed -n -e '/^.ifndef/,$$p' \
226 < $(top_srcdir)/src/include/warn-on-use.h \
227 > $@-t && \
228 mv $@-t $@
229MOSTLYCLEANFILES += warn-on-use.h warn-on-use.h-t
230
231WARN_ON_USE_H=warn-on-use.h
232
233EXTRA_DIST += $(top_srcdir)/src/include/warn-on-use.h
234
235## end gnulib module warn-on-use
236
237## begin gnulib module dummy
238
239libgnu_la_SOURCES += dummy.c
240
241## end gnulib module dummy
242
243
244mostlyclean-local: mostlyclean-generic
245 @for dir in '' $(MOSTLYCLEANDIRS); do \
246 if test -n "$$dir" && test -d $$dir; then \
247 echo "rmdir $$dir"; rmdir $$dir; \
248 fi; \
249 done; \
250 :