aboutsummaryrefslogtreecommitdiff
path: root/src/util/libgnu/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/libgnu/Makefile.am')
-rw-r--r--src/util/libgnu/Makefile.am248
1 files changed, 248 insertions, 0 deletions
diff --git a/src/util/libgnu/Makefile.am b/src/util/libgnu/Makefile.am
new file mode 100644
index 000000000..b0f704c61
--- /dev/null
+++ b/src/util/libgnu/Makefile.am
@@ -0,0 +1,248 @@
1## DO NOT EDIT! GENERATED AUTOMATICALLY!
2## Process this file with automake to produce Makefile.in.
3# Copyright (C) 2002-2011 Free Software Foundation, Inc.
4#
5# This file is free software, distributed under the terms of the GNU
6# General Public License. As a special exception to the GNU General
7# Public License, this file may be distributed as part of a program
8# that contains a configuration script generated by Autoconf, under
9# the same distribution terms as the rest of that program.
10#
11# Generated by gnulib-tool.
12# Reproduce by: gnulib-tool --import --dir=/home/nils/workspace/gnunet --lib=libgnu --source-base=src/util/libgnu --m4-base=m4 --doc-base=doc --tests-base=tests --aux-dir=. --libtool --macro-prefix=gl strtok_r
13
14AUTOMAKE_OPTIONS = 1.5 gnits
15
16SUBDIRS =
17noinst_HEADERS =
18noinst_LIBRARIES =
19noinst_LTLIBRARIES =
20EXTRA_DIST =
21BUILT_SOURCES =
22SUFFIXES =
23MOSTLYCLEANFILES = core *.stackdump
24MOSTLYCLEANDIRS =
25CLEANFILES =
26DISTCLEANFILES =
27MAINTAINERCLEANFILES =
28
29AM_CPPFLAGS =
30AM_CFLAGS =
31
32noinst_LTLIBRARIES += libgnu.la
33
34libgnu_la_SOURCES =
35libgnu_la_LIBADD = $(gl_LTLIBOBJS)
36libgnu_la_DEPENDENCIES = $(gl_LTLIBOBJS)
37EXTRA_libgnu_la_SOURCES =
38libgnu_la_LDFLAGS = $(AM_LDFLAGS)
39libgnu_la_LDFLAGS += -no-undefined
40
41## begin gnulib module arg-nonnull
42
43# The BUILT_SOURCES created by this Makefile snippet are not used via #include
44# statements but through direct file reference. Therefore this snippet must be
45# present in all Makefile.am that need it. This is ensured by the applicability
46# 'all' defined above.
47
48BUILT_SOURCES += arg-nonnull.h
49# The arg-nonnull.h that gets inserted into generated .h files is the same as
50# build-aux/arg-nonnull.h, except that it has the copyright header cut off.
51arg-nonnull.h: $(top_srcdir)/./arg-nonnull.h
52 $(AM_V_GEN)rm -f $@-t $@ && \
53 sed -n -e '/GL_ARG_NONNULL/,$$p' \
54 < $(top_srcdir)/./arg-nonnull.h \
55 > $@-t && \
56 mv $@-t $@
57MOSTLYCLEANFILES += arg-nonnull.h arg-nonnull.h-t
58
59ARG_NONNULL_H=arg-nonnull.h
60
61EXTRA_DIST += $(top_srcdir)/./arg-nonnull.h
62
63## end gnulib module arg-nonnull
64
65## begin gnulib module c++defs
66
67# The BUILT_SOURCES created by this Makefile snippet are not used via #include
68# statements but through direct file reference. Therefore this snippet must be
69# present in all Makefile.am that need it. This is ensured by the applicability
70# 'all' defined above.
71
72BUILT_SOURCES += c++defs.h
73# The c++defs.h that gets inserted into generated .h files is the same as
74# build-aux/c++defs.h, except that it has the copyright header cut off.
75c++defs.h: $(top_srcdir)/./c++defs.h
76 $(AM_V_GEN)rm -f $@-t $@ && \
77 sed -n -e '/_GL_CXXDEFS/,$$p' \
78 < $(top_srcdir)/./c++defs.h \
79 > $@-t && \
80 mv $@-t $@
81MOSTLYCLEANFILES += c++defs.h c++defs.h-t
82
83CXXDEFS_H=c++defs.h
84
85EXTRA_DIST += $(top_srcdir)/./c++defs.h
86
87## end gnulib module c++defs
88
89## begin gnulib module stddef
90
91BUILT_SOURCES += $(STDDEF_H)
92
93# We need the following in order to create <stddef.h> when the system
94# doesn't have one that works with the given compiler.
95stddef.h: stddef.in.h
96 $(AM_V_GEN)rm -f $@-t $@ && \
97 { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */' && \
98 sed -e 's|@''INCLUDE_NEXT''@|$(INCLUDE_NEXT)|g' \
99 -e 's|@''PRAGMA_SYSTEM_HEADER''@|@PRAGMA_SYSTEM_HEADER@|g' \
100 -e 's|@''PRAGMA_COLUMNS''@|@PRAGMA_COLUMNS@|g' \
101 -e 's|@''NEXT_STDDEF_H''@|$(NEXT_STDDEF_H)|g' \
102 -e 's|@''HAVE_WCHAR_T''@|$(HAVE_WCHAR_T)|g' \
103 -e 's|@''REPLACE_NULL''@|$(REPLACE_NULL)|g' \
104 < $(srcdir)/stddef.in.h; \
105 } > $@-t && \
106 mv $@-t $@
107MOSTLYCLEANFILES += stddef.h stddef.h-t
108
109EXTRA_DIST += stddef.in.h
110
111## end gnulib module stddef
112
113## begin gnulib module string
114
115BUILT_SOURCES += string.h
116
117# We need the following in order to create <string.h> when the system
118# doesn't have one that works with the given compiler.
119string.h: string.in.h $(CXXDEFS_H) $(ARG_NONNULL_H) $(WARN_ON_USE_H)
120 $(AM_V_GEN)rm -f $@-t $@ && \
121 { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */' && \
122 sed -e 's|@''INCLUDE_NEXT''@|$(INCLUDE_NEXT)|g' \
123 -e 's|@''PRAGMA_SYSTEM_HEADER''@|@PRAGMA_SYSTEM_HEADER@|g' \
124 -e 's|@''PRAGMA_COLUMNS''@|@PRAGMA_COLUMNS@|g' \
125 -e 's|@''NEXT_STRING_H''@|$(NEXT_STRING_H)|g' \
126 -e 's|@''GNULIB_MBSLEN''@|$(GNULIB_MBSLEN)|g' \
127 -e 's|@''GNULIB_MBSNLEN''@|$(GNULIB_MBSNLEN)|g' \
128 -e 's|@''GNULIB_MBSCHR''@|$(GNULIB_MBSCHR)|g' \
129 -e 's|@''GNULIB_MBSRCHR''@|$(GNULIB_MBSRCHR)|g' \
130 -e 's|@''GNULIB_MBSSTR''@|$(GNULIB_MBSSTR)|g' \
131 -e 's|@''GNULIB_MBSCASECMP''@|$(GNULIB_MBSCASECMP)|g' \
132 -e 's|@''GNULIB_MBSNCASECMP''@|$(GNULIB_MBSNCASECMP)|g' \
133 -e 's|@''GNULIB_MBSPCASECMP''@|$(GNULIB_MBSPCASECMP)|g' \
134 -e 's|@''GNULIB_MBSCASESTR''@|$(GNULIB_MBSCASESTR)|g' \
135 -e 's|@''GNULIB_MBSCSPN''@|$(GNULIB_MBSCSPN)|g' \
136 -e 's|@''GNULIB_MBSPBRK''@|$(GNULIB_MBSPBRK)|g' \
137 -e 's|@''GNULIB_MBSSPN''@|$(GNULIB_MBSSPN)|g' \
138 -e 's|@''GNULIB_MBSSEP''@|$(GNULIB_MBSSEP)|g' \
139 -e 's|@''GNULIB_MBSTOK_R''@|$(GNULIB_MBSTOK_R)|g' \
140 -e 's|@''GNULIB_MEMCHR''@|$(GNULIB_MEMCHR)|g' \
141 -e 's|@''GNULIB_MEMMEM''@|$(GNULIB_MEMMEM)|g' \
142 -e 's|@''GNULIB_MEMPCPY''@|$(GNULIB_MEMPCPY)|g' \
143 -e 's|@''GNULIB_MEMRCHR''@|$(GNULIB_MEMRCHR)|g' \
144 -e 's|@''GNULIB_RAWMEMCHR''@|$(GNULIB_RAWMEMCHR)|g' \
145 -e 's|@''GNULIB_STPCPY''@|$(GNULIB_STPCPY)|g' \
146 -e 's|@''GNULIB_STPNCPY''@|$(GNULIB_STPNCPY)|g' \
147 -e 's|@''GNULIB_STRCHRNUL''@|$(GNULIB_STRCHRNUL)|g' \
148 -e 's|@''GNULIB_STRDUP''@|$(GNULIB_STRDUP)|g' \
149 -e 's|@''GNULIB_STRNCAT''@|$(GNULIB_STRNCAT)|g' \
150 -e 's|@''GNULIB_STRNDUP''@|$(GNULIB_STRNDUP)|g' \
151 -e 's|@''GNULIB_STRNLEN''@|$(GNULIB_STRNLEN)|g' \
152 -e 's|@''GNULIB_STRPBRK''@|$(GNULIB_STRPBRK)|g' \
153 -e 's|@''GNULIB_STRSEP''@|$(GNULIB_STRSEP)|g' \
154 -e 's|@''GNULIB_STRSTR''@|$(GNULIB_STRSTR)|g' \
155 -e 's|@''GNULIB_STRCASESTR''@|$(GNULIB_STRCASESTR)|g' \
156 -e 's|@''GNULIB_STRTOK_R''@|$(GNULIB_STRTOK_R)|g' \
157 -e 's|@''GNULIB_STRERROR''@|$(GNULIB_STRERROR)|g' \
158 -e 's|@''GNULIB_STRERROR_R''@|$(GNULIB_STRERROR_R)|g' \
159 -e 's|@''GNULIB_STRSIGNAL''@|$(GNULIB_STRSIGNAL)|g' \
160 -e 's|@''GNULIB_STRVERSCMP''@|$(GNULIB_STRVERSCMP)|g' \
161 < $(srcdir)/string.in.h | \
162 sed -e 's|@''HAVE_MBSLEN''@|$(HAVE_MBSLEN)|g' \
163 -e 's|@''HAVE_MEMCHR''@|$(HAVE_MEMCHR)|g' \
164 -e 's|@''HAVE_DECL_MEMMEM''@|$(HAVE_DECL_MEMMEM)|g' \
165 -e 's|@''HAVE_MEMPCPY''@|$(HAVE_MEMPCPY)|g' \
166 -e 's|@''HAVE_DECL_MEMRCHR''@|$(HAVE_DECL_MEMRCHR)|g' \
167 -e 's|@''HAVE_RAWMEMCHR''@|$(HAVE_RAWMEMCHR)|g' \
168 -e 's|@''HAVE_STPCPY''@|$(HAVE_STPCPY)|g' \
169 -e 's|@''HAVE_STPNCPY''@|$(HAVE_STPNCPY)|g' \
170 -e 's|@''HAVE_STRCHRNUL''@|$(HAVE_STRCHRNUL)|g' \
171 -e 's|@''HAVE_DECL_STRDUP''@|$(HAVE_DECL_STRDUP)|g' \
172 -e 's|@''HAVE_DECL_STRNDUP''@|$(HAVE_DECL_STRNDUP)|g' \
173 -e 's|@''HAVE_DECL_STRNLEN''@|$(HAVE_DECL_STRNLEN)|g' \
174 -e 's|@''HAVE_STRPBRK''@|$(HAVE_STRPBRK)|g' \
175 -e 's|@''HAVE_STRSEP''@|$(HAVE_STRSEP)|g' \
176 -e 's|@''HAVE_STRCASESTR''@|$(HAVE_STRCASESTR)|g' \
177 -e 's|@''HAVE_DECL_STRTOK_R''@|$(HAVE_DECL_STRTOK_R)|g' \
178 -e 's|@''HAVE_DECL_STRERROR_R''@|$(HAVE_DECL_STRERROR_R)|g' \
179 -e 's|@''HAVE_DECL_STRSIGNAL''@|$(HAVE_DECL_STRSIGNAL)|g' \
180 -e 's|@''HAVE_STRVERSCMP''@|$(HAVE_STRVERSCMP)|g' \
181 -e 's|@''REPLACE_STPNCPY''@|$(REPLACE_STPNCPY)|g' \
182 -e 's|@''REPLACE_MEMCHR''@|$(REPLACE_MEMCHR)|g' \
183 -e 's|@''REPLACE_MEMMEM''@|$(REPLACE_MEMMEM)|g' \
184 -e 's|@''REPLACE_STRCASESTR''@|$(REPLACE_STRCASESTR)|g' \
185 -e 's|@''REPLACE_STRDUP''@|$(REPLACE_STRDUP)|g' \
186 -e 's|@''REPLACE_STRSTR''@|$(REPLACE_STRSTR)|g' \
187 -e 's|@''REPLACE_STRERROR''@|$(REPLACE_STRERROR)|g' \
188 -e 's|@''REPLACE_STRERROR_R''@|$(REPLACE_STRERROR_R)|g' \
189 -e 's|@''REPLACE_STRNCAT''@|$(REPLACE_STRNCAT)|g' \
190 -e 's|@''REPLACE_STRNDUP''@|$(REPLACE_STRNDUP)|g' \
191 -e 's|@''REPLACE_STRNLEN''@|$(REPLACE_STRNLEN)|g' \
192 -e 's|@''REPLACE_STRSIGNAL''@|$(REPLACE_STRSIGNAL)|g' \
193 -e 's|@''REPLACE_STRTOK_R''@|$(REPLACE_STRTOK_R)|g' \
194 -e 's|@''UNDEFINE_STRTOK_R''@|$(UNDEFINE_STRTOK_R)|g' \
195 -e '/definitions of _GL_FUNCDECL_RPL/r $(CXXDEFS_H)' \
196 -e '/definition of _GL_ARG_NONNULL/r $(ARG_NONNULL_H)' \
197 -e '/definition of _GL_WARN_ON_USE/r $(WARN_ON_USE_H)'; \
198 < $(srcdir)/string.in.h; \
199 } > $@-t && \
200 mv $@-t $@
201MOSTLYCLEANFILES += string.h string.h-t
202
203EXTRA_DIST += string.in.h
204
205## end gnulib module string
206
207## begin gnulib module strtok_r
208
209
210EXTRA_DIST += strtok_r.c
211
212EXTRA_libgnu_la_SOURCES += strtok_r.c
213
214## end gnulib module strtok_r
215
216## begin gnulib module warn-on-use
217
218BUILT_SOURCES += warn-on-use.h
219# The warn-on-use.h that gets inserted into generated .h files is the same as
220# build-aux/warn-on-use.h, except that it has the copyright header cut off.
221warn-on-use.h: $(top_srcdir)/./warn-on-use.h
222 $(AM_V_GEN)rm -f $@-t $@ && \
223 sed -n -e '/^.ifndef/,$$p' \
224 < $(top_srcdir)/./warn-on-use.h \
225 > $@-t && \
226 mv $@-t $@
227MOSTLYCLEANFILES += warn-on-use.h warn-on-use.h-t
228
229WARN_ON_USE_H=warn-on-use.h
230
231EXTRA_DIST += $(top_srcdir)/./warn-on-use.h
232
233## end gnulib module warn-on-use
234
235## begin gnulib module dummy
236
237libgnu_la_SOURCES += dummy.c
238
239## end gnulib module dummy
240
241
242mostlyclean-local: mostlyclean-generic
243 @for dir in '' $(MOSTLYCLEANDIRS); do \
244 if test -n "$$dir" && test -d $$dir; then \
245 echo "rmdir $$dir"; rmdir $$dir; \
246 fi; \
247 done; \
248 :