aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarkus Teich <markus.teich@stusta.mhn.de>2016-06-12 20:52:22 +0200
committerMarkus Teich <markus.teich@stusta.mhn.de>2016-06-12 20:52:22 +0200
commit62b87e57a7f7042d27fe0a80b9194aeae0c14a50 (patch)
tree961a43363dbca413e4b1e65b367c0ffd553cfaf0 /Makefile.am
parent5957a777076d014b17aada25afe0991397edbacc (diff)
downloadlibbrandt-62b87e57a7f7042d27fe0a80b9194aeae0c14a50.tar.gz
libbrandt-62b87e57a7f7042d27fe0a80b9194aeae0c14a50.zip
add tests for key generation
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d13e662..8264db3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,6 +5,7 @@ lib_LTLIBRARIES = \
5 libbrandt.la 5 libbrandt.la
6 6
7libbrandt_la_SOURCES = \ 7libbrandt_la_SOURCES = \
8 brandt.c \
8 crypto.c \ 9 crypto.c \
9 util.c 10 util.c
10 11
@@ -13,3 +14,11 @@ libbrandt_la_LIBADD = \
13 14
14libbrandt_la_LDFLAGS = \ 15libbrandt_la_LDFLAGS = \
15 -version-info 0:0:0 16 -version-info 0:0:0
17
18check_PROGRAMS = \
19 test_crypto
20
21test_crypto_SOURCES = test_crypto.c
22test_crypto_LDADD = libbrandt.la -lgcrypt -lgpg-error
23
24TESTS = $(check_PROGRAMS)