aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHeikki Lindholm <holin@iki.fi>2008-06-20 12:45:27 +0000
committerHeikki Lindholm <holin@iki.fi>2008-06-20 12:45:27 +0000
commit23dbd4271c4e97a45db91d6b012a664daeb985a9 (patch)
tree4a76d7beaf9b344ac80c6068c6418013f13352d4 /configure.ac
parent47fdd453d21070b178c07024be12749b2c8a5786 (diff)
downloadlibextractor-23dbd4271c4e97a45db91d6b012a664daeb985a9.tar.gz
libextractor-23dbd4271c4e97a45db91d6b012a664daeb985a9.zip
add preliminary ffmpeg-based thumbnail extractor
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac58
1 files changed, 57 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 887ab82..a94ce4b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -477,6 +477,22 @@ AC_ARG_ENABLE(printable,
477 printable=1]) 477 printable=1])
478AM_CONDITIONAL(HAVE_PRINTABLE, test x$printable != x0) 478AM_CONDITIONAL(HAVE_PRINTABLE, test x$printable != x0)
479 479
480ffmpeg_enabled=0
481AC_MSG_CHECKING([whether to enable the FFmpeg thumbnail extractor])
482AC_ARG_ENABLE(ffmpeg,
483 [AC_HELP_STRING([--enable-ffmpeg],[Enable FFmpeg support])
484 AC_HELP_STRING([--disable-ffmpeg],[Disable FFmpeg support])],
485 [case "$enableval" in
486 no) AC_MSG_RESULT(no)
487 ffmpeg_enabled=0
488 ;;
489 *) AC_MSG_RESULT(yes)
490 ffmpeg_enabled=1
491 ;;
492 esac],
493 [ AC_MSG_RESULT(no)
494 ffmpeg_enabled=0])
495AM_CONDITIONAL(HAVE_FFMPEG, test x$ffmpeg_enabled != x0)
480 496
481AC_SUBST(CPPFLAGS) 497AC_SUBST(CPPFLAGS)
482AC_SUBST(LDFLAGS) 498AC_SUBST(LDFLAGS)
@@ -499,6 +515,7 @@ src/plugins/rpm/Makefile
499src/plugins/printable/Makefile 515src/plugins/printable/Makefile
500src/plugins/hash/Makefile 516src/plugins/hash/Makefile
501src/plugins/thumbnail/Makefile 517src/plugins/thumbnail/Makefile
518src/plugins/thumbnailffmpeg/Makefile
502src/plugins/exiv2/Makefile 519src/plugins/exiv2/Makefile
503src/test/Makefile 520src/test/Makefile
504]) 521])
@@ -506,6 +523,38 @@ src/test/Makefile
506LIBEXTRACTOR_VERSION="0.5.18a" 523LIBEXTRACTOR_VERSION="0.5.18a"
507AX_CREATE_PKGCONFIG_INFO([libextractor.pc],,[-lextractor],[Metadata extraction library],,) 524AX_CREATE_PKGCONFIG_INFO([libextractor.pc],,[-lextractor],[Metadata extraction library],,)
508 525
526if test "x$ffmpeg_enabled" = "x1"
527then
528 AC_MSG_NOTICE([configuring FFmpeg])
529 cd src/plugins/thumbnailffmpeg/ffmpeg/
530 if ! ./configure \
531 --prefix=/tmp \
532 --disable-mmx \
533 --disable-altivec \
534 --enable-shared \
535 --enable-swscale \
536 --enable-gpl \
537 --disable-vhook \
538 --disable-postproc \
539 --disable-network \
540 --disable-ffmpeg \
541 --disable-ffserver \
542 --disable-ffplay \
543 --disable-devices \
544 --disable-protocols \
545 --disable-bsfs \
546 --disable-parsers \
547 --disable-muxers \
548 --disable-demuxers \
549 --disable-encoders \
550 --disable-decoders \
551 --enable-encoder=png \
552 --enable-decoder=png
553 then
554 AC_MSG_ERROR([FFmpeg configure failed.])
555 fi
556 cd ../../../../
557fi
509 558
510AC_OUTPUT 559AC_OUTPUT
511 560
@@ -534,7 +583,14 @@ then
534 AC_MSG_NOTICE([NOTICE: libgsf not found, no OLE2 (MS Office) support]) 583 AC_MSG_NOTICE([NOTICE: libgsf not found, no OLE2 (MS Office) support])
535fi 584fi
536 585
537if test "x$without_gtk" = "xtrue" -a "x$qt" = "x0" 586if test "x$ffmpeg_enabled" = "x0"
587then
588 AC_MSG_NOTICE([NOTICE: FFmpeg thumbnailer plugin disabled])
589else
590 AC_MSG_NOTICE([NOTICE: FFmpeg thumbnailer plugin enabled (security untested)])
591fi
592
593if test "x$without_gtk" = "xtrue" -a "x$qt" = "x0" -a "x$ffmpeg_enabled" = "x0"
538then 594then
539 AC_MSG_NOTICE([NOTICE: neither gtk nor Qt not found, no thumbnail support]) 595 AC_MSG_NOTICE([NOTICE: neither gtk nor Qt not found, no thumbnail support])
540fi 596fi