aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-08-27 18:51:58 +0000
committerChristian Grothoff <christian@grothoff.org>2012-08-27 18:51:58 +0000
commit343a04ebadbfd04b29cf17ae3ed5b9cf890c2c35 (patch)
tree7f10a824143de2c3ded4e5e4df1f3db8280948d7 /configure.ac
parent0d6694b10ed5c3429f0b2d6f5d4b266fe1179435 (diff)
downloadlibextractor-343a04ebadbfd04b29cf17ae3ed5b9cf890c2c35.tar.gz
libextractor-343a04ebadbfd04b29cf17ae3ed5b9cf890c2c35.zip
trying to improve gtk detection
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 06c4469..17647a9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -483,12 +483,12 @@ AC_ARG_WITH(gtk_version,
483without_gtk=false 483without_gtk=false
484if test "x$check_for_3" != "xfalse" 484if test "x$check_for_3" != "xfalse"
485then 485then
486 AM_PATH_GTK_3_0([$check_for_3],without_gtk=false,) 486 AM_PATH_GTK_3_0([$check_for_3],without_gtk=false,without_gtk=true)
487fi 487fi
488 488
489if test "x$without_gtk" == "xfalse" -a "x$check_for_2" != "xfalse" 489if test "x$without_gtk" == "xfalse" -a "x$check_for_2" != "xfalse"
490then 490then
491 AM_PATH_GTK_2_0([$check_for_2],without_gtk=false,) 491 AM_PATH_GTK_2_0([$check_for_2],without_gtk=false,without_gtk=true)
492fi 492fi
493 493
494AM_CONDITIONAL(HAVE_GTK, test x$without_gtk != xtrue) 494AM_CONDITIONAL(HAVE_GTK, test x$without_gtk != xtrue)
@@ -703,3 +703,8 @@ then
703else 703else
704 AC_MSG_NOTICE([NOTICE: gstreamer not found, gstreamer support disabled]) 704 AC_MSG_NOTICE([NOTICE: gstreamer not found, gstreamer support disabled])
705fi 705fi
706
707if test $without_gtk != false
708then
709 AC_MSG_NOTICE([NOTICE: gtk+ not found, gtk support disabled])
710fi