aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2011-11-28 16:16:12 +0000
committerChristian Grothoff <christian@grothoff.org>2011-11-28 16:16:12 +0000
commit6c673c55b78cae1137324e192be378f20d03f951 (patch)
tree85e0a534846ebc53c8b19b2c2caa265617fe562e /configure.ac
parentffbfc284e574b37c4680f6da9afb1489e35d4eff (diff)
downloadlibextractor-6c673c55b78cae1137324e192be378f20d03f951.tar.gz
libextractor-6c673c55b78cae1137324e192be378f20d03f951.zip
improved w32 winsock detection
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 90ac4de..f07b944 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,7 +93,13 @@ mingw*)
93 AC_DEFINE_UNQUOTED(MINGW,1,[This is a MinGW system]) 93 AC_DEFINE_UNQUOTED(MINGW,1,[This is a MinGW system])
94 AC_DEFINE_UNQUOTED(WINDOWS,1,[This is a Windows system]) 94 AC_DEFINE_UNQUOTED(WINDOWS,1,[This is a Windows system])
95 AC_CHECK_LIB(intl, gettext) 95 AC_CHECK_LIB(intl, gettext)
96 AC_CHECK_LIB(ws2_32, _head_libws2_32_a,,[AC_MSG_ERROR([libextractor requires Winsock2])]) 96 mingw32_ws2=yes
97 mingw64_ws2=yes
98 AC_CHECK_LIB(ws2_32, _head_libws2_32_a,,mingw32_ws2=no)
99 AC_CHECK_LIB(ws2_32, __imp_socket,,mingw64_ws2=no)
100 if test "x$mingw32_ws2" = "xno" -a "x$mingw64_ws2" = "xno"; then
101 AC_MSG_ERROR([libextractor requires Winsock2])
102 fi
97 AC_CHECK_LIB(plibc, plibc_init,,[AC_MSG_ERROR([libextractor requires PlibC])]) 103 AC_CHECK_LIB(plibc, plibc_init,,[AC_MSG_ERROR([libextractor requires PlibC])])
98 LDFLAGS="$LDFLAGS -Wl,-no-undefined -Wl,--export-all-symbols" 104 LDFLAGS="$LDFLAGS -Wl,-no-undefined -Wl,--export-all-symbols"
99 LIBSOLD=$LIBS 105 LIBSOLD=$LIBS