aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-03-27 13:05:17 +0000
committerChristian Grothoff <christian@grothoff.org>2012-03-27 13:05:17 +0000
commita9ce3d5f0c7a493ab94c724f1a60021f4bdb0533 (patch)
tree5f0cb7e19b72c3a4ad7e70688eef133aed7e3ad8 /configure.ac
parent2ae590d7ef42e827f7700f02bca519b6bb5acbe5 (diff)
downloadlibextractor-a9ce3d5f0c7a493ab94c724f1a60021f4bdb0533.tar.gz
libextractor-a9ce3d5f0c7a493ab94c724f1a60021f4bdb0533.zip
LRN is refactoring the plugin API, and hell breaks loose
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 003b078..553da74 100644
--- a/configure.ac
+++ b/configure.ac
@@ -101,6 +101,8 @@ mingw*)
101 if test "x$mingw32_ws2" = "xno" -a "x$mingw64_ws2" = "xno"; then 101 if test "x$mingw32_ws2" = "xno" -a "x$mingw64_ws2" = "xno"; then
102 AC_MSG_ERROR([libextractor requires Winsock2]) 102 AC_MSG_ERROR([libextractor requires Winsock2])
103 fi 103 fi
104 # Sufficiently new Windows XP
105 CFLAGS="-D__MSVCRT_VERSION__=0x0601 $CFLAGS"
104 106
105 AC_MSG_CHECKING(for PlibC) 107 AC_MSG_CHECKING(for PlibC)
106 plibc=0 108 plibc=0
@@ -136,6 +138,8 @@ mingw*)
136 if test $plibc -ne 1; 138 if test $plibc -ne 1;
137 then 139 then
138 AC_MSG_ERROR([libextractor requires PlibC]) 140 AC_MSG_ERROR([libextractor requires PlibC])
141 else
142 LIBS="$LIBS -lplibc"
139 fi 143 fi
140 144
141 LDFLAGS="$LDFLAGS -Wl,-no-undefined -Wl,--export-all-symbols" 145 LDFLAGS="$LDFLAGS -Wl,-no-undefined -Wl,--export-all-symbols"
@@ -336,7 +340,7 @@ AC_FUNC_STAT
336AC_FUNC_ERROR_AT_LINE 340AC_FUNC_ERROR_AT_LINE
337AC_SEARCH_LIBS(dlopen, dl) 341AC_SEARCH_LIBS(dlopen, dl)
338AC_SEARCH_LIBS(shm_open, rt) 342AC_SEARCH_LIBS(shm_open, rt)
339AC_CHECK_FUNCS([mkstemp strndup munmap strcasecmp strdup strncasecmp memmove memset strtoul floor getcwd pow setenv sqrt strchr strcspn strrchr strnlen strndup ftruncate shm_open shm_unlink]) 343AC_CHECK_FUNCS([mkstemp strndup munmap strcasecmp strdup strncasecmp memmove memset strtoul floor getcwd pow setenv sqrt strchr strcspn strrchr strnlen strndup ftruncate shm_open shm_unlink lseek64])
340LE_LIB_LIBS=$LIBS 344LE_LIB_LIBS=$LIBS
341LIBS=$LIBSOLD 345LIBS=$LIBSOLD
342 346