aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-08-14 16:53:51 +0000
committerChristian Grothoff <christian@grothoff.org>2012-08-14 16:53:51 +0000
commitb493473bd11d42ca9c57d3c48ed0958f5ea5c784 (patch)
tree73b81006aaafbeda29684b86ae0d6a8fd053744d /configure.ac
parent5e1200cd82ff8e247523f0ec5ccb68898d7ea14f (diff)
downloadlibextractor-b493473bd11d42ca9c57d3c48ed0958f5ea5c784.tar.gz
libextractor-b493473bd11d42ca9c57d3c48ed0958f5ea5c784.zip
cleaning up configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac51
1 files changed, 27 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index d63e9b9..03d493e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,11 +1,11 @@
1# Process this file with autoconf to produce a configure script. 1# Process this file with autoconf to produce a configure script.
2AC_PREREQ(2.61) 2AC_PREREQ(2.61)
3AC_INIT([libextractor], [0.6.3], [bug-libextractor@gnu.org]) 3AC_INIT([libextractor], [0.6.3], [bug-libextractor@gnu.org])
4LT_CONFIG_LTDL_DIR([libltdl])
5AC_CONFIG_AUX_DIR([libltdl/config])
6AM_INIT_AUTOMAKE([silent-rules])
7AC_CONFIG_HEADERS([config.h]) 4AC_CONFIG_HEADERS([config.h])
8AH_TOP([#define _GNU_SOURCE 1]) 5AH_TOP([#define _GNU_SOURCE 1])
6AC_CANONICAL_TARGET
7AC_CANONICAL_HOST
8AC_CANONICAL_SYSTEM
9 9
10LIB_VERSION_CURRENT=3 10LIB_VERSION_CURRENT=3
11LIB_VERSION_REVISION=2 11LIB_VERSION_REVISION=2
@@ -14,9 +14,11 @@ AC_SUBST(LIB_VERSION_CURRENT)
14AC_SUBST(LIB_VERSION_REVISION) 14AC_SUBST(LIB_VERSION_REVISION)
15AC_SUBST(LIB_VERSION_AGE) 15AC_SUBST(LIB_VERSION_AGE)
16 16
17LT_CONFIG_LTDL_DIR([libltdl])
18AC_CONFIG_AUX_DIR([libltdl/config])
19AM_INIT_AUTOMAKE([silent-rules])
20
17# Checks for programs. 21# Checks for programs.
18AC_CANONICAL_HOST
19AC_CANONICAL_TARGET
20AC_USE_SYSTEM_EXTENSIONS 22AC_USE_SYSTEM_EXTENSIONS
21AC_PROG_AWK 23AC_PROG_AWK
22AC_PROG_CC 24AC_PROG_CC
@@ -88,7 +90,8 @@ darwin*)
88 AM_CONDITIONAL(HAVE_GNU_LD, false) 90 AM_CONDITIONAL(HAVE_GNU_LD, false)
89 AM_CONDITIONAL(SOMEBSD, false) 91 AM_CONDITIONAL(SOMEBSD, false)
90 AM_CONDITIONAL(WINDOWS, false) 92 AM_CONDITIONAL(WINDOWS, false)
91 CFLAGS="-fno-common $CFLAGS" 93 CPPFLAGS="-D_APPLE_C_SOURCE $CPPFLAGS"
94 CFLAGS="-no-cpp-precomp -fno-common $CFLAGS"
92 LIBEXT=.so 95 LIBEXT=.so
93 ;; 96 ;;
94cygwin*) 97cygwin*)
@@ -361,21 +364,6 @@ AC_CHECK_LIB(magic, magic_open,
361# restore LIBS 364# restore LIBS
362LIBS=$LIBSOLD 365LIBS=$LIBSOLD
363 366
364# Special check for broken Operating Systems (OS X)
365AC_CACHE_CHECK(whether ${CC-cc} accepts -no-cpp-precomp,
366cv_prog_cc_darwin_cpp_precomp,
367[echo 'void f(){}' > conftest.c
368if test -z "`${CC-cc} -no-cpp-precomp -c conftest.c 2>&1`"; then
369 cv_prog_cc_darwin_cpp_precomp=yes
370else
371 cv_prog_cc_darwin_cpp_precomp=no
372fi
373rm -f conftest*
374])
375if test $cv_prog_cc_darwin_cpp_precomp = yes; then
376 CFLAGS="$CFLAGS -no-cpp-precomp"
377fi
378
379 367
380# Checks for header files. 368# Checks for header files.
381AC_HEADER_STDC 369AC_HEADER_STDC
@@ -676,12 +664,27 @@ AC_OUTPUT
676 664
677if test "x$HAVE_ZLIB_TRUE" = "x#" 665if test "x$HAVE_ZLIB_TRUE" = "x#"
678then 666then
679 AC_MSG_ERROR([FATAL: zlib not found (headers not installed?)]) 667 AC_MSG_NOTICE([NOTICE: zlib not found, zlib support disabled])
668fi
669
670if test "x$HAVE_BZ2_TRUE" = "x#"
671then
672 AC_MSG_NOTICE([NOTICE: libbz2 not found, bz2 support disabled])
673fi
674
675if test "x$HAVE_EXIV2_TRUE" = "x#"
676then
677 AC_MSG_NOTICE([NOTICE: libexiv2 not found, exiv2 disabled])
678fi
679
680if test "x$HAVE_JPEG_TRUE" = "x#"
681then
682 AC_MSG_NOTICE([NOTICE: libjpeg not found, jpeg disabled])
680fi 683fi
681 684
682if test "x$HAVE_EXIV2" = "x#" 685if test "x$HAVE_GIF_TRUE" = "x#"
683then 686then
684 AC_MSG_NOTICE([NOTICE: exiv2 disabled]) 687 AC_MSG_NOTICE([NOTICE: libgif not found, gif disabled])
685fi 688fi
686 689
687if test "x$have_gsf" != "xtrue" 690if test "x$have_gsf" != "xtrue"