aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHeikki Lindholm <holin@iki.fi>2009-12-27 06:52:50 +0000
committerHeikki Lindholm <holin@iki.fi>2009-12-27 06:52:50 +0000
commitbd14367713de0789d0ec786b2a201a8ecacc029a (patch)
treebbbc53c18e9b48d43d90b1ff7b3ff3f4b47a0b2f /configure.ac
parent47ef995cad970158ace3987dc231cb3877f5f091 (diff)
downloadlibextractor-bd14367713de0789d0ec786b2a201a8ecacc029a.tar.gz
libextractor-bd14367713de0789d0ec786b2a201a8ecacc029a.zip
-ldl clean-up
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 4d08feb..16800ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,6 +26,9 @@ AC_PROG_LN_S
26AC_PROG_MAKE_SET 26AC_PROG_MAKE_SET
27LT_CONFIG_LTDL_DIR([libltdl]) 27LT_CONFIG_LTDL_DIR([libltdl])
28AC_CANONICAL_HOST 28AC_CANONICAL_HOST
29# save LIBS, libtool does a AC_SEARCH_LIBS(dlopen, dl), but plugins
30# need not have -ldl added
31LIBSOLD=$LIBS
29LT_INIT([disable-static dlopen win32-dll]) 32LT_INIT([disable-static dlopen win32-dll])
30LTDL_INIT 33LTDL_INIT
31AC_SUBST(LTDLINCL) 34AC_SUBST(LTDLINCL)
@@ -149,15 +152,10 @@ AM_CONDITIONAL(HAVE_CXX, test "x$HAVE_CXX" = "xyes")
149 152
150# Checks for libraries. 153# Checks for libraries.
151 154
152# the library tests that follow should not result in every plugin linking to them,
153# thus we need to backup LIBS and restore
154LIBSOLD=$LIBS
155
156# Redhat 9, gcc 3.2, libextractor_pdf barfs if we don't check for this 155# Redhat 9, gcc 3.2, libextractor_pdf barfs if we don't check for this
157AC_CHECK_LIB(stdc++, fclose) 156AC_CHECK_LIB(stdc++, fclose)
158 157
159AC_CHECK_HEADERS(langinfo.h) 158AC_CHECK_HEADERS(langinfo.h)
160AC_CHECK_LIB(dl, dlopen)
161LIBS=$LIBSOLD 159LIBS=$LIBSOLD
162# FIXME: allow --with-oggvorbis=PFX 160# FIXME: allow --with-oggvorbis=PFX
163 161
@@ -274,9 +272,10 @@ AC_FUNC_VPRINTF
274AC_FUNC_MMAP 272AC_FUNC_MMAP
275AC_FUNC_STAT 273AC_FUNC_STAT
276AC_FUNC_ERROR_AT_LINE 274AC_FUNC_ERROR_AT_LINE
275AC_SEARCH_LIBS(dlopen, dl)
277AC_SEARCH_LIBS(shm_open, rt) 276AC_SEARCH_LIBS(shm_open, rt)
278AC_CHECK_FUNCS([mkstemp strndup munmap strcasecmp strdup strncasecmp memmove memset strtoul floor getcwd pow setenv sqrt strchr strcspn strrchr strnlen strndup ftruncate shm_open shm_unlink]) 277AC_CHECK_FUNCS([mkstemp strndup munmap strcasecmp strdup strncasecmp memmove memset strtoul floor getcwd pow setenv sqrt strchr strcspn strrchr strnlen strndup ftruncate shm_open shm_unlink])
279LE_EXTRACTOR_LIBS=$LIBS 278LE_LIB_LIBS=$LIBS
280LIBS=$LIBSOLD 279LIBS=$LIBSOLD
281 280
282AM_GNU_GETTEXT_VERSION([0.16.1]) 281AM_GNU_GETTEXT_VERSION([0.16.1])
@@ -533,7 +532,7 @@ AC_SUBST(LE_LIB_LDFLAGS)
533AC_SUBST(LE_PLUGIN_LDFLAGS) 532AC_SUBST(LE_PLUGIN_LDFLAGS)
534AC_SUBST(LE_INTLINCL) 533AC_SUBST(LE_INTLINCL)
535AC_SUBST(LE_LIBINTL) 534AC_SUBST(LE_LIBINTL)
536AC_SUBST(LE_EXTRACTOR_LIBS) 535AC_SUBST(LE_LIB_LIBS)
537 536
538AC_SUBST(CPPFLAGS) 537AC_SUBST(CPPFLAGS)
539AC_SUBST(LDFLAGS) 538AC_SUBST(LDFLAGS)