aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2009-12-16 14:45:05 +0000
committerChristian Grothoff <christian@grothoff.org>2009-12-16 14:45:05 +0000
commitdf57c70280d34506c4221980f4446aa8cce4322e (patch)
tree90d68d7d5fa527aa0a301a959e48cbd1fafbf7d3 /configure.ac
parent13fa59885862da1b6e7404852dcb547f0e113b0b (diff)
downloadlibextractor-df57c70280d34506c4221980f4446aa8cce4322e.tar.gz
libextractor-df57c70280d34506c4221980f4446aa8cce4322e.zip
updating dist code
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac79
1 files changed, 4 insertions, 75 deletions
diff --git a/configure.ac b/configure.ac
index 1f8e5eb..718ab14 100644
--- a/configure.ac
+++ b/configure.ac
@@ -458,23 +458,6 @@ AC_CHECK_LIB(gsf-1, gsf_init, AC_DEFINE(HAVE_GSF_INIT,1,[gsf_init supported]))
458AC_CHECK_PROG([HAVE_ZZUF],[zzuf], 1, 0) 458AC_CHECK_PROG([HAVE_ZZUF],[zzuf], 1, 0)
459AM_CONDITIONAL(HAVE_ZZUF, test 0 != $HAVE_ZZUF) 459AM_CONDITIONAL(HAVE_ZZUF, test 0 != $HAVE_ZZUF)
460 460
461printable=1
462AC_MSG_CHECKING([whether to enable printable extractors])
463AC_ARG_ENABLE(printable,
464 [AC_HELP_STRING([--enable-printable],[Enable printable support])
465 AC_HELP_STRING([--disable-printable],[Disable printable support])],
466 [case "$enableval" in
467 no) AC_MSG_RESULT(no)
468 printable=0
469 ;;
470 *) AC_MSG_RESULT(yes)
471 printable=1
472 ;;
473 esac],
474 [ AC_MSG_RESULT(yes)
475 printable=1])
476AM_CONDITIONAL(HAVE_PRINTABLE, test x$printable != x0)
477
478ffmpeg_enabled=0 461ffmpeg_enabled=0
479AC_MSG_CHECKING([whether to enable the FFmpeg thumbnail extractor]) 462AC_MSG_CHECKING([whether to enable the FFmpeg thumbnail extractor])
480AC_ARG_ENABLE(ffmpeg, 463AC_ARG_ENABLE(ffmpeg,
@@ -563,65 +546,16 @@ src/test/Makefile
563 546
564AX_CREATE_PKGCONFIG_INFO([libextractor.pc],,[-lextractor],[Metadata extraction library],,) 547AX_CREATE_PKGCONFIG_INFO([libextractor.pc],,[-lextractor],[Metadata extraction library],,)
565 548
566if test "x$ffmpeg_enabled" = "x1"
567then
568 AC_MSG_NOTICE([configuring FFmpeg])
569 FFMPEGARCH=""
570 if test "x$ffmpegarch" != "x"
571 then
572 FFMPEGARCH="--enable-cross-compile --arch=$ffmpegarch"
573 fi
574 cd src/plugins/ffmpeg/
575 if ! ./configure \
576 --cc="$CC" \
577 $FFMPEGARCH \
578 --prefix=/tmp \
579 --disable-optimizations \
580 --disable-mmx \
581 --disable-altivec \
582 --enable-shared \
583 --enable-swscale \
584 --enable-gpl \
585 --enable-hardcoded-tables \
586 --disable-vhook \
587 --disable-postproc \
588 --disable-network \
589 --disable-ffmpeg \
590 --disable-ffserver \
591 --disable-ffplay \
592 --disable-devices \
593 --disable-protocols \
594 --disable-bsfs \
595 --disable-parsers \
596 --disable-muxers \
597 --disable-demuxers \
598 --disable-encoders \
599 --disable-decoders \
600 --enable-encoder=png \
601 --enable-encoder=ppm \
602 --enable-decoder=bmp \
603 --enable-decoder=gif \
604 --enable-decoder=png \
605 --enable-parser=pnm
606 then
607 AC_MSG_ERROR([FFmpeg configure failed.])
608 fi
609 cd ../../../
610fi
611
612AC_OUTPUT 549AC_OUTPUT
613 550
614if test "x$exiv2" = "x0" 551if test "x$HAVE_ZLIB_TRUE" = "x#"
615then 552then
616 AC_MSG_NOTICE([NOTICE: exiv2 disabled]) 553 AC_MSG_ERROR([FATAL: zlib not found (headers not installed?)])
617fi 554fi
618 555
619 556if test "x$exiv2" = "x0"
620if test "x$printable" = "x0"
621then 557then
622 AC_MSG_NOTICE([NOTICE: printable plugins disabled]) 558 AC_MSG_NOTICE([NOTICE: exiv2 disabled])
623else
624 AC_MSG_NOTICE([NOTICE: printable plugins enabled])
625fi 559fi
626 560
627if test "x$have_gsf" != "xtrue" 561if test "x$have_gsf" != "xtrue"
@@ -646,11 +580,6 @@ then
646 AC_MSG_NOTICE([NOTICE: vorbis support disabled]) 580 AC_MSG_NOTICE([NOTICE: vorbis support disabled])
647fi 581fi
648 582
649if test "x$HAVE_ZLIB_TRUE" = "x#"
650then
651 AC_MSG_ERROR([FATAL: zlib not found (headers not installed?)])
652fi
653
654if test "x$HAVE_MPEG2_TRUE" = "x#" 583if test "x$HAVE_MPEG2_TRUE" = "x#"
655then 584then
656 AC_MSG_NOTICE([NOTICE: libmpeg2 not found (will not compile mpeg2 plugin)]) 585 AC_MSG_NOTICE([NOTICE: libmpeg2 not found (will not compile mpeg2 plugin)])