aboutsummaryrefslogtreecommitdiff
path: root/src/plugins/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-08-26 00:43:54 +0000
committerChristian Grothoff <christian@grothoff.org>2012-08-26 00:43:54 +0000
commit9982f36619684b6b089e3ed8e58739680e65ddbc (patch)
tree91771aeeac03490709eca26fc0b735f01f1ef8b3 /src/plugins/Makefile.am
parent6ce04c08ce03b9c48c6764e662b450ec4c2e004b (diff)
downloadlibextractor-9982f36619684b6b089e3ed8e58739680e65ddbc.tar.gz
libextractor-9982f36619684b6b089e3ed8e58739680e65ddbc.zip
docu updates, improvements to build system
Diffstat (limited to 'src/plugins/Makefile.am')
-rw-r--r--src/plugins/Makefile.am28
1 files changed, 15 insertions, 13 deletions
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
index 3bfca47..d55b720 100644
--- a/src/plugins/Makefile.am
+++ b/src/plugins/Makefile.am
@@ -110,9 +110,11 @@ TEST_JPEG=test_jpeg
110endif 110endif
111 111
112if HAVE_MP4 112if HAVE_MP4
113if HAVE_EXPERIMENTAL
113PLUGIN_MP4=libextractor_mp4.la 114PLUGIN_MP4=libextractor_mp4.la
114TEST_MP4=test_mp4 115TEST_MP4=test_mp4
115endif 116endif
117endif
116 118
117if HAVE_MPEG2 119if HAVE_MPEG2
118PLUGIN_MPEG=libextractor_mpeg.la 120PLUGIN_MPEG=libextractor_mpeg.la
@@ -230,6 +232,19 @@ libtest_la_LIBADD = \
230 $(top_builddir)/src/main/libextractor.la 232 $(top_builddir)/src/main/libextractor.la
231 233
232 234
235libextractor_archive_la_SOURCES = \
236 archive_extractor.c
237libextractor_archive_la_LDFLAGS = \
238 $(PLUGINFLAGS)
239libextractor_archive_la_LIBADD = \
240 -larchive
241
242test_archive_SOURCES = \
243 test_archive.c
244test_archive_LDADD = \
245 $(top_builddir)/src/plugins/libtest.la
246
247
233libextractor_deb_la_SOURCES = \ 248libextractor_deb_la_SOURCES = \
234 deb_extractor.c 249 deb_extractor.c
235libextractor_deb_la_LDFLAGS = \ 250libextractor_deb_la_LDFLAGS = \
@@ -542,19 +557,6 @@ test_sid_LDADD = \
542 $(top_builddir)/src/plugins/libtest.la 557 $(top_builddir)/src/plugins/libtest.la
543 558
544 559
545libextractor_archive_la_SOURCES = \
546 archive_extractor.c
547libextractor_archive_la_LDFLAGS = \
548 $(PLUGINFLAGS)
549libextractor_archive_la_LIBADD = \
550 -larchive
551
552test_archive_SOURCES = \
553 test_archive.c
554test_archive_LDADD = \
555 $(top_builddir)/src/plugins/libtest.la
556
557
558libextractor_thumbnailffmpeg_la_SOURCES = \ 560libextractor_thumbnailffmpeg_la_SOURCES = \
559 thumbnailffmpeg_extractor.c 561 thumbnailffmpeg_extractor.c
560libextractor_thumbnailffmpeg_la_LDFLAGS = \ 562libextractor_thumbnailffmpeg_la_LDFLAGS = \